WordPress.org

Ready to get started?Download WordPress

Forums

Not Found 404 error on one post. URGENT!!! (14 posts)

  1. malkah
    Member
    Posted 1 year ago #

    Hi

    I have a strange problem
    When I try to go to a certain post on my website, I get the Not Found 404 error.
    all other posts are OK.
    I tried deleting and reposting with the same post name but with no success.
    I tried also to save again in Permalink Settings but with no success.

    the permalink of this post is very important since lots of external inks are directed to this link:
    http://babygenderonline.com/determine-baby-gender/

    Please assist ASAP.
    thanks
    Malka

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Is the post visible in Admin -> Posts -> All Posts? What happens if you switch to the default permalink structure?

  3. malkah
    Member
    Posted 1 year ago #

    thanks for your reply

    Yes it is visible. If I click on 'view' then I can see the post correctly.
    Only when reaching from outside I get the 404 error.

    I dont want to switch to default permalink since its very important that I keep the current permalinks.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    This is part of the troubleshooting process. Please try switching to the default permalink structure temporarily.

  5. malkah
    Member
    Posted 1 year ago #

    OK I switched to default permalink.
    It doesnt seems to refresh. IE still remembers the old permalink.

  6. malkah
    Member
    Posted 1 year ago #

    Now its working OK with the default permalinks.
    what do we learn from his?

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    That there could be an issue with the way that your current server is dealing with rewritten urls. What custom permalink structure were you using previously?

  8. malkah
    Member
    Posted 1 year ago #

    post name
    http://babygenderonline.com/%postname%/

    If its a server problem, why does it affect only this post?

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    What happens if you use one of the numeric permalink structures?

  10. malkah
    Member
    Posted 1 year ago #

    Its working OK as well.

  11. alchymyth
    Forum Moderator
    Posted 1 year ago #

    why does it affect only this post?

    it might have been a conflict with a category of the same slug (determine-baby-gender) which got settled with the re-writing of the permalinks.

  12. malkah
    Member
    Posted 1 year ago #

    now I switched back to /%postname%/ and the problem returned.
    I dont know why just this post.

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    As alchymyth said, there could be a clash between this post's title and the title of an existing page, category or tag.

  14. malkah
    Member
    Posted 1 year ago #

    alchymyth, YOU ARE THE MAN!
    esmi thanks for re-emphasizing alchymyth's words again.

    It was a hidden duplicate page I didnt notice.

    THANK YOU!

    malka

Topic Closed

This topic has been closed to new replies.

About this Topic