WordPress.org

Ready to get started?Download WordPress

Forums

WP RSS Aggregator
[resolved] Not fetching feeds. (10 posts)

  1. James Laws
    The WP Ninjas
    Posted 4 months ago #

    Installed, added to feeds, they never get fetched. Settings look fine and there is no errors being reported, just no feeds. Tried fetching manually several time but nothing it doesn't work.

    ### Begin System Info ###

    ## Please include this information when posting support requests ##

    Multi-site: No

    SITE_URL: http://wpnnews.wpengine.com
    HOME_URL: http://wpnnews.wpengine.com

    Plugin Version: 4.1.3
    WordPress Version: 3.8.3

    Platform: Apple
    Browser Name: Chrome
    Browser Version: 34.0.1847.131
    User Agent String: Mozilla/5.0 (Macintosh; Intel Ma
    c OS X 10_9_2) AppleWebKit/537.3
    6 (KHTML, like Gecko) Chrome/34.
    0.1847.131 Safari/537.36

    PHP Version: 5.3.2-1ubuntu4.19
    MySQL Version: 5.5.30-30.2-log
    Web Server Info: Apache

    PHP Safe Mode: No
    PHP Memory Limit: 256M
    PHP Post Max Size: 100M
    PHP Time Limit: 3600

    WP_DEBUG: Disabled

    WP Table Prefix: Length: 3 Status: Acceptable

    Show On Front: posts
    Page On Front: #0
    Page For Posts: #0

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /var/lib/php5
    Use Cookies: On
    Use Only Cookies: On

    UPLOAD_MAX_FILESIZE: 50MB
    POST_MAX_SIZE: 100MB
    WordPress Memory Limit: 40MB
    DISPLAY ERRORS: N/A
    FSOCKOPEN: Your server supports fsockopen.

    ACTIVE PLUGINS:

    WP RSS Aggregator: 4.1.3

    DEACTIVATED PLUGINS:

    Akismet: 2.6.0

    CURRENT THEME:

    Twenty Fourteen: 1.0

    ### End System Info ###

    https://wordpress.org/plugins/wp-rss-aggregator/

  2. Mekku
    Member
    Plugin Contributor

    Posted 3 months ago #

    Hi James,

    Do you see any feed items in the Feed Preview?

    Also, how are you performing the manual fetching? From the Debugging page, or from the All Feed Sources page ('Fetch feeds" link, when hovering over a feed source in the feed source list) ?

  3. James Laws
    The WP Ninjas
    Posted 3 months ago #

    Feed preview shows the proper feeds.

    I've tried it both ways and neither seems to do anything at all.

  4. slcousin
    Member
    Posted 3 months ago #

    I am having the same problem as this.

    Feed preview fine, but no feed importing taking place

  5. Mekku
    Member
    Plugin Contributor

    Posted 3 months ago #

    Interesting.

    Are you sure all your settings accommodate the feed items you wish to import?
    Mainly, you'd want to check the "Limit" option and the "Delete feed items older than" option in the create/edit feed source page.

    The first should not be zero, while the second should be set to an age that is at least older than the age of the first feed item in the preview.

  6. James Laws
    The WP Ninjas
    Posted 3 months ago #

  7. jeangalea
    Member
    Plugin Author

    Posted 3 months ago #

    Hi James,

    I created a new site on WP Engine, added the WP RSS Aggregator plugin, added the feed from WP Mayor, and hit publish. Then I created a new page and inserted the shortcode [wp-rss-aggregator]. Everything worked fine. I left all default settings as they are.

    That's the closest I can come to setting things up as you did. Have you done anything different from what I described? If you'd like us to take a look at your installation you can email credentials to your test site to support@wprssaggregator.com

    Thanks

  8. ioannist
    Member
    Posted 3 months ago #

    Hi guys,
    I am having the same problem. I am using wordpress 3.9, feeds show up in preview but they never get fetched and the page displays "no feed items found". Checked the limit and age settings, and they are good.

    Ioannis

  9. adampenly
    Member
    Posted 3 months ago #

    I had this problem and had to do a couple things to fix it.

    1. Removed .htaccess basic authentication. My site was on a password protected staging server with basic auth, and that seemed to be causing issues.

    2. Install WP Crontrol plugin and cleared out stuck cron processes for RSS Aggregator.

    As soon as I did these steps my feeds started importing.

  10. Mekku
    Member
    Plugin Contributor

    Posted 3 months ago #

    @adampenly

    Beat me to it! haha

    It seems that under certain circumstances that I have yet to identify, some cron jobs seem to get stuck. I am not sure if this is caused by our plugin, other conflicting plugins or WordPress itself, but we will look into it.

    Try either running or deleting the cron jobs. Cron jobs marked as recurring should reschedule themselves automatically, so you don't have to worry about breaking the plugin.

    Here are the cron jobs to look for:

    wprss_fetch_all_feeds_hook
    Updates all feed sources.
    This should be marked to recur according to your update interval setting.

    wprss_fetch_single_feed_hook
    Updates a single feed source. Should have the feed source's ID as an argument.
    This should either spawn when the wprss_fetch_all_feeds_hook is run, or recurs according to the feed source's own update interval.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.