WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Not displaying a link to Next Page (21 posts)

  1. fiskbook
    Member
    Posted 2 years ago #

    I have several posts that use Next Page. Have recently moved the site over from wordpress.com to wordpress.org Have also installed a plug-in to alter the look of the "next page". But this problem existed before installing this plug in. Quite simply, it's not showing any way of navigating to the next page (eg. 1,2,3 or "next page").

  2. keesiemeijer
    moderator
    Posted 2 years ago #

    Please provide a link to a page demonstrating the problem. Is the problem in single posts with the <!--nextpage--> Quicktag in it?
    http://codex.wordpress.org/Function_Reference/wp_link_pages

    Have also installed a plug-in to alter the look of the "next page".

    Which plugin?

  3. fiskbook
    Member
    Posted 2 years ago #

    Hi,

    Thanks for responding so quickly. Yes, the problem seems to be with pages with the <!--nextpage--> in.

    This is an example page -

    http://fiskbook.com/post40/

    As you should see, there is simply no way of accessing subsequent pages.

    This is the plug-in I've installed so that it will hopefully show "1,2,3" (I don't think this plugin is anything to do with the problemn though) -

    http://wordpress.org/extend/plugins/next-page/

    At this moment, I can't even access wp-admin either.

    Regards

  4. keesiemeijer
    moderator
    Posted 2 years ago #

    Does your theme's single.php have the function wp_link_pages() inside the loop

    If not add it right after the_content();:

    <?php the_content(); ?>
    <?php wp_link_pages(); ?>
  5. keesiemeijer
    moderator
    Posted 2 years ago #

    At this moment, I can't even access wp-admin either.

    try:
    - resetting the plugins folder by using FTP or whatever file management application your host provides. Sometimes, an apparently inactive plugin can still cause problems.

    - switching to the default theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides.

  6. fiskbook
    Member
    Posted 2 years ago #

    I can't imagine it's a case of resetting the plugins to be honest.

    Got to say, for a site that is supposed to be user-friendly, wordpress seems like just the opposite a lot of the time.

    The concept of a simple blog, where you just upload posts should be just that - easy to use.

    I have done some web design, but with a simple blog, I don't really want to be bothered with anything technical.

  7. keesiemeijer
    moderator
    Posted 2 years ago #

    What happens when you try to log in?

    Resetting the plugins folder and switching to the default twenty eleven theme are basic troubleshooting steps to see where the problem comes from.

  8. fiskbook
    Member
    Posted 2 years ago #

    I am just getting error message HTTP 500.

    Have not tried on another PC yet, and won't be able to do this for another hour.

    If it is a case of resetting the plugin folders, etc. you will need to guide me through the process in layman's terms, cos I really am not used to going through the files in FTP etc.

    I am also reluctant to reset all the plugins, and very reluctant to reset the theme, so will only do this if it's absolutely necessary.

  9. keesiemeijer
    moderator
    Posted 2 years ago #

    Before we do reset the plugins folder ask your host if they have a problem on their end or what errors there are in the server error logs.

  10. fiskbook
    Member
    Posted 2 years ago #

    Ok. I am just going to check if I can log-in on another PC. If I can, then it could be a problem with the host. I think they may put an automatic lock on my IP if I have a problem logging in - have done it before with another site of mine they host, so yes, could be that.

    Thanks for your help anyway. If you're still accessible in about 45 mins, I will write again and let you know how I'm getting on.

  11. fiskbook
    Member
    Posted 2 years ago #

    Hi, No, can't login elsewhere either. Have emailed host, so will wait to hear from them I suppose.

  12. fiskbook
    Member
    Posted 2 years ago #

    Hi. My host has asked me to provide my WP login details. Slightly reluctant to do this - and could they help if I do that anyway?

  13. esmi
    Forum Moderator
    Posted 2 years ago #

    Are you still having problems logging in? Only I an access your login page.

  14. fiskbook
    Member
    Posted 2 years ago #

    Hi, Yes - can log in at last. Being advised to remove "thumb.php" from my theme, if you could let me know how to do that.

    So now, still have the problem of not being able to access subsequent pages on posts where I have inserted "next page".

    Tags are also not being displayed at the bottom of each post.

  15. fiskbook
    Member
    Posted 2 years ago #

    Hi. Removed thumb.php

    Just need help with above if possible.

  16. esmi
    Forum Moderator
    Posted 2 years ago #

    I'm sorry but as you are using a commercial theme, you need to seek support from the theme's vendors.
    http://support.woothemes.com/

  17. keesiemeijer
    moderator
    Posted 2 years ago #

    Go to wp-admin > Appearance > Editor and select your theme in the dropdown on the top right. Click "Single Post" and look if the single.php has this function: <?php wp_link_pages(); ?>.

    If it hasn't got that function it will not show the paginated pages of the post. Look for <?php the_content(); ?> or <?php the excerpt(); ?> and paste this after it: <?php wp_link_pages(); ?>. But be careful because if you make a mistake it could break your site.

    As this is a commercial theme, it's best to seek support from the theme vendors though.

  18. fiskbook
    Member
    Posted 2 years ago #

    Hurrah! It's worked - thanks v much mate. Only thing is, not sure why tags not displaying. Not essential. Could try and figure that out myself.

  19. fiskbook
    Member
    Posted 2 years ago #

    Ok. Have got everything as I'd like it for most posts, but it is different for the post on the home page - is there an easy way of changing this? Trying to work on at the moment..

  20. fiskbook
    Member
    Posted 2 years ago #

    Hi. Have found out how to get the home page the same as a single post. Thanks again for your help.

  21. ChowKaiDeng
    Member
    Posted 1 year ago #

    Thanks keesiemeijer! Have a similar problem around here and it was the <?php wp_link_pages(); ?> :D

Topic Closed

This topic has been closed to new replies.

About this Topic