WordPress.org

Ready to get started?Download WordPress

Forums

WP-Polls
[resolved] Not counting registered users votes (8 posts)

  1. biellebrunner
    Member
    Posted 7 months ago #

    For some reason, my polls don't count registered users votes.
    So what's happening is that registered users voted on the same option, but it's still showing a 0% result.
    What's the matter? Is there a way to solve this?
    Thanks.

    http://wordpress.org/plugins/wp-polls/

  2. Lester Chan
    Member
    Plugin Author

    Posted 7 months ago #

    Only registered users?
    Does guest users vote fine?
    In "Who Is Allowed To Vote?" and "Poll Logging Method:" what do you set to?

    I tried to voted on my test side using a registered user with "Who Is Allowed To Vote?" set to "Registered User and Guest" and Poll Logging Method" to "Logged By Username", it works fine for me.

  3. biellebrunner
    Member
    Posted 7 months ago #

    Yeah, only registered. When I go to the log, I can see all the votes, but on the poll result displayed on the site, the logged in users votes aren't being count.
    eg: 2 members voted on option X, with another 3 guests. And only 3 people (all guests) voted for option Y. So X has 5 votes, and Y has 3. But on the poll, it shows as if they're tied with 3 votes each.

    In my "Poll Options", I have "Registered users and guests." selected.
    In "Poll Logging Method", it was selected "Logged By Cookie and IP", and then I changed to "Logged by IP". Now I changed to "Logged By Username", cleared the cache and all, but still, registered users votes just won't count...

    We can vote just fine, but for some reason, it's just not counting the votes.
    If it helps, this is the website: http://castlefanatic.com.br

    Thanks!

  4. Lester Chan
    Member
    Plugin Author

    Posted 7 months ago #

    I see you are using W3TC, could you turn it off to see it it works in the first place, because on my site I am not using any cache.

    I have a feeling that the poll is logged since u can see it in the logs, but the results of the wp_polls is being cache by W3TC.

    Try create a new poll, voted using a registered user, and go to the DB direction using phpMyAdmin to see if the vote is correctly recorded under wp_pollsq and wp_pollsa table.

  5. biellebrunner
    Member
    Posted 7 months ago #

    *sigh* I recently changed themes, and now the whole plugin stopped working, it seems. Even logged out I can't vote anymore. Other plugings and functionalities have been affected as well. I did some searching and it seems like it might be jQuery related. I suppose this plugin uses jQuery as well...? Any clue as to what exactly might be affecting it?
    When logged in, I select the option and click on "vote", but nothing happens. When I'm logged out, I can't even see the boxes to select a vote. Settings are the same as before.

  6. Lester Chan
    Member
    Plugin Author

    Posted 7 months ago #

    Yes, it uses jQuery as well, but it should not affect other plugins/themes unless the other plugins/themes screws up the JS first (which is what happen to your site it seems. It doesn't break just polls but one of your plugin as well.

    Uncaught ReferenceError: wp_cpg_initPopUpImage is not defined castlefanatic.com.br/:470
    Uncaught ReferenceError: jQuery is not defined castlefanatic.com.br/:495
    Uncaught ReferenceError: poll_booth is not defined
  7. biellebrunner
    Member
    Posted 7 months ago #

    I know this has nothing to do with the plugin anymore, but would know (or could at least point me to) a solution to this problem? Cause I disabled every single plugin but WP-Poll, cleared the cache, and it still wouldn't work. Thanks!

  8. Lester Chan
    Member
    Plugin Author

    Posted 7 months ago #

    Sorry I am not really sure myself. On initial look it seems jQuery loads fine, but your theme does not have <?php wp_footer(); ?> in the footer.php and <?php wp_head(); ?> in the header.php. I am pretty sure of that. If that is already in, it means your cache is steal and you need to force the cache to regenerate.

    Also I would not recommend you using a caching plugin if your site is not overloaded yet.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags