WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Not being recognized as Admin when logged in (2 posts)

  1. MrJPH
    Member
    Posted 1 year ago #

    Hello,

    I have used WP for about a year now on my personal photography website, and just this weekend, began the process of setting up a new photography website, also to be powered by WP.

    I have registered my new domain, and new hosting (this time with BlueHost, whilst my personal photo site is still hosted by HostExcellence, as I have one year left with them), and have WP installed and up and running on the the website.

    I am also using ProPhoto Blogs awesome themes, and noticed while I was going in to create and setup the new website and theme, that I was not able to view the new site while in Construction Mode (where I can see the site, but visitors only see a blank page with a message of the site being under construction). I turned the Construction Mode off, and was able to view the website, but then noticed that in live view mode, I wasn't seeing any 'Edit' link on the site.

    For some reason, even though I am the only Admin, and logged in, and just created a post, when I go to view the post, it's not recognizing me as the Admin and showing me the 'Edit' option, and figuring that is why I am treated also like a visitor in Construction Mode, I am not being seeing as me, even when logged in!

    Why would this be? I hop over to my old site, and am viewed naturally as the Admin over there, and can see the 'Edit' option when viewing my site live, just not on the new site... why is that happening? Any suggestions? Did I miss something somewhere?

    Any help will be very much appreciated, as I need to work on my new site. Thank you in advance for your time and assistance.
    JPH

  2. MrJPH
    Member
    Posted 1 year ago #

    <sarcasm>Thank you for all the help to all those here on the WP Forums!</sarcasm>

    For others though, who may come up with this problem, I was helped by the awesome support at ProPhoto Blogs, who took the much appreciative time with figuring out where the issue was coming from.

    It seemed under WordPress Settings > General, all it ended up being was under the 'WordPress Address (URL)' and in the 'Site Address (URL)', the Site Addy had -

    http://www.website.com

    whilst, the WP Addy only had -

    http://website.com/wordpress

    Yep, just the missing of the 'www.' was what was the problem... once entered, my being an Admin was then somehow accepted and recognized. :-) Also, it cleared up my '.htaccess' being automatically rewritten when a change occurred, whereas before, it was also not doing that, but needing to update manually.

    So, if anyone encounters this themselves, simply go and double check that both addresses are fully entered correctly.

    Thank you again to the very helpful support at ProPhoto Blogs!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags