WordPress.org

Ready to get started?Download WordPress

Forums

NextScripts: Social Networks Auto-Poster
[resolved] Not autoposting to Twitter (5 posts)

  1. Cannor
    Member
    Posted 1 year ago #

    Hey,

    Recently, SNAP has stopped auto-posting to Twitter from my site. I've tried uninstalling and reinstalling the plugin, and changing to the alternative cron method (define('ALTERNATE_WP_CRON', true);), but neither helped.

    Then I remembered that WP_DEBUG was still true in my config, so I had a look at the (incredibly large by now) debug file and saw the following errors (I've blanked out my login name):

    [27-Feb-2013 17:00:44 UTC] PHP Notice: Undefined variable: args in /home/***/public_html/unitforward/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/nxs_functions.php on line 388
    [27-Feb-2013 17:00:44 UTC] PHP Notice: Undefined variable: logNT in /home/***/public_html/unitforward/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/nxs_functions.php on line 390
    [27-Feb-2013 17:00:49 UTC] PHP Notice: Undefined variable: uqID in /home/***/public_html/unitforward/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/inc-cl/tw.php on line 200

    Could those be the reason? If I press "Repost to Twitter" after manually publishing a post, it goes to Twitter without a problem, but the plugin won't auto-Tweet manual or scheduled posts unless I press that.

    I'd appreciate any help you can offer, as SNAP does everything I need it to do, except for this one problem. Thanks!

    http://wordpress.org/extend/plugins/social-networks-auto-poster-facebook-twitter-g/

  2. rockwildaz
    Member
    Posted 1 year ago #

    My experience as of 2.7.2 is Twitter is not auto posting nor does it post when click on the button, it just constantly says posting to twitter and it doesn't. I am trying to get 2.7.1 but not available for download.

    This only started since update to 2.7.2

  3. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    What do you have in the Log/History tab?

  4. rockwildaz
    Member
    Posted 1 year ago #

    What seems to be happening is, if the post's length is beyond 140 characters it will not post, which is logical. However, I think the plugin needs an indicator to show how many characters used. If I am missing the indicator, I apologize.

  5. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    Plugin has built in mechanism that cuts message at 140 characters. Twitter broke it recently by increasing the length of the URL, but that was fixed in 2.7.2

    So what exactly do you have in Log/History tab? Can you tell me the whole error message?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.