WordPress.org

Ready to get started?Download WordPress

Forums

MailChimp for WordPress
[resolved] Not adding to MC list from Comment Form (4 posts)

  1. jmwalker11
    Member
    Posted 4 weeks ago #

    I can successfully post a comment on my site but I do not get an opt-in email for the newsletter. I currently have first and last name as a required field in my MC list. I am not sure how to add another field to my comment form to match this. Is this the reason that the MC part of this isn't working?

    Any help would be GREATLY appreciated!

    site: raphajourney.com/blog

    https://wordpress.org/plugins/mailchimp-for-wp/

  2. Danny van Kooten
    Member
    Plugin Author

    Posted 4 weeks ago #

    Hi there,

    As long as people provide a name with at least two words, the plugin will automatically try to split this into a FNAME and LNAME field.

    Do you have double opt-in enabled and did you select a list to subscribe to in the plugin settings? If so, do you see any failed API calls in your API log in MailChimp?

  3. jmwalker11
    Member
    Posted 3 weeks ago #

    So it is working IF I enter a first and last name but I don't get an email if I only enter my first name. Is there a way to change the name box to say first and last name?

  4. Danny van Kooten
    Member
    Plugin Author

    Posted 2 weeks ago #

    Hi there,

    This depends a lot on your theme but there isn't a clear way that I know of. An easier method might be to make the "last name" field optional for your MailChimp list. You can do this by unchecking the "required?" checkbox in your MailChimp account.

    Hope that helps!

Reply

You must log in to post.

About this Plugin

About this Topic