WordPress.org

Ready to get started?Download WordPress

Forums

Not able to set up any type of contact form on my word press page (13 posts)

  1. l10sworld
    Member
    Posted 2 years ago #

    Hi there...

    I'm new to using WordPress and have been learning through tutorials. The only thing I can't seem to do is add a contact form on my contact page. I've tried every possible plugin recommended online and I've deactivated every plugin to see if there's a conflict. Still only showing [contact-form] on the contact page of . Any help would be great :)

    L10

  2. Marventus
    Member
    Posted 2 years ago #

    Hi.
    Did you try Contact Form 7? If the default shortcode provided is not working, try using do_shortcode.
    Cheers!

  3. l10sworld
    Member
    Posted 2 years ago #

    Hi Marventus...

    Is this the other code you recommended to use <?php echo do_shortcode( $content ) ?> which I got from clicking the do_shortcode hyperlink? The code contact form 7 wants me to use doesn't work still. and [do_shortcode] and <?php echo do_shortcode( $content ) ?> don't work either :(

    Thanks!
    L10

  4. Marventus
    Member
    Posted 2 years ago #

    Is this the other code you recommended to use

    <?php echo do_shortcode( $content ) ?>

    Yes, that's the one, except that you need to replace $content with the actual shortcode of your contact form. Here is an example:

    <?php echo do_shortcode('[contact-form 1 "Contact Form"]'); ?>

    Also, if you are using this PHP code in pages, posts, or widgets, you would need to enable PHP execution for the code to work. I recommend using the Exec-PHP plugin for that, along with a capability manager plugin such as Role Manager.

  5. l10sworld
    Member
    Posted 2 years ago #

    Hi Marventus....

    Not sure if I missed a step there.. but Still no go for some reason installing the Exec-PHP & Role Manager plugins and using <?php echo do_shortcode('[contact-form-7 id="359" title="Contact form 1"]'); ?>

  6. Marventus
    Member
    Posted 2 years ago #

    That's odd.
    Could you share a link to the page where your contact form should be displaying?

  7. l10sworld
    Member
    Posted 2 years ago #

    Marventus.... the contact form should be at the bottom of this page under the record label text on link: http://l10sworld.com/contact

    this is exactly everything that is on the HTML for the image, text and the contact form on the bottom

    <img class="aligncenter size-full wp-image-120" title="1011 Records & Publishing" src="http://l10sworld.com/wp-content/uploads/2011/12/1011-Records-Publishing.jpg" alt="" width="500" height="500" />

    1011 Records & Publishing
    IODA Distribution

    <?php echo do_shortcode('[contact-form-7 id="359" title="Contact form 1"]'); ?>

  8. Shyam Kumar 2012
    Member
    Posted 2 years ago #

    Hi l10sworld,
    put your shortcode into contact page.[contact-form-7 id="359" title="Contact form 1"].and update your contact form 7 plugin to its latest version.
    It will surely work!!!

  9. Marventus
    Member
    Posted 2 years ago #

    Your PHP code is being commented out as evidenced in your Contact page's source code:

    <p><!--?php echo do_shortcode('[contact-form-7 id="359" title="Contact form 1"]'); ?--></p>

    When you edit your contact page, make sure you are in HTML mode and not Visual mode so that your custom PHP code works.
    Actually, if you are going to be resorting to PHP code in your posts and pages, you might as well disable the WYSIWYG editor altogether from:

    Users --> Profile --> Visual Editor --> Disable visual editor when writing (should be checked)

  10. Marventus
    Member
    Posted 2 years ago #

    Hi. Could you make this work?

  11. l10sworld
    Member
    Posted 2 years ago #

    Hi there Marventus... I also had someone sitting with me to help me with it and the contact form still didn't show up..

  12. Marventus
    Member
    Posted 2 years ago #

    Hi.
    The problem lies in the fact that your php code is being commented out instead of actually being run. Did you follow the steps outlined above? Here's a checklist:

    1. Disable the Visual Editor (see instructions above) so as to force WP to go into HTML mode when you edit your pages and posts.
    2. Make sure you can execute PHP code inside posts, pages and widgets. This is not a default WP functionality, so you need to enable it, preferably via a plugin such as Exec-PHP in conjunction with Role Manager. You can use different ones as well if you want.
    3. Copy and paste this code to the letter into your Contact Page without pasting it into any other recipient:
    <?php echo do_shortcode('[contact-form 1 "Contact Form"]'); ?>

    Try those steps and LMK if you see any changes.

    Cheers!

  13. nicholl91
    Member
    Posted 1 year ago #

    @Marventus Genius ty sir my problems sloved :P

Topic Closed

This topic has been closed to new replies.

About this Topic