WordPress.org

Ready to get started?Download WordPress

Forums

None of my links are working (17 posts)

  1. BrooklynB
    Member
    Posted 8 years ago #

    I'm working on building a new site, and for some reason all of my links stopped working yesterday. Noone can post a comment, or click on the link to read individual posts. Could i have changed something in my php's? I'm a newbie, so i may need someone to walk me through. Thank you!

  2. Class
    Member
    Posted 8 years ago #

    Some more info would help, did you change your permalinks setup? What error messages do you get? Got a link we can see?

  3. BrooklynB
    Member
    Posted 8 years ago #

    that would help, right? the site is http://www.brooklynbodega.com. i did reconfigure the permalinks set up to be: /index.php/%year%/%monthnum%/%day%/%postname%/

    but i think my links issue started a few days after i changed the permalink...

  4. BrooklynB
    Member
    Posted 8 years ago #

    i figured it out -- i just reverted back to my old permalinks setting and it seemed to fix the problem. Any insight as to how i can reconfigure my permalinks w/out messing up my links entirely?

  5. Class
    Member
    Posted 8 years ago #

    Did you read the codex and search? There's lots of Q&A's on the permalinks issue :)

  6. muskie
    Member
    Posted 8 years ago #

    I too am experiencing this. I just upgraded to WordPress 2.0 My links now no longer work, I don't get an error, I just get the main page reloaded. This happens when I try to post a comment too.

    I looked at the options it has the third one down selected for Permalinks for me, this is Date plus title. I think I used a pretty standard permalink before, I certainly didn't change it, but the intall may have... I'll look at an old posting and see what permalink style I was using from inside the Admin interface.

  7. muskie
    Member
    Posted 8 years ago #

    I changed the permalinks to be customer /year/month/day/title/ which was option number three. This didn't seem to fix the problem. My website/blog is http://blog.muschamp.ca/ I'm giving up for the day.

    Muskie

  8. muskie
    Member
    Posted 8 years ago #

    Could it be do to the .htaccess file? The permalink structure is correct, WordPress has taken it upon itself to change it from custom to choice 2 (Date and name base). The one on the server has this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>

    # END WordPress

    I think that is what it has always have, the one that came with the distribution is blank... Any suggestions?

    PS Note I use a subdomain this cause lots of problems at first, but everything was working prior to upgrading to 2.0

  9. muskie
    Member
    Posted 8 years ago #

    Anyone Beuler?

    My blog has been blatantly busted ever since I upgraded that has been several days now...

    Muskie

  10. ulyssesr
    Member
    Posted 8 years ago #

    I had somewhat a similar problem before. I solved it by backing up first my existing .htaccess file by renaming it to something else other than .htaccess.

    Next, I logged in to WordPress and selected Options - Permalinks and then clicked on the Update Permalink Structure. WordPress supposedly re-creates the .htaccess file if it's missing.

    The reason I'm suggesting this is that your .htaccess file may be corrupted like mine was. I hope that helps.

  11. muskie
    Member
    Posted 8 years ago #

    Decent, I think this might be it, I had to do something like this before. The other huge issue for me is I'm in China and am reliant on WiFi so I don't have the internet access you want. Anything that takes over 15 minutes is hard to find time for, just keeping up on email and updating my blog is weekly struggle. I spend a lot on various foods and drinks just to use the internet.

    Muskie

  12. muskie
    Member
    Posted 8 years ago #

    Nooo. I did that, it didn't recreate the file, but I cut and pasted in the text it generated and upload it and it didn't change anything. I click on a link to an old posting and it changes the URL but it just reloads my main blog page, the most recent 10 postings. That is only thing anyone can read right now, unless they can edit old posts through admin which only I can.

    Muskie

  13. muskie
    Member
    Posted 8 years ago #

    I've tried it with and without the BEGIN # WordPress stuff and using the second option and the custom option which for me now is the second option and nothing has worked. I've regenerated my permalinks multiple times, I've tried Firefox and Opera, still no love.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>
    # END WordPress

    That is my current WordPress generated .htaccess file with the # BEGIN and # END additions

  14. muskie
    Member
    Posted 8 years ago #

    I went to a custom permalink as suggested by somebody somewhere starting with index.php/yadda/yadda/yadda/ and it works for the generated links, but the links inside my posts where I cut and pasted the old permalinks as static HTML links still don't work. Plus this changed my permalinks to be something like http://blog.muschamp.ca/index.php/2005/12/05/something-or-other/ and that is no good.

    I even tried to downgrade but that script doesn't seem to work for me. I swear nothing works for me anymore.

    Muskie

  15. muskie
    Member
    Posted 8 years ago #

    If I hack my URL to include index.php it can display my old posts. This is all well and fine but I got hundred of posts with links using my old permalinks with index.php. Surely I don't need 'index.php' other blogs don't.

    http://blog.muschamp.ca/index.php/2006/01/03/dance-dance-dance/

    Muskie

  16. muskie
    Member
    Posted 8 years ago #

    I've upgraded to WordPress 2.0.1 or at least I tried very very hard to. The internet connection is so dodgy I had to babysit my ftp program for over an hour. I ended up using a cleaner install rather than syncing.

    My permalinks still don't work nor does the date based navigation such as the previous post link on the bottom of the front page. I now get a 404. It is a pretty 404 with all my navigation and even my sidebar on it, but it isn't what I want. I will try regenerating my permalinks again to see if that helps.

  17. muskie
    Member
    Posted 8 years ago #

    Hoozah! That did it. Now I'm sure to completely dominate Google and then the world...

    Or at the very least I won't look so incompetent with so many busted links. Here is a working permalink:

    http://blog.muschamp.ca/2006/01/18/guns-germs-steel-koreans-calves-and-civilization-iii/

    Note the date is last month so it is well off my front page.

    Cheers,

    Muskie

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.