WordPress.org

Ready to get started?Download WordPress

Forums

/none at the end of url (Permalinks) (8 posts)

  1. Podd63
    Member
    Posted 2 years ago #

    Hello everybody,

    My problem :

    I crawled my website because I've too many 404 errors from google.
    I find every page is created twice : the first which is ok and the second which Url's ends with /none - this one is the 404 error.

    I really don't know where it comes from... Permalinks ? Sitemap ? Theme? ...
    If anyone have an idea, it would be nice !

    Thx in advance.
    Podd63

  2. Podd63
    Member
    Posted 2 years ago #

    I tried to deactivate every extension... None of them was responsible of the trouble.
    I found it's my theme : themkraft Custom Community.
    I've probably made a mistake by configuring it.
    Is anyone have encountered the same problem ?

  3. Talton
    Member
    Posted 2 years ago #

    This might be happening due to a CSS rule being set incorrectly.

    Example:

    background: url (none);

    In this situation your site will try to load a resource simply named 'none', which is mostly likely causing this.

  4. Stream83
    Member
    Posted 2 years ago #

    I have the same problem, and Im also using Custom Community (with my own child theme on it). I have made my own style.css file that is pretty short. I don't know how "rtl.css" actually works? I haven't find any url with none so far but I'll keep looking!

    I found the /none-problem on http://gtmetrix.com/ when I tried to find what's been slowing my site down, and the /none-problem with a 404-error turns out to be about 2,5 seconds (and thats for each page loading).

    EDIT: I found both "background-image:url(none)" and "background:url("")" in the code. Now I only have to find where to change it :) And that can be a problem with Custom Community, I don't think the structure is very logical... I'll get back when I find it!

  5. Podd63
    Member
    Posted 2 years ago #

    In Custom Community, you have to create a pixel transparent image and put it in the Theme settings>header>background img. And then the problem is off ! It's a CSS rule problem as Talton said !
    I solved this problem thanks to the help of JCircle from ThemeKraft team whose concern was really appreciated !

    Big problem, simple solution !

  6. Stream83
    Member
    Posted 2 years ago #

    Yeah, I also solved it! The problem is that in the Custom Community theme settings, they write that you should put the word "none" in the header image row if you want no header image. Instead of creating a transparent image, I just erased the word none. I think that also solved the problem (at least gtmetrix dosen't complain anymore). But your solution mabye is more effective? Im looking for ways to speed up my site, and putting nothing in the row may affect something else (or they wouldn't have the "write none"-part?).

  7. Stream83
    Member
    Posted 2 years ago #

    One last post! You got to do like Podd63 says, if you just remove "none" in the header image like I did, the theme will use Custom Communitys original header image. So the correct solution is two posts up :)

  8. PrincessL
    Member
    Posted 1 year ago #

    Thank you so much for this post and answer - I've been racking my brain to find my error ending in /none - this fixed it!!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic