WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Non WWW Path Forwards to Signup Page... (21 posts)

  1. flashpunk
    Member
    Posted 4 years ago #

    I can't seem to figure out what is happening here, my http://www.DOMAIN.com works just fine, however, if i try to access DOMAIN.com, it forwards to DOMAIN.com/wp-signup.php?new=DOMAIN.com

    Any help would be appreciated!

  2. Are you using multisite with subdomains turned on?

    Do you have anything fancy in your htaccess?

  3. SidianMSJones
    Member
    Posted 4 years ago #

    Apparently this same thing is happening at my site as well.

    - I am using WP 3.0b2 with subdomains (or directories, I forget?) turned on.
    - The only things I've changed in my htaccess are what the WP documentation has told me to get 3.0 networked sites working.

  4. Don't hijack flashpunk's post :) His issue may not be the same (and if it is, you only said "But when I change my domain name settings to take it off the site crashes."

    Please be specific in YOUR thread, with complete details as to what you did: http://wordpress.org/support/topic/396999?replies=4

  5. flashpunk
    Member
    Posted 4 years ago #

    @ipstenu: I set it up using the subdomains setting. However, it gave me some errors, something to do with my configuration - potentially not being able to display the sites using the subdomains.

    I didn't think it was related, but I assume it could be. I was going to continue looking into that issue further after I had the http://www.SITE.com working, not just the SITE.com.

    For reference - I just changed the "define( 'SUBDOMAIN_INSTALL', true );" to FALSE - and the http://www.DOMAIN.com works still (as it did), however, DOMAIN.com gives me an "Error establishing database connection" error.

    Thanks for any help!

  6. Try putting this in your .htaccess BEFORE the WordPress rules

    #redirect to www for the main site
    RewriteCond %{HTTP_HOST} ^domain\.com
    RewriteRule ^ http://www.domain.com%{REQUEST_URI} [L,R=301]
  7. flashpunk
    Member
    Posted 4 years ago #

    That worked. Thanks so much!
    I had a feeling it could be fixed with a redirect, however is this a problem with the sub domain mapping with WP 3.0?

  8. I'm honestly not sure, and I left a message for the best WPMU gurus I know about it. It strikes me as odd. My blog url is just domain.com and I redirect www. to the non-www URL (shorter = better to me) so I've never run into it.

    I THINK that if your site was installed all the way as domain.com, you'd be okay, but you'd have to play with it.

  9. flashpunk
    Member
    Posted 4 years ago #

    I currently can't get sub domain mapping working..

  10. However, it gave me some errors, something to do with my configuration - potentially not being able to display the sites using the subdomains.

    Let me be psychic. It gave you a mod_rewrite error? I saw someone else with this issue somewhere... *off to look*

    Edited to add Two things. One is that it could be your server set up. The other is that it might be the changes to the rewrite rules. Are you using the latest and greatest from 3.0? You can snag 'em from the network menu.

  11. flashpunk
    Member
    Posted 4 years ago #

    Hey, thanks for being so responsive, I really appreciate it!!

    I am using the latest nightly build.

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.SITE.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    #redirect to www for the main site
    RewriteCond %{HTTP_HOST} ^DOMAIN\.com
    RewriteRule ^ http://www.DOMAIN.com%{REQUEST_URI} [L,R=301]
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>

    Firefox is currently giving me a "Firefox can't find the server at media.DOMAIN.com." error.

  12. Do you have wildcard DNS mapping on?

    I actually don't use subdomains so this has wandered outside my purview, but at a vague recollection, you need to setup wildcard DNS mapping so that your site knows *.domain.com gets parsed by WP.

  13. I'm looking into this as well, but if you're using www in your main domain, even before you install WP, you have to make sure your server is answering properly for both it and the non-www and redirecting appropriately.

  14. Ron Rennick
    MultiSite Guru
    Posted 4 years ago #

    "I can't seem to figure out what is happening here, my http://www.DOMAIN.com works just fine, however, if i try to access DOMAIN.com, it forwards to DOMAIN.com/wp-signup.php?new=DOMAIN.com"

    If you want your install to respond to both http://www.domain.com and domain.com then change your siteurl to domain.com before enabling the network.

  15. flashpunk
    Member
    Posted 4 years ago #

    If you want your install to respond to both http://www.domain.com and domain.com then change your siteurl to domain.com before enabling the network.

    Is there a way to change this after doing it the wrong way?

  16. flashpunk
    Member
    Posted 4 years ago #

    Ok, i've got wildcard DNS Mapping turned on for my domain.

    Still no luck with the subdomain setup.

  17. you need a wildcard subdomain record both in Apache and your DNS.

  18. flashpunk
    Member
    Posted 4 years ago #

    Looks like i've got it working 100% now.
    Thanks!

  19. Ovidiu
    Member
    Posted 4 years ago #

    @andrea

    mind helping out here too?

    was upgrading a test-blog from 2.92 to 3.0 beta2, enabled multisite, the blog url was set without www

    the instructions were:

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.klub-kamikaze.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    WHY? automatically SUBDOMAIN_INSTALL set to false? I prefer TRUE
    Also why would the DOMAIN_CURRENT_SITE be with WWW?

  20. Pierre_02
    Member
    Posted 4 years ago #

    Hi all,

    no need to add extra rule in your .htaccess ;)

    Connect to phpMyAdmin and you'll find a table named wp_blogs (or any other prefix you choose).
    If you've got the redirect problem, in the field domain, normally you'll find the value www.yourdomain.com (without http:// wordpress.org transform my code...) replace it by yourdomain.com

    Enjoy, no more redirect problem :)

    Amicably,

    Pierre.

  21. Daniel Haim
    Member
    Posted 4 years ago #

    Hi everyone, I'm having the same exact problem I've tried everything above and nothing worked. @Flashpunk, I tried to install the plugin, but that didn't help me - how did you solve it?

    Pierre, I don't have that value in my wp_blog table of 'domain' could you please recommend any other solution?

Topic Closed

This topic has been closed to new replies.

About this Topic