WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
Non-SSL host problem with FORCE_SSL_ADMIN (13 posts)

  1. Antti Kuosmanen
    Member
    Posted 7 months ago #

    Hi!

    The plugin works great with redirecting the user to the SSL host side with a different url when 'Force SSL Administration' is checked in the settings and SSL host is set to the proper page. e.g. http://non-ssl.com/wp-admin would redirect nicely to https://ssl-enabled.com/wp-admin

    However, I keep getting a HTTPS certificate error due to the plugin forcing the non SSL page's wp-login.php to be https too. http://non-ssl.com/wp-admin seems to first redirect to https://non-ssl.com/wp-login.php which is causing the untrusted certificate warning. Is there any way to make wordpress redirect straight to the SSL host from http://non-ssl.com/wp-admin instead of first going to https://non-ssl.com/wp-login.php ?

    I really hope this isn't too confusing. :)

    Thanks in advance!

    http://wordpress.org/plugins/wordpress-https/

  2. mrbimble
    Member
    Posted 7 months ago #

    I have SSL forced on a couple of pages and the plugin settings set to revert back to HTTP on other pagers. But this isn't happening when the user switches from a page viewed via HTTPS and I get a certificate error message. I have tried to disable and re-enable the plugin without change. Any suggestions as to what else I might do, or is this a error of the plugin?

  3. Otto Kekäläinen
    Member
    Posted 7 months ago #

    I have the same issue. When for the site coss.fi I enabled the plugin option "force SSL" and in the field SSL host there is "coss.seravo.fi" the redirects look like this:

    $ curl -I http://coss.fi/wp-admin/
    HTTP/1.1 301 Moved Permanently
    Location: https://coss.seravo.fi/wp-admin/
    [..]
    
    $ curl -I https://coss.seravo.fi/wp-admin/
    HTTP/1.1 302 Found
    Location: https://coss.fi/wp-login.php?redirect_to=https%3A%2F%2Fcoss.seravo.fi%2Fwp-admin%2F&reauth=1
    [..]

    The first redirect is OK but then the second not. It should not at this point jump back to wrong hostname. After login the redirect again goes to the correct location https://coss.seravo.fi/...

  4. Otto Kekäläinen
    Member
    Posted 7 months ago #

    I tested removing the plugin. The same redirect stupidness presists, so it is not directly the fault of the plugin, but more like that I expected the plugin (based on that it asks the SSL host in the settings view) to handle this and disable the default WordPress wp-login.php redirect thing.

    Next I'm going to try something like this: http://wordpress.org/support/topic/wordpresscom-like-setup-ssl-problem?replies=6#post-4428213

  5. esmi
    Forum Moderator
    Posted 7 months ago #

    @Otto Kekäläinen: If you require assistance then, as per the Forum Welcome, please post your own topic.

  6. Otto Kekäläinen
    Member
    Posted 7 months ago #

    @esmi: the forum welcome states: "Unless you are using the same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme & configurations as the original poster, do not post in someone else's thread."

    As I am posting about the same issue this is the correct place to discuss it. For the same issue one thread will have all discussions and eventually the solution. Am am sure whoever wrote the forum welcome text did not aim to have same issues duplicated in multiple different discussion threads.

  7. esmi
    Forum Moderator
    Posted 7 months ago #

    So you are using the same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme & configurations as the original poster?

  8. Antti Kuosmanen
    Member
    Posted 7 months ago #

    @esmi: Yes, that's exactly the case here.

  9. esmi
    Forum Moderator
    Posted 7 months ago #

    How do you know what server the original poster is using?

  10. Also you may want to make sure you have the same revision of OpenSSL, same PEAR modules, same activated PHP modules, same cURL (if this plugin uses cURL), and same Apache2 modules and versions as the original poster. ;)

    For the same issue one thread will have all discussions and eventually the solution.

    Look, it's not that moderators don't want you to solve problems and if you're contributing to solving Zuige's issue then that's great. Fantastic in fact.

    But if you are looking for a solution to your problem then that might be something that you can better accomplish with your own topic. That's all that's being said.

    Note: Before you reply keep in mind that we're not trying to wind you up or prevent you from contributing to this topic and want to keep this conversation going forward. But please interact with Zuige to solve his problem. This is his topic after all.

  11. Back to the original topic: Zuige can you provide us with real URLs? I want to look at the SSL cert and the redirection just to level set and confirm Otto's (this Otto in the thread) steps.

  12. Otto Kekäläinen
    Member
    Posted 7 months ago #

    I ended up writing a plugin to solve this issue. @mrbimble does this plugin solve your need too?

    https://github.com/Seravo/wp-https-domain-alias

  13. Otto Kekäläinen
    Member
    Posted 7 months ago #

    Now it is wordpress.org official: http://wordpress.org/plugins/https-domain-alias/

Reply

You must log in to post.

About this Plugin

About this Topic