WordPress.org

Ready to get started?Download WordPress

Forums

Non-Roman Language support in WordPress and plugins (10 posts)

  1. still giving
    Member
    Posted 4 years ago #

    This has been raised before but has anyone worked out a work around?

    WordPress does not seem to be able to handle non-Roman languages well in themes and plugins, e.g. Chinese or Japanese when it comes to using Kanji characters instead of letters and words.

    I have seen this in themes, where designs should cut off posts by the word count, and now I also see it in plugins. Such plugins and widgets, e.g. Recent SiteWide Post, show entire posts and ignores <!--more --> type excerpts.

    Is it not possible to achieve the same results using "character count" rather than word count? Any ideas for work around?

    This is also raised here but it seems to be a WordPress problem: http://buddypress.org/forums/topic/recent-sitewide-post-shows-entire-post-ignores#post-31576.

  2. Hi,
    Japanese WordPress package includes a plugin called "WP Mutibyte Patch" to solve this issue. It's not in the plugin directory but is available from:

  3. still giving
    Member
    Posted 4 years ago #

    I will look into that and feedback.

    Are there simple English instructions for use anywhere?

    The readme.txt comes down a gobbledygook.

    Thank you.

  4. Unfortunately, I don't think there is anything written in English yet.
    So here it is :)

    1. Install and activate the plugin.
    2. In wp-config.php, find the location where WPLANG is defined.
      • Japanese = define ('WPLANG', 'ja'); - you don't have to change anything in the plugin.
      • English = define ('WPLANG', ''); - rename /wp-multibyte-patch/ext/ja to default, so it will be like /wp-multibyte-patch/ext/default
      • Other locale = define ('WPLANG', 'locale'); - rename /wp-multibyte-patch/ext/ja to match the locale defined as WPLANG. e.g. zh_CN, vi

    I hope this helps!

  5. still giving
    Member
    Posted 4 years ago #

    It looks like it may just about work.

    Hows does one control the number of characters as one does by words in English?

    I very much hope the WordPress suite improves its support for Chinese, Japanese and other languages etc.

    It is a massive market.

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    Have you read the documentation?

    WordPress in Your Language

  7. @nonegiven

    1. Find wpmp-config-sample.php in the plugin directory
    2. Duplicate the file and rename it as wpmp-config.php
    3. Change $wpmp_conf['excerpt_mblength'] value from 110 to what you want

    @Otto42
    I don't think nonegiven is talking about installing other language based WordPress. He/she is trying to write non-latin characters within English (?) install.
    e.g.
    http://core.trac.wordpress.org/ticket/8759

  8. still giving
    Member
    Posted 4 years ago #

    Thank you for confirming the issue so succinctly, nao.

    This seems to work with excerpts but not themes such as magazine themes which determine their own word count ... or have various word counts according to the modules or excerpt's position.

    That is what I am trying to do. I have no idea how to customize or apply the path to them.

    • Is it still the position in 2.9 that plugins and themes cannot be localized because their strings are not in the default WP catalog?

    Chinese, Japanese and Korean (to begin with) would be great markets for WordPress to enter and get right. I am desperate for better support of them. M$ etc have just steamed into the region and the local options are pretty dire in my opinion.

    • I make the point that in many case clients now have a legal responsibility to provide multi-lingual services and this is not really conceived of in the core of WordPress.

    Otto42: Have you read the documentation?

    WordPress in Your Language

    Yes, Otto42, please don't patronise ... your answer does not come anywhere near the problem. Do you know anything about making WordPress work with non-Latin characters ... have you tried at all?

    • Actually, problems arise not just with English installs, but also with installs in native languages, including non-Latin installs.

    It is to do with the majority of themes being Latin characters only. Particularly problems arise with theming and plugins which do cannot recognize, and do not support non-Latin characters. Whereas you might have one language plugin that works to some degree, if you combine it with another plugin it does not work.

    Where there is documentation, and there is not a lot, it is rarely in English. In this case, there is not (t looks like the readme is corrupted). Or take a look at the Japanese WP site.

    I suggest that you try making a bi- or tri-lingual WP install work sometime. Technically, it is fairly possible. Visually, as in making a theme work universally in all languages with features, it is a real problem.

    WordPress should really address it by moving all the site language elements (words rendered in browsers) ... and encouraging developers to move all the language ... out of the themes, numerous pages of code etc and into one or two editable single pages, e.g. one for front end, one for back end.

    My 2c.

  9. still giving
    Member
    Posted 4 years ago #

    I think there is another problem relating to non-Roman language when you use URL (long URLs?) containing non-Roman script. It seems to blow out the rest of the post after it.

    I will have a look at it later.

    Thanks

  10. graemethom
    Member
    Posted 3 years ago #

    Hi "still giving"

    I just posted something in a different thread which you might want to look at. I don't know if it will help though!

    http://wordpress.org/support/topic/confirmation-on-japanese-fonts-issue?replies=7

    Kind regards,
    Graeme Thom

Topic Closed

This topic has been closed to new replies.

About this Topic