WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] noindex,nofollow tags on all my pages (7 posts)

  1. cliffweathers
    Member
    Posted 2 years ago #

    I've had an inexplicable problem. My wordpress site is not set for "Private" under settings, yet the default robots.txt file had disallowed crawling of the site and I have <meta name='robots' content='noindex,nofollow' />. In addition, I have <meta name="robots" content="noindex" /> once as well.

    I was able to resolve the robots.txt problem with a workaround through a plug-in called iRobots.txt SEO, so now I have a pretty good robots.txt file that allows the crawling of the posts and pages on my site. However, I still had the meta tag problem.

    I downloaded Yoast SEO and Yoast Robots Meta to see if I could toggle posts and pages back to index,follow. But now when I go to my posts or pages listings in the administrative area, they already say "index, follow" under the "Robots Meta" heading. However, when I view the source file of any page, I still get noindex,nofollow

    I've deactivated every plug-in and nothing seems to have helped. Is there anything that I'm missing?

  2. dkotter
    Member
    Posted 2 years ago #

    Have you tried switching to the default theme, to see if it is something in your theme that is doing it? If it's not a plugin inserting the code, I'd think it would be the theme doing it, because it shouldn't be there otherwise.

  3. cliffweathers
    Member
    Posted 2 years ago #

    I just tried your suggestion. Unfortunately, it didn't work.

    Here's a list of my plug-ins:

    Copyright Proof
    Creative Commons Media Tagger
    Custom Author Byline
    Facebook Comments
    Facebook Like Box
    Feedburner Feedsmith Exttend
    Google+Plugin
    iRobots.txt SEO
    Jetpack
    nrelate Flyout
    Podcasting Plugin by TG
    Robots Meta (Yoast)
    Shareholic
    Social login
    WordPress Mobile Pack
    WordPress SEO (Yoast)
    WordPress Tweaks
    WP Google Fonts
    WP to Twitter

    I have deactivated all of them and reloaded the pages to look at source code, but to no avail.

  4. cliffweathers
    Member
    Posted 2 years ago #

    I did have a plug-in for an under construction page that I removed some time ago. Could it have left some residual code?

  5. dkotter
    Member
    Posted 2 years ago #

    I did have a plug-in for an under construction page that I removed some time ago. Could it have left some residual code?

    It's possible. You'd have to look through your files via FTP and see if you could find some leftover code. I've dealt with plugins before that don't fully uninstall when they should.

  6. cliffweathers
    Member
    Posted 2 years ago #

    I'll try, but I get all nervous and confused when I start poring through code. Would reinstalling the theme perhaps help? Would I lose all my preferences? I really spent a lot of time building this site and it would take me weeks to do it again.

  7. cliffweathers
    Member
    Posted 2 years ago #

    I'm not sure if this will help anyone else, but this is what I did. I turned off every single plug-in and then I swtiched themes. This time, the 'noindex,nofollow' disappeared.

    So I returned to the previous theme and the robots.txt file read fine without the plug-in workaround that I had needed previously. I have since re-activated each plug-in one-by-one and checked the source code of two pages. Right now, that dirty 'noindex,nofollow' has not returned. I know this sounds unlikely and not logical, but that's what worked.

Topic Closed

This topic has been closed to new replies.

About this Topic