WordPress.org

Ready to get started?Download WordPress

Forums

Noindex, Nofollow issue (6 posts)

  1. Silverzz
    Member
    Posted 1 year ago #

    Hi,

    I have my website in development currently in "Discourage search engines from indexing this site" mode.

    However the code is showing up incorrectly, looks like this ;

    <meta name='robots' content='noindex,nofollow' />

    Note the space before closing tag.

    How can I fix this, which file can I edit ?

    I noticed today that the subdirectory I added this privacy setting on has now appeared in the index, which is leading me to believe that the space in the tag could be the cause of the problem.

    How else to make sure pages are not indexed by google if this isnt the problem ?

    Just as a side question, does anyone now know how I can remove this from the index via google webmaster..

    My main website is like this - http://www.mymainwebsite.com

    The development pages are like this - dev.mymainwebsite.com

    All help would be appreciated

  2. paulwpxp
    Font hero
    Posted 1 year ago #

    I remember this trac ticket discussing the proper word to use.
    http://core.trac.wordpress.org/ticket/16416

    Regarding the space before closing tag, I do not think it's a problem. Refering to this link below, you would see it clearly that google use the one that has a space before a closing tag.

    https://developers.google.com/webmasters/control-crawl-index/docs/robots_meta_tag

    The point is that WP should consider using this as well.

    <meta name="googlebot" content="noindex" />
  3. Silverzz
    Member
    Posted 1 year ago #

    Hi Paul, thanks for your reply.

    I wonder then if it's because the words noindex and nofollow are not inside quote marks ?

    Could you please tell me how I can edit this meta tag ?

    Thanks again.

  4. paulwpxp
    Font hero
    Posted 1 year ago #

    When exactly did you turn on the "Discourage search engines from indexing this site" ? since beginning ? or just recently ?

    Don't forget that it requires that any changes will be made only after the next time Google crawl your site.

    And there is nothing wrong with WP's version of noindex tag, it's just that there is no 100% sure way to prevent SE from indexing your site.

    So there is "no need to worry" about making changes to this part of WP.

  5. Silverzz
    Member
    Posted 1 year ago #

    Hi Paul,

    That was turned on as soon as I set-up the wordpress and before any content was added, which is what worries me.

    In the websites developmet stage I really need this 'shielded' from view, do you have any other idea as to how to stop these pages being viewed by the public ?

    Thanks again.

  6. paulwpxp
    Font hero
    Posted 1 year ago #

    Password Protected plugin
    http://wordpress.org/extend/plugins/password-protected/

    You might as well, put this into head along with whatever already there.

    <meta name="googlebot" content="noindex" />

    and add robot.txt to prevent indexing as well.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.