WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Noindex for Categories is Not Working Again (4 posts)

  1. tushonline
    Member
    Posted 1 year ago #

    WordPress version: 3.5.1
    WordPress SEO version: 1.3.4.4

    I did this: Added noodp meta robots tag sitewide , Added noydir meta robots tag sitewide

    I expected the plugin to do this: Append these values in existing Robots Meta

    Instead it did this: Replaced NoIndex meta value with noodp,noydir

    And hence, my categories got indexed in Google. I think the issue is recent cause had no problem since last 4-6 months.

    I dont want to block categories from robots.

    Please see how we can resolve the matter.
    Thanks in advance

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Danielle
    Inactive
    Posted 1 year ago #

    Google will sometimes ignore the no-follow attribute, that has nothing to do with your site but more with google. about your question, you replace the no-index so no wonder that your categories get indexed. do your really understand what noydir and noodp are doing ? both has nothing to do with no-index

  3. tushonline
    Member
    Posted 1 year ago #

    Yes, it could have been the case if the plugin was successfully adding noindex robots tag as set inside settings pages and under categories meta data.

    However, this is not the case. Recently, the plugin has removed the noindex,follow tag & replaced forced setting of noodp,noydir and that's the concerning part on plugin's behavior after the upgrade.

    I think the author should look into it.

    @Author - let me know if you need more inputs to check.

    Thanks in advance

  4. Danielle
    Inactive
    Posted 1 year ago #

    Okay I understand

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic