WordPress.org

Ready to get started?Download WordPress

Forums

Kebo Twitter Feed
[resolved] Nofollow links? (14 posts)

  1. Alex Schenker
    Member
    Posted 3 months ago #

    Any chance of adding a feature to nofollow links produced by the Kebo Twitter feed in the sidebar?

    https://wordpress.org/plugins/kebo-twitter-feed/

  2. Peter Booker
    Member
    Plugin Author

    Posted 3 months ago #

    Hi Alex,

    This is a great suggestion and an option which clearly should be included. It will be coming in the next update, thanks!

  3. Alex Schenker
    Member
    Posted 3 months ago #

    That's great to hear, thanks Peter! :-)

  4. Peter Booker
    Member
    Plugin Author

    Posted 3 months ago #

    Hi Alex,

    This went live just a moment ago in the latest update (1.4.8), it took a while longer than expected. It turned out that the WP functions I was using were mostly outputting nofollow links anyway, but that my usage of wp_kses() to filter the content was stripping the rel attibutes out.

    This is all resolved now and you can control whether or not the links are nofollow from the plugins settings page. Its turned on by default to mimic the twitter websites behavior.

  5. Alex Schenker
    Member
    Posted 3 months ago #

    Fantastic Peter, thank you!!

  6. Alex Schenker
    Member
    Posted 3 months ago #

    Okay so this almost works. @links and #tag links are not tagged nofollow.

    Also, if it's possible to have a separate option to leave the main account link (@WebsiteName) with a follow, that would be ideal (since if one link is nofollowed on a page, all instances of it are ignored by search engines, and the main Twitter account link should probably not be ignored).

    Thanks!!

  7. Peter Booker
    Member
    Plugin Author

    Posted 3 months ago #

    Hi Alex,

    Thank you for pointing this out, I completely reverted a change (which added the nofollow to mentions/hashtags) by accident. I have added it back in so that these are correctly controlled by the option now too (version 1.4.10).

    The account name is slightly more difficult. I originally thought that as you could display other accounts (through Re-Tweets) I should leave this under control of the option. However, I realise their are better options:

    1) Only nofollow retweets if the option is set.

    2) Never nofollow accounts.

    3) Either of these, with an added rel="me" option too, to let search engines know its an account associated with the website.

    Which do you think is ideal?

  8. Alex Schenker
    Member
    Posted 3 months ago #

    Hi Peter,

    As far as I can tell, ideal would be 1) and 3) for the main account URL. I don't suppose it's possible to specify a URL to "follow and me" and nofollow everything else?

    Lastly, I see a couple more links that need nofollow: the /intent/ links (reply, retweet, favorite).

    Your level of support is stellar, I had posted my last request when no sooner an update popped up in our WP dashboard, and sure enough, it was you addressing this issue. Our team has never seen such WP plugin support speed! Props :-)

  9. Peter Booker
    Member
    Plugin Author

    Posted 3 months ago #

    Hi Alex,

    As you can see, I am not always so fast! Thank you though, that is very nice of you to say!

    After some nofollow research today I agree that the Intent links should be nofollow (regardless of the option?).

    It sounds like the best solution is to add rel="nofollow" to Re-Tweet account links (if the option is set) and rel="me" to normal Tweet account links.

    I will work on an update for this tonight.

  10. Alex Schenker
    Member
    Posted 3 months ago #

    May be related to all these updates, but this plugin (v1.4.11) is crashing our site now (unable to access /wp-admin/ pages if it's enabled).

  11. Peter Booker
    Member
    Plugin Author

    Posted 3 months ago #

    Hi Alex Schenker,

    That is a serious problem, and I am very sorry that the plugin has caused a fatal PHP error. Something I will never consider acceptable.

    Can you see the PHP error that caused the problem? If you can let me know what it is, I will be able to prevent it happening. I just checked the various test sites and cannot reproduce it anywhere. Which makes fixing it difficult, until I can discover the cause.

  12. Alex Schenker
    Member
    Posted 3 months ago #

    It appears to be a conflict with our theme, Sahifa (from Tielabs). And even though disabling Kebo resolves it, I'm not sure it's your plugins' fault. Would it help to give you admin access to the site?

  13. Alex Schenker
    Member
    Posted 3 months ago #

    Okay, ran some more tests and I'm pretty sure it's not your plugin. Sorry for the confusion.

  14. Peter Booker
    Member
    Plugin Author

    Posted 3 months ago #

    Hi Alex,

    Thank you for the fast response. No problem at all. Anything causing fatal PHP errors is a serious issue and I will always investigate.

    It can also be very difficult finding the root cause of some problems. I deal with the same challenge frequently!

    If you have any more problems let me know!

Reply

You must log in to post.

About this Plugin

About this Topic