WordPress.org

Ready to get started?Download WordPress

Forums

No WYSIWYG Editor in 2.1 (71 posts)

  1. healthdesk
    Member
    Posted 7 years ago #

    Our new tabbed editor allows you to switch between WYSIWYG and code editing instantly while writing a post.

    After upgrading to 2.1 everthing works fine, but I can't find a 'tabbed editor'. Just get a plain text editor.

  2. momocat
    Member
    Posted 7 years ago #

    Did you switch on visual editor on?

    User -> Your Profile

  3. spencerp
    Member
    Posted 7 years ago #

    Under your USER profile in the wp-admin, under Personal Options (located at top), make sure there is a check in the checkbox for: "Use the visual editor when writing"

    I believe this is right, I really don't use that anymore, so.. Good luck either way though! ;):)

    spencerp

  4. healthdesk
    Member
    Posted 7 years ago #

    Can't find any checkbox - is it a database thing - I switched off visual editor in 2.0.7 before updating

  5. DoomAng3l
    Member
    Posted 7 years ago #

    I have a similar issue, in that the Visual editor is on, yet all the text tools are missing, the only tools present are Bold, Italic, split post and spell check.
    None of the others are present .

    I have reinstalled and the issue remains.

  6. spencerp
    Member
    Posted 7 years ago #

    Are you sure that you've DELETED all the files, except for the wp-content/ folder, wp-config.php and .htaccess file, and then reuploaded NEW FRESH files for the 2.1 stuff?

    That includes for the files under the wp-includes/,wp-includes/js/ folders too.

    spencerp

  7. faustina
    Member
    Posted 7 years ago #

    I am having a similar problem. For me everything works correctly with rich text turned off. When I enable it I see the tabs, but they are not click-able, and there are no other buttons for formatting or anything. I Did the full install, replaced every single thing except my themes and the few important files. This problem exists with or without plugins activated.

  8. healthdesk
    Member
    Posted 7 years ago #

    After reinstallation my WYSIWYG editor finally works, but I'm back to the old problem with the linebreaks. Nor Shift+Enter neither 2 x Shift gives me a line break

  9. DoomAng3l
    Member
    Posted 7 years ago #

    Sorted!
    Reinstalled deleting the old wp install first.

  10. subiectiv
    Member
    Posted 7 years ago #

    try ctrl+f5 or shift+f5 if the only tabs in the rich editor are bold, italic, toggle and split cells. worked for me, tho insert link/image tabs have some errors. i mean, none of the X, cancel or insert buttons work.

  11. momocat
    Member
    Posted 7 years ago #

    Cleaning the browser cache helped for me too!

  12. faustina
    Member
    Posted 7 years ago #

    deleting the cache does nothing for me. No formating options show at all. The tabs between visual and code are not even click-able. I'm not sure what to do.

  13. scribbler
    Member
    Posted 7 years ago #

    In either Safari or Firefox, I can enter text only if the RTF is unchecked in my profile. With RTF unchecked, I get all the buttons but no visual/code tabs. When RTF is checked, I get only some of the buttons, I get the tabs, but they aren't clickable, and what's stranger, I cannot enter any text. I can enter the title of the post, but nothing in the body. I have reinstalled wht TinyMCE stuff, cleared my caches, everything suggested here. Nothing works.

  14. supor1t
    Member
    Posted 7 years ago #

    Make sure that all scripts in your browser are enabled.

  15. faustina
    Member
    Posted 7 years ago #

    All my scripts are enabled.

  16. scribbler
    Member
    Posted 7 years ago #

    Did that. Makes no difference.

  17. supor1t
    Member
    Posted 7 years ago #

    This might be a red herring, but I noticed I got an SSL error that initially disabled some buttons on the visual editor after I first installed 2.10. My host cleared this up and then everything worked fine. Do you see any errors when you try to load the write post or write page?

  18. scribbler
    Member
    Posted 7 years ago #

    No, I don't. Everything appears to load as designed. I've just tried it again, and get no errors.

  19. faustina
    Member
    Posted 7 years ago #

    no errors for me either.

  20. adam-pi-de
    Member
    Posted 7 years ago #

    Not only do I not have any WYSIWYG commands, or tabs to switch between writing formats, but when I attempt to save what I have written I get the following error message:

    Warning: Cannot modify header information - headers already sent by (output started at /home/p/private-intellectual.de/public_html/wp-content/advanced-cache.php:1) in /home/p/private-intellectual.de/public_html/wp-includes/pluggable.php on line 275

    Bascially this means that I cannot write and then save any new posts, which makes WP pretty redundant on the whole.

  21. supor1t
    Member
    Posted 7 years ago #

    The last thing I can think of is to restart mySQL.

    If that doesn't work, you could try a fresh WP 2.1 install in a subdir of your site. If it didn't work there, you'd know the problem is something to do with WP/server/host. If it did work, you'd know the problem has something to do your install.

  22. Samuel B
    moderator
    Posted 7 years ago #

    Deactivate all of your plugins (including Akismet)- test - reactivate one by one.

  23. faustina
    Member
    Posted 7 years ago #

    The plugins have no effect for me. I may try installing 2.1 over again, waiting on that as a last option though.

  24. scribbler
    Member
    Posted 7 years ago #

    Aha!!! Tried the plug-ins, and my problems cleared as soon as I deactivated the WYSI-WordPress plugin.

  25. faustina
    Member
    Posted 7 years ago #

    Why will nothing fix mine!!! If only it were that easy.

  26. Atta
    Member
    Posted 7 years ago #

    Yup. I'm having similar problems.

    I completely wiped everything, including the content directory and uploaded WP 2.1. I didn't have any pluggins, apart from the ones that come with the stock WP and they were all disabled anyway.

    RTF Just doesn't want to work.

    Everything else seems fine, albeit a little slow.

  27. faustina
    Member
    Posted 7 years ago #

    yes, mine is quite slow also, besides the fact that RTF doesn't work. I am glad I'm not alone in this problem at least.

  28. adam-pi-de
    Member
    Posted 7 years ago #

    Mine is still slow, however I appear to have sorted out a couple of problems. I removed (not deleted!) the wp-config.php file and up loaded a new, blank, advanced-cache.php file to wp-content then uploaded the wp-config.php file once more. This resulted in the system telling me that the wp-config.php file was already there so I had no need to re-config. The write page now appears in its full glory and I can save posts once more.

  29. Atta
    Member
    Posted 7 years ago #

    My web-host has stopped supporting the PHP command virtual(). Could this or/and the fact that PHP is now running in CGI mode be the source of the problem?

  30. AdrianusV
    Member
    Posted 7 years ago #

    I deactivated the plugins imagemanager and plain-text-paste and then my visual rich editor came back. So the plugins caused an error with tinyMCE. 2.1 now works fine.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags