WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] No web.config File? (30 posts)

  1. Koolstr
    Member
    Posted 5 years ago #

    I have wordpress up and running, but when I try to change some of the settings, it says I need to edit my web.config file because it can't. Although, there is no web.config file! What do I do?

    I host with GoDaddy, if that is of any information.

    Thanks!
    Koolstr

  2. Samuel B
    moderator
    Posted 5 years ago #

    it likely means your wp-config.php

  3. Koolstr
    Member
    Posted 5 years ago #

    If so, then where do I place it? This is what it says:

    If your web.config file were writable, we could do this automatically, but it isn’t so this is the url rewrite rule you should have in your web.config file. Click in the field and press CTRL + a to select all. Then insert this rule inside of the /<configuration>/<system.webServer>/<rewrite>/<rules> element in web.config file.

    If you temporarily make your web.config file writable for us to generate rewrite rules automatically, do not forget to revert the permissions after rule has been saved.

    Where are those tags, and where exactly do I place the code? (I'm not showing the code for obvious reasons)

  4. Samuel B
    moderator
    Posted 5 years ago #

    ahhh... chmod your .htaccess to 666 and it should accept the rewrite rules

  5. Koolstr
    Member
    Posted 5 years ago #

    This is all that is in my wp-config.php file (with my details hidden with *'s, of course):

    <?php
    /**
    * The base configurations of the WordPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information by
    * visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    *
    * This file is used by the wp-config.php creation script during the
    * installation. You don't have to use the web site, you can just copy this file
    * to "wp-config.php" and fill in the values.
    *
    * @package WordPress
    */

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '*******');

    /** MySQL database username */
    define('DB_USER', '*******');

    /** MySQL database password */
    define('DB_PASSWORD', '************');

    /** MySQL hostname */
    define('DB_HOST', '*****************************************');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    /**#@+
    * Authentication Unique Keys.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define('AUTH_KEY', 'eqD-)bCDQ^?GZBm;~=||6m~Wf/Iv`[B%~Z!(B);SG$Tk@:~JK?D4g1z:l*vo0!|D');
    define('SECURE_AUTH_KEY', 'v;9k!:Kno$;Xd*1Ut/kR1WI$J*$1!Ssh?j3ZV*HQvjhk$NF!@-rr5/YI}5u,Bi6(');
    define('LOGGED_IN_KEY', 'xqg+}..1he4g&XnOE)X,X:JOXx_>|xKorstlPQ|<$Mw#sq@u$wW7IwmpnLut+w`k');
    define('NONCE_KEY', 'UH.5,mp<WW!4 JG+ojT5HX_.}~Jq+*F*~2Th.kWGB]eBj+>k`6(7;_Q&z*@wF/R[');

    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'wp_';

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
    * language support.
    */
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    /** WordPress absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Where in this exactly am I posting the code? If you need to know, the code is:

    <rule name="wordpress" patternSyntax="Wildcard">
    <match url="*" />
    <conditions>
    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
    </conditions>
    <action type="Rewrite" url="index.php" />
    </rule>

  6. Samuel B
    moderator
    Posted 5 years ago #

    re-read my last answer

  7. Koolstr
    Member
    Posted 5 years ago #

    Your last answer is a little confusing... A little too techie for me lol. Mind explaining better or in more english? Or pointing it out for me?

    Sorry.

  8. Samuel B
    moderator
    Posted 5 years ago #

    your .htaccess file should be in the same location as your wp-config.php
    use your host file manager or ftp client to change the file permissions to 666
    http://codex.wordpress.org/Changing_File_Permissions#Using_an_FTP_Client

    if you don't see it
    http://codex.wordpress.org/Changing_File_Permissions#Unhide_the_hidden_files

  9. Koolstr
    Member
    Posted 5 years ago #

    Oh, alright.

    No invisible files show on my GoDaddy hosting server..... =/

  10. gohlkus
    Member
    Posted 5 years ago #

    You should use an FTP program instead of the web interface to find the .htaccess file then, so that you can find the invisible files. You can download Filezilla for free (among others). Once you install that, you should be able to use the username and password for your hosting account.

  11. Koolstr
    Member
    Posted 5 years ago #

    I did. Even inside, with Filezilla, I can't see it. I followed the instructions exactly, I made sure invisible files were visible. yet still, there are no invisible files on the server, and not a .htaccess file.

  12. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    @Koolstr
    A web.config file is specific to a Windows account. This means you also will not have an .htaccess file, which is only on Linux. You can add a web.config file to your hosting account manually, or you can turn on permalinks and WordPress will add this file for you and it will be writable.

  13. Koolstr
    Member
    Posted 5 years ago #

    How do I turn on/off permalinks? I only have a choice between permalinks.

    Thanks for the great explanation, though.

    Also, if I add my own web.config, what else goes in it beside for the code they tell me to put in it? Can somebody give me a sample web.config?

  14. Koolstr
    Member
    Posted 5 years ago #

    Bump.

    Can anybody help? Read my previous post please. Thanks.

  15. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    The default option is considered off. As for your question about the web.config, try this doc: http://codex.wordpress.org/Using_Permalinks

  16. Koolstr
    Member
    Posted 5 years ago #

    The document didn't help. I don't know what is supposed to be in the web.config file!

    I tried creating a web.config file and just inserted the code they gave me. It ended up breaking my entire site, so I took it off and its working like before I put it on. Obviously, it needs all of the contents of a web.config file!! Can somebody please just post me a sample, of one from their one domain?
    I even tried naming it .htaccess, and it did nothing. Right now, nothing works on my wordpress blog, except for the main page. None of it will work until I can put in this code.

    Also, is there a way to turn back off the permalinks? I just switch it back to Default?

    Help would be great.
    Thanks!

  17. iridiax
    Member
    Posted 5 years ago #

    I tried creating a web.config file and just inserted the code they gave me.
    I even tried naming it .htaccess, and it did nothing.

    Delete this .htaccess file.

    Contact your web host to see if mod_rewrite can be enabled or not.

  18. Koolstr
    Member
    Posted 4 years ago #

    I contacted them, I guess I will just have to wait to see what they say.

    In the meantime, is there any possibility that somebody can give me a copy of their web.config, in case this does not work?

  19. Koolstr
    Member
    Posted 4 years ago #

    They told me that changing my permalinks would work if I changed my server to a Linux server. So I did, but the problem is that it screwed up everything. Nothing is working properly. WordPress is running extremely slowly, and the page formatting of it is screwed up. I'm thinking of switching back to windows, as switching to Linux may have been the cause of this. But this means that I won't be able to change my permalink structure.. :(

  20. zonknz
    Member
    Posted 4 years ago #

    ahhh... chmod your .htaccess to 666 and it should accept the rewrite rules

    and then change them right back. Leave files world writable is just a bad, bad idea.

  21. Koolstr
    Member
    Posted 4 years ago #

    Okay everything seems to be running fine again, so I guess I won't switch back to Windows. The only problem I'm having still is the fact that the Admin CP is entirely deformed... Here is a screenshot of what I mean: http://tinypic.com/r/309hc8x/3

    If anybody knows what the source of the problem is or how to fix it, that would be great!!!

    Thanks again.

  22. Koolstr
    Member
    Posted 4 years ago #

    Bump?

    If you want, I can make a new topic about the new problem, as my original one is solved.

  23. iridiax
    Member
    Posted 4 years ago #

    Try refreshing the page or emptying the browser cache to see if it's a browser issue. Another possibility is that some of the WordPress core files are missing/corrupt after the move, in which case an upgrade or reinstall ("upgrade" to the same version) should fix it. This once happened to my site after a server move.

  24. Koolstr
    Member
    Posted 4 years ago #

    It still isn't fixed... I'm making a new topic about the issue. This can be closed.

    Thank you once again, for all your help.

  25. Kathy
    Member
    Posted 4 years ago #

    I was hoping I'd be able to find the answer to the web.config file. I'm in the same boat you are Koolstr. My blog is working, and I can get past the home page, but I'd like to activate Permalinks so my site is searchable by post name.

    Can anyone tell me how to create this non-existent web.config file?

    Thanks!
    Kath

  26. Kathy
    Member
    Posted 4 years ago #

    Koolstr - I found a solution to our problem!!
    You can follow my instructions here...I even added visuals! :D
    http://bit.ly/15Tbmp

    Please let me know if this solved your problem.

    Thanks and good luck!

  27. globalartwork
    Member
    Posted 4 years ago #

    That link didn't work for me - if you are still having problems, Ive stuck up an explanation as well as a web.config sample file for downloading at http://www.globalartwork.com/2009/wordpress-permalinks-on-windows-iis/

    Post back here or in the comments of that page if it didn't help :)

  28. Codeslinger
    Member
    Posted 4 years ago #

    Changing to Linux is NOT the global solution for getting WordPress to work. There are quite legitimate reasons to want/need to run IIS and .NET on the web server. It would be nice if some attempt was made to help folks in this environment who may be using it not by random choice but by actual need. Web.config is not the same as wp-config.php and servers an entirely different purpose and is what is used to specify config info to allow URL Rewrite under IIS.

  29. Codeslinger
    Member
    Posted 4 years ago #

    I got permalinks working on GoDaddy WIMP with their new grid hosting where they do not have Microsoft URLRewrite installed, thanks to an article by John Sessford. I have posted a reference to John's article, code and my GoDaddy tailored instructions at my new WP site located at http://www.49thlatitude.com/wordpress/wordpress/permalinks-on-godaddy-wimp which nicely uses the new permalinks ability. - Dave

  30. sanunewa
    Member
    Posted 4 years ago #

    i too got same problem and i solve it by this link:
    http://www.globalartwork.com/2009/wordpress-permalinks-on-windows-iis/

Topic Closed

This topic has been closed to new replies.

About this Topic