WordPress.org

Ready to get started?Download WordPress

Forums

no visual editor when writing ! (58 posts)

  1. alyas2022
    Member
    Posted 6 years ago #

    hello
    when I want to post a new article, I can't find the visual editor !!! and yes I have "use the visual editor when writing" cheked !

  2. alyas2022
    Member
    Posted 6 years ago #

    trying to fix the probelme, I just downloaded the "TinyMCE Excerpt" plugin and activated, but still can't get the visual editor !!

    please ! anyone know what should I do ?

  3. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    Just to clarify. You login, that takes you to xxx/WordPress/wp-admin/post-new.php

    When you get there you click on "Write" tab and nothing happens?

  4. alyas2022
    Member
    Posted 6 years ago #

    When I click "Write" I have the page to write a new article, but no text visual editor (the place where you clique icones to put an image, you clique "B" to bold texte )!

  5. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    If you can see the image icon, the B for bold, etc. you are in a visual editor. Is there not an area below the icons to write in? Are you at this url 'http://www.myurl.com/WordPress/wp-admin/post-new.php' ?

    BTW, I don' think had to do this . . . "I have "use the visual editor when writing" cheked !"

  6. alyas2022
    Member
    Posted 6 years ago #

    I think either you don't want to understand, either you are kidding me ! :)

    what I sead is totaly clear , I don't see the visual editor !
    I'm not so dumb to try to write something in :

    'http://www.myurl.com/wordpress/wp-admin/themes.php'
    of course Im in :
    'http://www.myurl.com/WordPress/wp-admin/post-new.php'

    I don't have the B for bold, the image icone to inser an image and all the other features.
    take a look at this image

    http://img513.imageshack.us/img513/9950/sanstitre1ql2.jpg

  7. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    Well I did want to understand. Despite what you say, "I can't find the visual editor !!! " leaves a lot of room for misunderstanding.:^)

    OK, check this post under WordPress/Support/Miscellaneous
    "WordPress Editor is making me crazy! Don't apear wysiwyg editor"

    He had a picture of the editor much like yours. In the end he solved it (26 minutes ago) and said, "the site was on a sub dir were .htaccess was OK,but the problem was on the .htaccess on the main dir :("

    Perhaps this will help you.

  8. defendthyself
    Member
    Posted 6 years ago #

    I am having the same problem. When I go to write a new post, there are 2 tabs, visual and code. The buttons that let me add links, bold, images, are all gone, and the code tab does nothing.

    It happens on every browerser on my PC and Firefox on Mac. Only Safari on a Mac will let me edit my post and show all the edit buttons. This is so frustrating as I know everyone else is using IE or Firefox on a PC and I can't. Anyone be of help?

  9. alyas2022
    Member
    Posted 6 years ago #

    Re: kmessinger

    Yes, thank you man, it did help
    unfortunatly I recently uploaded an .htaccess file to the /wp-includes/ directory, and it wasn't configured well
    thank you again :)

    Re: defendthyself

    If you have an htaccess file on your 'site.com/wp-includes/'
    just delet it !

  10. daoducquan
    Member
    Posted 6 years ago #

    I have the same error, could you please help me.
    I saw your conversation and I don't understand what is htaccess file in wp-includes directory. I cannot find any name htaccess in this directory.

  11. alyas2022
    Member
    Posted 6 years ago #

    an htaccess file is in simple words a file that you put in a folder to denie access to it by normal people, if it is not well configured, it can block some settings.

    in my case I had an .htaccess in the folder /wp-includes/ and it blocked the Tinymce (plugin responsible of visual editor) which situated in /wp-includes/js/plugins/tinymce/
    so whene I deleted it, the browser could access the folder normaly and display the rich editor....

    by defaut, there is no .htaccess in the /wp-includes/ directory, there is one in the root of your blog( puted there by your server) so I think you have something that block your brower from accessing the /wp-includes/ directory and getting the tinymce plugin, just undo you last configuration !

  12. Chris_K
    Member
    Posted 6 years ago #

    Side note: The file is actually .htaccess (note the dot at the beginning). If using an FTP client to check for files, you may have to instruct it to show hidden files.

  13. daoducquan
    Member
    Posted 6 years ago #

    Thank you for your kind support but I still cannot find the .htaccess file in wp-includes folder event I turned on the show hidden files. :(

    I think that the Smiley plugin made it happened but i uninstalled that plugin already but the error is still there.

    ???

  14. kaotic
    Member
    Posted 6 years ago #

    I am also having this same problem however there is no .htaccess file. I have confirmed this at the consol level (using "ls -la") I do have one in the root of my wordpress install that tells everything to use php5 (this webserver has php4 and 5 installed) it also contains some mod rewrite rules. I have no visual editor and the box is checked in my profile to use the visual editor.

    I experenced this after upgrading to 2.3 is there a solution or do I need to think about reverting to 2.2?

  15. Ivovic
    Member
    Posted 6 years ago #

    Kaotic, it might be as simple as the visual editor being turned off in your user options... check your own user profile and look for the checkbox at the top for the visual editor.

    Sorry to suggest something so trivial, but I always have to ask if it's plugged in... :)

  16. daoducquan
    Member
    Posted 6 years ago #

    Ivovic, we turn on this option in profile already then I ask in this forum!

  17. kaotic
    Member
    Posted 6 years ago #

    Ivovic: The editor is turned on in my profile, I noted that in my last post. this ocured after I upgraded. any other ideas?

  18. kaotic
    Member
    Posted 6 years ago #

    So far I have re uploaded my wp-includes directory, verified that the checkbox in my profile for use visual editor is checked and gone over my .htaccess file, what else can this be? I really need to get this back up and working any help wold be greatly apreciated.

  19. Chris_K
    Member
    Posted 6 years ago #

    Check web server error logs after visiting the Write Posts page. Anything show up in the logs?

  20. alyas2022
    Member
    Posted 6 years ago #

    or your files' CHMOD !
    CHMOD your /wp-includes/..../tinymce/ to 777 ( I guess)

  21. kaotic
    Member
    Posted 6 years ago #

    Okay, so after experementing with various other borswers I have narowed this issue to Safari, the visual editor works in Flock (on mac) and in IE (windows)

  22. eliZZZa
    Member
    Posted 6 years ago #

    Since I set up a new site with WP 2.3 visual editors in all my WP installations donĀ“t appear anymore. Neither WP 2.3 nor WP 2.2 (visual editor worked hasslefree in 2.2 installations before).
    Visual Editor DOES NOT APPEAR (Win XP) in
    Firefox 2.0
    IE 7.0
    Browzar 1.4

    DOES APPEAR in
    Safari 3.0.3 (Win XP)

    User Profile "use visual editor" checked. File and Folder permissions checked. No .htaccess file other than in root.

    This is very much ennoying!!! Any solution?

    Kind regards from Austria
    eliZZZa

  23. Interspike
    Member
    Posted 6 years ago #

    I had the same problem after upgrading from an older version to 2.3.

    I have no .htaccess files to be concerned about and the option to "use visual editor" was checked.

    I was able to get my editor icons to show up by doing the following:

    * Toggle (uncheck, save, check, save) the "Use Visual Editor" checkbox
    * Run "chown -R apache:root /my-wordpress-directory"

    After this, voila! Hopefully this helps others.

    WordPress is the shix. Thanks for building such a great and easy to use application. I'd love to help.

  24. theotheragentm
    Member
    Posted 6 years ago #

    The Who Sees Ads plugin 1.2.2 was giving me the problem. Version 1.3 seems to make things okay.

  25. JCSupSvc
    Member
    Posted 6 years ago #

    THANK YOU Kaotic. I've been struggling with with this problem for a while and finally wandered over here. I'd gone through every page trying to find what the problem was. Tonight, I come here and in 5 minutes find the solution (profile page, upper left, check the box) and now it's perfect.

    THANK YOU
    .

  26. Eva0607
    Member
    Posted 6 years ago #

    I was able to get my editor icons to show up by doing the following:

    * Toggle (uncheck, save, check, save) the "Use Visual Editor" checkbox
    * Run "chown -R apache:root /my-wordpress-directory"

    Interspike, could you please explain what do you mean by
    * Run "chown -R apache:root /my-wordpress-directory"?
    I am sorry but I didn't understand you and I really tried everything else-I am so frustrated ughhh
    Yesterday everything seemed fine but today when I upgraded to 3.2.1 the Editor was gone :S
    Hope you can help me

  27. clappingtree
    Member
    Posted 6 years ago #

    Good grief! "chown -R apache:root /my-wordpress-directory" looks like some Linux line command which is normally not accessible from most Web hosting account.

    Is there any other solution? My web host is asking for:

    "Can you please provide us with a step-by-step instruction and a set of login details to test it?"

  28. technophobe
    Member
    Posted 6 years ago #

    Help! My toolbar disappeared also. I have checked "use visual editor," created a new profile, decativated and reactivated all plug-ins as suggested and nothing works.

  29. susanfitzm
    Member
    Posted 6 years ago #

    I am using WordPress as a content management system for 8 people. 7 can see and use the visual editor. The 8th cannot. I had her send me screenshots. She does not have a choice between visual and code. She definitely has it turned on. How can 7 people have one experience and the 8th not. She is on a Mac Mini with OS X 3.4 using Safari. I am on a macbook using safari or firefox so I don't think that is the issue. I had her try Firefox and there was no difference. Any clues?

  30. susanfitzm
    Member
    Posted 6 years ago #

    OK, the problem might be obvious to you all, but I did solve it. The security on both Safari and Firefox was set too high. When lessened, WordPress worked on both browsers just fine.

Topic Closed

This topic has been closed to new replies.

About this Topic