WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] No version number appears for my plug-in in the directory (3 posts)

  1. RealSatisfied
    Member
    Posted 1 year ago #

    Hi,

    I presume that this is something rather simple, but I've been playing with it a while now and I'm not getting far...

    My *new* plugin - http://wordpress.org/extend/plugins/realsatisfied-widget/ has no version number in the directory.

    My readme.txt uses Stable tag: trunk

    My plugin file currently has Version: 1.3.5

    yet no version appears in the directory or on the WP.org page... and this means no updates are offered to users (right?)

    I'm sure I have something wrong, but just can't see what it is...

    I had been tagging releases, but stopped as I understood it was optional. I thought had followed Otto's steps here (http://make.wordpress.org/plugins/2012/06/09/the-plugins-directory-and-readme-txt-files/) but still nothing...

    Any assistance would be appreciated.

    thanks,

    phil

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 1 year ago #

    Should be fixed now. Newlines matter, and your file had a mix of CRLF and LF style feeds.

    When using a text editor, use one that can save consistent line endings. It doesn't matter whether the file uses the PC format (CR+LF) or Unix format (LF alone), as long as it's consistent the whole way through. A mixed set will cause weirdness.

    In your specific case, the header had a different type of newline than the rest of the file did, causing the parser to not recognize the header as multiple lines, and thus not seeing the version.

  3. RealSatisfied
    Member
    Posted 1 year ago #

    Thanks for the help - much appreciated

Topic Closed

This topic has been closed to new replies.

About this Topic