WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] No tool-tips for WordPress TinyMCEComments on 2.7.1 (10 posts)

  1. shamasis
    Member
    Posted 5 years ago #

    The tool-tips for TinyMCE buttons doe not work on WP 2.7.1. Instead, "advanced.bold_desc" is shown when we hover on "bold" button and so on...

    http://wordpress.org/extend/plugins/tinymcecomments/

  2. object81
    Member
    Posted 5 years ago #

    Same issue here. Any way the WYSISWYG Editor inside the admin-panel can be shown in the comment form?

  3. object81
    Member
    Posted 5 years ago #

    Found the bug. When TinyMCE doesn't find the correct language file, it shows the descriptor ("advanced.bold_desc"). But putting a language file in /wp-includes/js/tinymce/langs which corresponts to the language set for your blog. Like if WP has the German locale de_DE, a de.js file should be placed inside the langs folder AND ../plugins/tinymcecomments/settings.js should be configured for the same language as well, like language: 'de'

    Not sure if that applies to everyone, but it worked for me!

  4. Elfenwald
    Member
    Posted 5 years ago #

    err, object81, in case you are still around - I do not HAVE a settings.js in my plugin folder...
    make a new one and just put in one variable, or how is this supposed to work?

    I can't get this plugin to show anything else but the dreaded placeholders, and besides looking ugly, it messes up some functionality, e.g. you can't assign a target when adding a link (actually you can assign it, but it won't work...)

    Thanks for any more detailed instructions!

  5. object81
    Member
    Posted 5 years ago #

    New versions of TinyMCEComments don't have a settings.js.

    Simply rename wp-includes/js/tinymce/langs/wp-langs-en.js to wp-langs-[YOUR LOCAL].js and edit the labels. I.e. wp-langs-de.js

  6. dhoffmann
    Member
    Posted 4 years ago #

    Do you have any idea how to fix this in 2.8.4? Renaming the file didn't work. Thanks in advance.

  7. StefanMz
    Member
    Posted 4 years ago #

    Renaming the wp-langs-en.js to wp-langs-[YOUR_LOCALE].js as explained by object81 above is only the first step. Then you have to edit the file and replace all occurances of 'en' with [YOUR_LOCALE]. You'll find them at the beginning of each definition, i.e.

    tinyMCE.addI18n({en:{...

    tinyMCE.addI18n("en.advanced",{...

    tinyMCE.addI18n("en.advanced_dlg",{...

    tinyMCE.addI18n("en.media_dlg",{...

    tinyMCE.addI18n("en.wordpress",{...

    tinyMCE.addI18n("en.wpeditimage",{...

    Then you may translate the texts as you wish.

  8. dhoffmann
    Member
    Posted 4 years ago #

    Hi Stefan, even the new version didn't fix the problem. My wp-langs-de.js does not look like yours. Here's the beginning:

    tinyMCE.addI18n({de:{
    common:{
    edit_confirm:"Do you want to use the WYSIWYG mode for this textarea?",
    apply:"Apply",
    insert:"Insert",
    update:"Update",
    cancel:"Cancel",
    close:"Close",
    browse:"Browse",
    class_name:"Class",
    not_set:"-- Not set --",

  9. saharusa
    Member
    Posted 4 years ago #

    I confirm StefanMz steps, working fine on wp 2.7.1 and TinyMCEComments 0.4.8

  10. Jani Uusitalo
    Member
    Posted 4 years ago #

    I solved this by modifying the plugin so that it utilizes the core WordPress translation of TinyMCE. Thought I'd link it here to make it easier for others who want to address the problem in this way.

Topic Closed

This topic has been closed to new replies.

About this Topic