WordPress.org

Ready to get started?Download WordPress

Forums

no thumbnail image upload windows/iis (7 posts)

  1. wpiisnewbie
    Member
    Posted 8 years ago #

    No matter what size image I am uploading, the automatic thumbnail creation is not taking place. All images I have tested have the "no thumbnail" option crossed out. When I upload an image, it saves the file to the server, and adds it to the db; just no thumbnail creation at all. I have already checked the "inline-uploading.php" bits, and that's not it. I am hosting on a windows 2003/IIS 6. PHP should be the newest version. Anybody else having this problem?

  2. kstaib
    Member
    Posted 8 years ago #

    I'm having trouble uploading an image as well. All I get when I try to upload image to my website is
    "The uploaded file could not be moved to ."
    No thumbnail. Nothing. Can anyone help?

  3. rwgraeber
    Member
    Posted 8 years ago #

    You don't have the graphics library extension enabled in your Web server.

    Not sure if the settings are the same for IIS, but for Apache, I had to uncomment out the following line in my php.ini file:

    extension=php_gd2.dll

    Once that was uncommented and I restarted my Web server, thumbnails were created whenever I uploaded an image and the thumbnail choice is no longer crossed out.

  4. ladydelaluna
    Member
    Posted 8 years ago #

    Okay - after hours of searching - I finally found "my" problem here... it's actually a client's problem, and while I wish to high heaven I could switch them to Linux, I simply can't, and I'm getting no help from the hosting company whatsoever.

    "You don't have the graphics library extension enabled in your Web server.
    Not sure if the settings are the same for IIS, but for Apache, I had to uncomment out the following line in my php.ini file:
    extension=php_gd2.dll
    Once that was uncommented and I restarted my Web server..."

    Okay, so I don't know if this is IIS or Apache.
    I don't know how to access the php.ini file.
    And I don't know how to "restart my web server".

    Ugh - I've been using wordpress for over a year now, and this is the first time I've ever been forced to use it on a Windows server. Can anyone help me?

  5. thesheep
    Member
    Posted 8 years ago #

    I have the same problem - after uploading an image the 'using thumbnail' option is not available - instead it is crossed out.

    I am using Apache 2 and I have checked with phpinfo() and it says that the GD library is bundled (2.0.28 compatible). My understanding is that if GD2 is available then the thumbnail generation should work. I don't understand why it doesn't seem to be.

    Anyone have any ideas or suggestions? Thanks.

  6. thesheep
    Member
    Posted 8 years ago #

    OK I solved this issue now. It turns out from talking to the hosting company that GD2 was not properly configured (despite the fact phpinfo() seemed to say it was... but what do I know?)

  7. rbaldoma
    Member
    Posted 7 years ago #

    Hey, look at this post : http://wordpress.org/support/topic/54549?replies=14#post-355607

    I've solved the problem with this solution, changing 3 for 100.

    Look at it

Topic Closed

This topic has been closed to new replies.

About this Topic