WordPress.org

Ready to get started?Download WordPress

Forums

No text editing tools (14 posts)

  1. espenpre
    Member
    Posted 7 years ago #

    I’m having trouble with my text editing tools in the “write page” section of my wordpress admin panel. The line that should appear over the text editing window isn’t there! Any one else with this problem or any solutions? This happened when I upgraded to the 2.1 ver. I have also tried a complete re-installment!

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Disable all your plugins. Find the one that's causing the issue.

  3. espenpre
    Member
    Posted 7 years ago #

    Thanks, tried it! Nothing changed!

  4. kifo
    Member
    Posted 7 years ago #

    I was also reporting the same thing in another thread...

  5. John Keegan
    Member
    Posted 7 years ago #

    For anyone who is seeing this problem that the Visual Editor is not appearing, I have seen this as well on a number of installs. The cuplrit appears to be with the way that the TinyMCE editor is using gzip compression. I found this bug which reported a similar issue:

    http://trac.wordpress.org/ticket/3144

    And the resolution here:

    http://trac.wordpress.org/attachment/ticket/3144/3144-gzipoptoins-tinymce.patch

    worked for me. In the file wp-includes/js/tinymce/tiny_mce_gzip.php I changed the line:

    if ((in_array('gzip', $encodings) || in_array('x-gzip', $encodings) || isset($_SERVER['---------------'])) && function_exists('ob_gzhandler') && !ini_get('zlib.output_compression')) {

    to read this:

    if ((in_array('gzip', $encodings) || in_array('x-gzip', $encodings) || isset($_SERVER['---------------'])) && function_exists('ob_gzhandler') && !ini_get('zlib.output_compression') && get_settings('gzipcompression')) {

    and that immediately solved the problem: the Visual Editor appeared just as it should.

  6. espenpre
    Member
    Posted 7 years ago #

    Thank you, but this didn’t help me. I have now installed ver. 2.0.8 instead and everything works now! But thank you for your help!

  7. groovyKimo
    Member
    Posted 7 years ago #

    Hi

    Thanks a lot for this hint - it worked well for me!

    I might mention that this bug seems to be related with Norton Internet Security, as they say here:
    http://trac.wordpress.org/attachment/ticket/3144/3144-gzipoptoins-tinymce.patch

    (same as jkeegan2's link above)

    regards
    Kimo

  8. saftogvann
    Member
    Posted 7 years ago #

    Thank you jkeegan2! Finally, after hours of cursing and at least a thousand times clearing the cache it is finally there!

  9. johnedgley
    Member
    Posted 6 years ago #

    I recently installed two new 2.2s, one works perfectly but the other has no formatting buttons at all (though I'm sure they were there at first- I did post an opening article and I'm sure I'd have noticed ;).

    I've done all the recommended fixes, checking and unchecking visual editor in profile, clearing the cache and forcing reload, adding www, and even jkeegan2's fix though the file has been updated in 2.2 anyway, all to no avail.

    All I have is the two tabs (Visual and Code) and clicking on them makes no difference at all - the view shows the post with <p> tags so I assume it's the code view, but it won't change to visual. Any help will be much appreciated, though I think I'll just re-install - though by the sound of it that won't necessarily solve the problem!

  10. nextwave
    Member
    Posted 6 years ago #

    This is still broken- on some installations on my server. The fix didn't work. It's not theme or plugin related.
    I'm thinking it has something to do with update progression- if you skipped a few updates- and then applied 2.2.1- no tinyMCE.
    I could be wrong- but, I've wasted a ton of time on this- and no joy.

  11. nextwave
    Member
    Posted 6 years ago #

    I tried everything- After much screwing around- the only solution to get the visual text editor back is to reinstall 2.1.3
    You have to update the db- and then things work as they should.
    There seems to be some kind of code in the TinyMCE folder that causes problems- I will wait till 2.2.2 to try this again.

  12. yuin
    Member
    Posted 6 years ago #

    I'm having pretty much the same problem as johnedgley - I can see the two tabs, but clicking on them makes no difference as there's still no toolbar showing.
    If I turn off visual editor, it seems fine (but I'd sure prefer to have the visual editor!)

    Clearing the cache, reuploading didn't work.
    Editing the tinymce files as someone suggested didn't work.
    But it's there when I login using IE. On Firefox (my main browser) it doesn't appear at all, that toolbar. :(

    Sigh. It's really quite frustrating... So I hope that future updates will fix this problem.

  13. dissid3nt
    Member
    Posted 6 years ago #

    I had exactly the same problem but this solution solved the issue: http://wordpress.org/support/topic/123892?replies=2#post-657817

  14. zazk
    Member
    Posted 6 years ago #

    Las diferentes soluciones a este bug han sido resueltas de distintas maneras, espero que estas se resuelvan en los próximas versiones...

Topic Closed

This topic has been closed to new replies.

About this Topic