WordPress.org

Ready to get started?Download WordPress

Forums

Background Manager
No text appears when loading the blog on Chrome for the first time (6 posts)

  1. PanosK20
    Member
    Posted 5 months ago #

    Hello,

    On Chrome (and on Chrome only), when the site has been loaded for the first time, background, pictures, divs with background color or borders appear ok but not ANY of the text. The weirdest thing is that I can see the underlines for links but not the text of those links.

    I also get this warning: event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

    If I deactivate the Background Manager there is no warning and the text displays OK.

    Can anyone please help?

    Many thanks

    https://wordpress.org/plugins/background-manager/

  2. Chris Andersen
    Member
    Posted 5 months ago #

    Have the same, just not the event error.
    Only on Chrome. Switched off all other plugins.
    Only have this effect, when Background Manager (BG) is activated.
    Just deactivated BG in the meantime.

    Have the latest WP version + Twenty Twelve.
    What am I doing wrong?

  3. cwe
    Member
    Posted 5 months ago #

    I can confirm that behavior on Chrome (Windows, Android).

    The text is there, but somehow invisible - it can be marked, is then still invisible, but can be copied & pasted. If you hit a link, the next page is displayed correctly, until you reload (F5 or manually), then the problem occurs again.

    Disabling background manager immediately fixes the problem.

  4. cwe
    Member
    Posted 5 months ago #

    I did a bit debugging and found the cause of the problem. As i am not a JavaScript developer and Myatu's code is really hard to understand without working in it, following fix is not a real fix. It can break things, kill your cat and cause thermonuclear war. If you want to use, use it, but i take no responsibility for fucked up things. Make a backup.

    As far as i understand this, the disappearing text is caused by when the flux.js checks for 3d-transition compatibility. if this is true, it tries to modify the html, which, i assume gives Google Chrome some headaches -> text disappears.

    So the fix is the deactivation of the sourcecode-modification, which applies to all webkit-bases browsers. there SHOULD be no effects on other browsers like Firefox and IE.

    The fix:

    open wp-content/plugins/background-manager/resources/js/flux.js in a editor of your choice. Make a backup first.
    The code is obfuscated and in a single line, so it's readibility is bad. But that's not important, as you only add a //

    Search for the following:

    [code]
    b("head").append(f);
    [/code]

    add a // before to comment that code out. Do not change any other things.

    it should look like this:
    [code]
    //b("head").append(f);
    [/code]

    Save. Upload. Try Chrome ;)

    As said, this can break some other things. Basically, maybe 3D-Transitions will not work. Hopefully, Myatu will fix this much better ;)

  5. cwe
    Member
    Posted 5 months ago #

    Whoops, sorry, here again the code parts:

    search:

    b("head").append(f);

    add // before, should look like this

    //b("head").append(f);

  6. cwe
    Member
    Posted 5 months ago #

    Whoops #2

    Sorry, this breaks the code, it comments all the following code out.

    Here is the correct fix (this time for real):

    search:
    b("head").append(f);

    replace it with:

    /**b("head").append(f);*/

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.