WordPress.org

Ready to get started?Download WordPress

Forums

No tabs plug-ins work with my site (12 posts)

  1. dorearendil
    Member
    Posted 1 year ago #

    Hi guys,

    I'm desperate to get a simple tabs system to work on one specific page of my website. However, none of the plug-ins I install seem to work.

    I've spent quite some time fiddling around, in vain, and the developpers of all three plug-ins have been out fishing cod in Greenland for months now, so none of them reply any support messages anymore.

    I suspect a .js problem, but I have no clue how to start fixing it.
    See three 'tabtest' pages I'm working on, each of which displays the result from one of the three plug-ins:

    Could it be that my theme is loading an old version of jQuery or sth? How can I verify this?

    Cheers,
    Dorian

  2. s_ha_dum
    Member
    Posted 1 year ago #

    Could it be that my theme is loading an old version of jQuery or sth? How can I verify this?

    Install the FireFox addon JSView and you will get a neat right-click menu with all of the Javascript and CSS files listed in it. You can usually tell by the URL of the script but if not click the script and you can read the Script's header.

  3. dorearendil
    Member
    Posted 1 year ago #

    Thanks for the advice!
    I inspected the pages, but it seems the latest version of jQuery is installed already...

    Would you have any other ideas to figure out if there's a conflict anywhere (with my theme, perhaps?) and if so how to solve it?

  4. s_ha_dum
    Member
    Posted 1 year ago #

    If you enable FireBug's console you will get messages about javascript errors.

  5. dorearendil
    Member
    Posted 1 year ago #

    Hi,
    The only JS error I see is related to a Firefox plug-in, nothing within my blog...

    But There's also a warning:

    Warning: The use of getAttributeNode() is obsolete. Use GetAttribute() instead.
    Source FileĀ : http://www.meridian-online.com/wp-content/themes/seso/js/jquery-1.5.1.min.js?ver=1.5.1
    Line: 16

    Could this be the source of my issue?

  6. s_ha_dum
    Member
    Posted 1 year ago #

    Your them is loading an old version of jQuery-- about a year old. It is loading jQuery 1.5.1. JQuery is up to 1.7.2 now.

    I get this on every page load:

    jQuery("#nwpsNav-1").attr("src") is undefined
    http://www.meridian-online.com/wp-content/plugins/nwp-slideshow/js/frontend.js
    Line 62

    I'd say that is more likely to be your problem.

  7. dorearendil
    Member
    Posted 1 year ago #

    Hi,
    I updated my jQuery library to the latest version, but still no progress. It seems no plug-in using jQuery will work with this theme... WTH? This is getting depressing.

  8. s_ha_dum
    Member
    Posted 1 year ago #

    Javascript is picky. A fatal error anywhere can make all of the Javascript fail. That is why I pointed out the error in that nwp-slideshow javascript, and that is why I said that it "more likely to be your problem". Updating jQuery is fine but I am not surprised it didn't help. Disable that nwp-slideshow plugin and see what happens.

  9. 1GR3
    Member
    Posted 1 year ago #

    The same situation here :(
    any new ideas?

  10. dorearendil
    Member
    Posted 1 year ago #

    Still no joy on my side.
    Even after disabling all possible culprits among the plug-ins, I get the same results on my test pages.
    I've contacted my theme developer, but he abides by the strict life principle that once he's sold a theme, his business is done.

    So for now I work my way around this issue.
    But if you manage to solve yours, 1GR3, please do share the information!

    Cheers
    D

  11. 1GR3
    Member
    Posted 1 year ago #

    I've tried to switch themes, because this one is 3 years old custom made from the scratch but theres no luck with twenty eleven either...
    anyway, as i remember in your case there's no results at all but in mine some plugins work but it looks very chaotic and useless.
    I'll try to contact some of my friends who might know some tricks so I'll let you know if we achieve any progress!
    best regards,
    Ivo

  12. 1GR3
    Member
    Posted 1 year ago #

    Di dorearendil (and every one else stuck with this problem)!
    I found very simple solution: switch to default theme and deactivate all plugins - it will surely work! then try your theme. if it works, start activating and checking plugins one by one.
    In my case, I chose "WP UI - tabs, accordions and more" and in the end it works fine with all the other plugins. it seams that the order of activation is what matters.
    good luck, and please report me the results!
    best regards,
    Ivo

Topic Closed

This topic has been closed to new replies.

About this Topic