WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] No such file or directory Errors after move from Windows server to Linux server (11 posts)

  1. vahost
    Member
    Posted 1 year ago #

    I love your plugin, Donncha! Up until now, it's worked great on multiple sites for me. However I'm experiencing an issue now that I cannot resolve.

    After migrating from a Windows server to a Linux server, I'm getting the following errors when I try to activate WP Super Cache. (I've replaced the old and new paths with [old windows server path] and [new linux server path] for security reasons.

    Warning: include([old windows server path]\blog\wp-content\plugins\wp-super-cache/wp-cache-base.php) [function.include]: failed to open stream: No such file or directory in [new linux server path]/blog/wp-content/plugins/wp-super-cache/wp-cache.php on line 53

    Warning: include([old windows server path]\blog\wp-content\plugins\wp-super-cache/wp-cache-base.php) [function.include]: failed to open stream: No such file or directory in [new linux server path]/blog/wp-content/plugins/wp-super-cache/wp-cache.php on line 53

    Warning: include() [function.include]: Failed opening '[old windows server path]\blog\wp-content\plugins\wp-super-cache/wp-cache-base.php' for inclusion (include_path='.:/usr/services/vux/lib/php') in [new linux server path]/blog/wp-content/plugins/wp-super-cache/wp-cache.php on line 53

    Warning: include_once([old windows server path]\blog\wp-content\plugins\wp-super-cache/ossdl-cdn.php) [function.include-once]: failed to open stream: No such file or directory in [new linux server path]/blog/wp-content/plugins/wp-super-cache/wp-cache.php on line 70

    Warning: include_once() [function.include]: Failed opening '[old windows server path]\blog\wp-content\plugins\wp-super-cache/ossdl-cdn.php' for inclusion (include_path='.:/usr/services/vux/lib/php') in [new linux server path]/blog/wp-content/plugins/wp-super-cache/wp-cache.php on line 70

    Warning: Cannot modify header information - headers already sent by (output started at [new linux server path]/blog/wp-content/plugins/wp-super-cache/wp-cache.php:53) in /[new linux server path]/blog/wp-includes/option.php on line 568

    Warning: Cannot modify header information - headers already sent by (output started at [new linux server path]/blog/wp-content/plugins/wp-super-cache/wp-cache.php:53) in [new linux server path]/blog/wp-includes/option.php on line 569

    Any idea why the new plugin would be looking for the old path?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. mbrsolution
    Member
    Posted 1 year ago #

    Hello how are you? Have you tried to delete the plugin and make sure that it is completely removed from your server. Then install and activate it again? Also make sure that the browser cache is deleted as well.

    Kind regards

  3. vahost
    Member
    Posted 1 year ago #

    Yup. Tried deleting and reinstalling multiple times. I also double-checked via FTP to make sure everything deleted when I uninstalled. It did.

    Also tried using another browser (Chrome instead of Firefox) and cleared the cache. Same problem as before.

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    Remove wp-content/advanced-cache.php and wp-content/wp-cache-config.php too. The old path is saved there somewhere!

  5. vahost
    Member
    Posted 1 year ago #

    Both those files are already gone. I just did a dump of the entire database and searched it for strings beginning with c:\ but there aren't any. Any idea where else I should look?

  6. vahost
    Member
    Posted 1 year ago #

    By the way, in case I wasn't clear, c:\ was the beginning of the old Windows path.

    Also, I've verified each time that the two files you mentioned aren't there after I delete the plugin.

    However, I did notice that when I try to install and activate, the two files you mentioned do NOT get installed.

    If I try to visit the admin page for the plugin after activation, it gives me the same errors and tells me, "Cannot continue... fix previous problems and retry."

    The wp-content folder's permissions are set to 765, so that shouldn't be the problem.

  7. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    Look in wp-config.php, is that path there?

  8. vahost
    Member
    Posted 1 year ago #

    Bingo! You're brilliant. That was the problem.

    define( 'WPCACHEHOME', had the old path in it. It never updated. I deleted the line, reinstalled, and everything worked.

    Thanks Donncha!

    :)

  9. Debwork
    Member
    Posted 9 months ago #

    Thanks from me too. I moved a site using BackupBuddy and had to do the same thing.

  10. mbrsolution
    Member
    Posted 9 months ago #

    Hello @vahost, if this issue is resolved for you could you mark this support ticket as resolved.

    Kind regards

  11. vahost
    Member
    Posted 9 months ago #

    Done

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic