WordPress.org

Ready to get started?Download WordPress

Forums

WP-Piwik
[resolved] No stats coming through (10 posts)

  1. sjswarts
    Member
    Posted 1 year ago #

    G'day mate,

    First up it works on one website and works very well, thank you.

    Secondly however I host a few websites on a single server using VirtualHosts via a Control panel called ISPConfig 3.0.5

    The issue is that a completely different website (same IP) doesn't update any statistics. But all the support tests come back fine.

    *** Test 1/2: SitesManager.getSitesWithAtLeastViewAccess ***
    Using: cURL
    SSL peer verification: disabled
    User Agent:
    Call: https://swartsit.com/analytics/?module=API&method=SitesManager.getSitesWithAtLeastViewAccess&format=XML&token_auth= + TOKEN
    Result:
    HTTP/1.1 200 OK
    Date: Tue, 16 Apr 2013 16:59:12 GMT
    Server: Apache/2.2.16 (Debian)
    X-Powered-By: PHP/5.3.23-1~dotdeb.0
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Set-Cookie: PIWIK_SESSID=XXXXXXXXXXXXXXXXXXXXXXXXXXXX; path=/; secure; HttpOnly
    Vary: Accept-Encoding
    Transfer-Encoding: chunked
    Content-Type: text/xml; charset=utf-8
    
    <?xml version="1.0" encoding="utf-8" ?>
    <result>
    	<row>
    		<idsite>3</idsite>
    		<name>Clean Drum</name>
    		<main_url>http://cleandrum.com</main_url>
    		<ts_created>2012-09-05 16:14:09</ts_created>
    		<ecommerce>0</ecommerce>
    		<timezone>Australia/Perth</timezone>
    		<currency>AUD</currency>
    		<excluded_ips />
    		<excluded_parameters />
    		<excluded_user_agents />
    		<sitesearch>1</sitesearch>
    		<sitesearch_keyword_parameters />
    		<sitesearch_category_parameters />
    		<group />
    		<keep_url_fragment>0</keep_url_fragment>
    	</row>
    	<row>
    		<idsite>4</idsite>
    		<name>Coastal Finishing</name>
    		<main_url>http://coastalfinishing.com</main_url>
    		<ts_created>2012-09-26 05:41:32</ts_created>
    		<ecommerce>0</ecommerce>
    		<timezone>Australia/Perth</timezone>
    		<currency>AUD</currency>
    		<excluded_ips />
    		<excluded_parameters />
    		<excluded_user_agents />
    		<sitesearch>1</sitesearch>
    		<sitesearch_keyword_parameters />
    		<sitesearch_category_parameters />
    		<group />
    		<keep_url_fragment>0</keep_url_fragment>
    	</row>
    	<row>
    		<idsite>5</idsite>
    		<name>All About Wood</name>
    		<main_url>http://allaboutwood.com.au</main_url>
    		<ts_created>2012-10-23 08:48:50</ts_created>
    		<ecommerce>0</ecommerce>
    		<timezone>Australia/Perth</timezone>
    		<currency>AUD</currency>
    		<excluded_ips />
    		<excluded_parameters />
    		<excluded_user_agents />
    		<sitesearch>1</sitesearch>
    		<sitesearch_keyword_parameters>q,query,s,search,searchword,k,keyword</sitesearch_keyword_parameters>
    		<sitesearch_category_parameters />
    		<group />
    		<keep_url_fragment>0</keep_url_fragment>
    	</row>
    	<row>
    		<idsite>6</idsite>
    		<name>FRC-MtNasura</name>
    		<main_url>http://swartsit.com.au</main_url>
    		<ts_created>2012-11-25 05:54:41</ts_created>
    		<ecommerce>0</ecommerce>
    		<timezone>Australia/Perth</timezone>
    		<currency>AUD</currency>
    		<excluded_ips />
    		<excluded_parameters />
    		<excluded_user_agents />
    		<sitesearch>1</sitesearch>
    		<sitesearch_keyword_parameters>q,query,s,search,searchword,k,keyword</sitesearch_keyword_parameters>
    		<sitesearch_category_parameters />
    		<group />
    		<keep_url_fragment>0</keep_url_fragment>
    	</row>
    	<row>
    		<idsite>7</idsite>
    		<name>Ashscreens</name>
    		<main_url>http://ashscreens.com</main_url>
    		<ts_created>2012-11-26 04:17:40</ts_created>
    		<ecommerce>0</ecommerce>
    		<timezone>Australia/Perth</timezone>
    		<currency>AUD</currency>
    		<excluded_ips />
    		<excluded_parameters />
    		<excluded_user_agents />
    		<sitesearch>1</sitesearch>
    		<sitesearch_keyword_parameters>q,query,s,search,searchword,k,keyword</sitesearch_keyword_parameters>
    		<sitesearch_category_parameters />
    		<group />
    		<keep_url_fragment>0</keep_url_fragment>
    	</row>
    	<row>
    		<idsite>10</idsite>
    		<name>Steves Blog</name>
    		<main_url>http://www.swartsit.com/blog</main_url>
    		<ts_created>2013-04-10 15:52:27</ts_created>
    		<ecommerce>0</ecommerce>
    		<timezone>Australia/Perth</timezone>
    		<currency>AUD</currency>
    		<excluded_ips />
    		<excluded_parameters />
    		<excluded_user_agents />
    		<sitesearch>1</sitesearch>
    		<sitesearch_keyword_parameters />
    		<sitesearch_category_parameters />
    		<group />
    		<keep_url_fragment>0</keep_url_fragment>
    	</row>
    	<row>
    		<idsite>11</idsite>
    		<name>Defence of the Truth</name>
    		<main_url>http://defenceofthetruth.com</main_url>
    		<ts_created>2013-04-11 11:14:11</ts_created>
    		<ecommerce>0</ecommerce>
    		<timezone>Australia/Perth</timezone>
    		<currency>AUD</currency>
    		<excluded_ips />
    		<excluded_parameters />
    		<excluded_user_agents />
    		<sitesearch>1</sitesearch>
    		<sitesearch_keyword_parameters />
    		<sitesearch_category_parameters />
    		<group />
    		<keep_url_fragment>0</keep_url_fragment>
    	</row>
    </result>
    Time: 0.18s
    
    *** Test 2/2: SitesManager.getSitesIdFromSiteUrl ***
    Using: cURL
    SSL peer verification: disabled
    User Agent:
    Call: https://swartsit.com/analytics/?module=API&method=SitesManager.getSitesIdFromSiteUrl&url=http%3A%2F%2Fdefenceofthetruth.com&format=XML&token_auth= + TOKEN
    Result:
    HTTP/1.1 200 OK
    Date: Tue, 16 Apr 2013 16:59:12 GMT
    Server: Apache/2.2.16 (Debian)
    X-Powered-By: PHP/5.3.23-1~dotdeb.0
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Set-Cookie: PIWIK_SESSID=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX; path=/; secure; HttpOnly
    Vary: Accept-Encoding
    Transfer-Encoding: chunked
    Content-Type: text/xml; charset=utf-8
    
    <?xml version="1.0" encoding="utf-8" ?>
    <result>
    	<row>
    		<idsite>11</idsite>
    	</row>
    </result>
    Time: 0.07s

    http://wordpress.org/extend/plugins/wp-piwik/

  2. sjswarts
    Member
    Posted 1 year ago #

    Some more info:

    I do have my own blog on the same server, but I have 2 IP's that I have set one to my own blog and the other to this website I host for others.

    https://swartsit.com/blog
    http://defenceofthetruth.com

    Both are WordPress, both have latest updates, I've tried using the Admin token and tried with separate user account token - nothing works.

    Seeing that I host the website myself I can find any form of log file you would like, just let me know what you need to have.

    Regards,
    Steven Swarts
    Swarts IT

  3. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    First of all: Are you using different Piwik URLs on your sites? The Piwik URL should equal the domain configured as "trusted domain" in Piwik itself.

  4. sjswarts
    Member
    Posted 1 year ago #

    I don't quite understand by Piwik URL's, are you talking about Piwik itself the URL used to communicate with that?

    If so then yes same URL:

    https://swartsit.com/analytics/

    I also have a proper certificate verified by GeoTrust Inc.

  5. sjswarts
    Member
    Posted 1 year ago #

    I noticed on the FAQ that SSL is not supported.
    That statement conflicts with my existing WordPress Blog that works. Is this still the case or have you fixed it without updating the FAQ??

    Cheers,
    Steven Swarts

  6. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    WP-Piwik supports SSL and the FAQ is up to date. The link shown as answer to the FAQ gives all information about possible SSL problems (http://wordpress.org/support/topic/plugin-wp-piwik-https-ssl-support), e.g. invalid certificates.

    I read your first post again. Just to keep sure I understand your issue: WP-Piwik works fine (plugin running & connection, stats page is shown), but tracking itself does not work?

    A valid tracking code is shown anyway? (See page source.)

    Is Piwik itself also accessible without using SSL? (The second site does not use SSL, so the tracking code will do so, too.)

  7. sjswarts
    Member
    Posted 1 year ago #

    G'day mate,

    It seems to be working today. These are the two things I've done:

    This morning I did an update to my server - Debian 64bit - it upgraded cURL.

    Later today I was trying out different themes, but in the end I resorted back to the same theme Graphene.

    So I don't know which was responsible (I'm leaning heavily towards the cURL update) but it works fine now. As far as I can tell.

    Does this make sense to you?

    P.S. in response to what you asked - yes everything appears to be functioning correctly but the tracking does not work. I even checked the apache log responsible for the domain that hosts Piwik and it showed requests coming in from http://defenceofthetruth.com

    Apache is set to make all form of communication between my host server (with Piwik) and outside requests on port 80 be converted to 443 under https. So to answer your question no Piwik is not accessible under http only.

    I cannot see what you mean by

    The second site does not use SSL, so the tracking code will do so, too.
    I read them both to say the same thing... but I must be missing something. Do you mean that http://defenceofthetruth.com is not using SSL? Because that is the only site I see that doesn't (In relation to this question)

    Please advise.

    Thank you for your help.

    Regards,
    Steven Swarts

  8. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    Hm, no, this does not make sense... Are you using Auto Archiving (see http://piwik.org/docs/setup-auto-archiving/)? If auto archiving is not running properly, my sites don't generate any stats. Only after it is running again, all stats appear (btw. retroactive, too).

    About my "SSL-sentence": defenceofthetruth does not use SSL. So the tracking code does not use SSL as well. But if everything is working fine now, I don't think this had no bearing on your issue.

  9. sjswarts
    Member
    Posted 1 year ago #

    I had auto-archiving set by default to work with webpage requests. So on access it would archive. Now it is set to work with a cron job.

    Although that still doesn't explain why it didn't work and then did.

    Very strange. I understand that you are most likely very busy so if you wish I can mark this as closed. But if you want to further investigate I would gladly comply.

    Regards,
    Steven Swarts

  10. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    Well, I'm busy, but I'm also interested in solving this issue. :-)

    If you notice a strange plugin/Piwik behaviour again, please tell me about this. But I think there is no way to get behind its reason until everything works fine. A vicious circle, isn't it? ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic