WordPress.org

Ready to get started?Download WordPress

Forums

No smilies (21 posts)

  1. salami
    Member
    Posted 9 years ago #

    Hi,
    I activated the "convert emoticons" checkbox in my options and also installed and activated wp-grins, but there are no smilies anywhere, neither in the write-section nor in the comments. I also tried deleting and re-uploading them in binary format but that made no change. So where could I have gone wrong?

  2. salami
    Member
    Posted 9 years ago #

    No idea, anyone? :-(

  3. midori
    Member
    Posted 9 years ago #

    a) vars.php in the include folder. Is anything (any smileys) listed in the conversion table ?
    b) wp-images: are there pics in the smileys subfolder ?

  4. salami
    Member
    Posted 9 years ago #

    All smilies appear in vars.php and also in wp-images/smilies.

  5. salami
    Member
    Posted 9 years ago #

    This is the vars.php - anything wrong with it?
    [Long code removed]

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

    If you get no errors, nothing is wrong with it.
    [Above code edited]

  7. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Can we have a link to your site ?

  8. salami
    Member
    Posted 9 years ago #

  9. Mark (podz)
    Support Maven
    Posted 9 years ago #

    When you go back to the activate emoticons page, is the option still checked ?
    It looks very much like WP is not even making the effort to change them.

  10. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Well spotted Beel !:)

  11. salami
    Member
    Posted 9 years ago #

    @podz: you mean in the writing options? yes, the option is still checked.
    @beel: I see your smiley but don't really understand how you made it appear there

  12. moshu
    Member
    Posted 9 years ago #

    What Beel says: do not put the "smiley" at the beginning of the line :)

  13. salami
    Member
    Posted 9 years ago #

    I activated the wp-grins plugin - but where are these smileys?

  14. salami
    Member
    Posted 9 years ago #

    I don't see any code, podz. Is there something missing in your text?

  15. salami
    Member
    Posted 9 years ago #

    Wow, beel, it works for the comments :-)))) Thanks!!!
    And is there also a way to get them into the writing section?

  16. Beel
    Member
    Posted 9 years ago #

    Same, same.

  17. salami
    Member
    Posted 9 years ago #

    Could you just give me a hint of which file I would have to use? Please? (By the way, your calendar style looks really good)

  18. Mark (podz)
    Support Maven
    Posted 9 years ago #

    From the readme:
    "Add the clickable smilies to the post area in your admin interface.
    1. The easy way (if you are already using Quicktags, if no - why aren't you? they're great!) is to add the call in wp-admin/quicktags.php. Add this at the end of the file:
    <?php wp_grins(); ?>

  19. Beel
    Member
    Posted 9 years ago #

    I use function_exists so if I ever turn off the plugin the page does not fail to load (I actually do that with all added plugin functions).

  20. salami
    Member
    Posted 9 years ago #

    I'm not sure if I described what I meant correctly - the smileys show up in the comments ok now. But when I want to post an entry, they are not there, but they should be somewhere with the wp-grins plugin, shouldn't they?

  21. salami
    Member
    Posted 9 years ago #

    podz, I just added what you proposed in the quicktags.php and everything is like I wanted it now :-)
    Thanks to you all!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.