WordPress.org

Ready to get started?Download WordPress

Forums

no smileys :-( (20 posts)

  1. cnm
    Member
    Posted 8 years ago #

    hello all...

    I just recently installed wordpress and I have all the settings set to show smileys and I get nothing... nada... zilch

    the directory is fine... the files are fine

    I installed the file via fantastico and I've tried it in 3 differnet themes and it does not work...

    would anyone have any advice? much apprecitated...

  2. vkaryl
    Member
    Posted 8 years ago #

    You might check the permissions on the smiley folder. I don't know what they should be, but if they're only 644, you could try setting them to 666, 755, etc. and see if that helps.

    [I don't know what the permissions should be since I don't use smileys. Someone else may be along who knows.]

  3. oriecat
    Member
    Posted 8 years ago #

    Do the smilies show up as the text or just nothing?

  4. cnm
    Member
    Posted 8 years ago #

    hey there vkaryi... permissions are set to 755

    and hello oriecat... all I get is the text

  5. Firefox or IE? IE will display a red X if it's a broken image, FF will display the ALT text. View the source, if it is trying to display the image but it's just a 404, then check your smilies path and etc.

    If it truely is just displaying text, then double check your smilie aliases (i.e. :) to grin.gif or whatever).

  6. cnm
    Member
    Posted 8 years ago #

    thank you for the input Viper... I mostly work in FF but viewed in IE and it is just showing the text

    how would I go about checking the smiley aliases? in other words, check that the path is true and make sure the tag for the smiley matches the graphic... correct? where would I find the code pertaining to the smileys?

    basically I am giving myself a crash course in wordpress world for future reference and I am new to including smileys in code (I have never typed the word "smiley" so much in my life)

  7. You can either edit /wp-includes/vars.php or even better, add something like this to your wp-config.php:

    $wpsmiliestrans = array(
    ' :)' => 'icon_smile.gif',
    ' :D' => 'icon_biggrin.gif',
    ' :-D' => 'icon_biggrin.gif',
    ':grin:' => 'icon_biggrin.gif',
    ' :)' => 'icon_smile.gif',
    ' :-)' => 'icon_smile.gif',
    ':smile:' => 'icon_smile.gif',
    ' :(' => 'icon_sad.gif',
    ' :-(' => 'icon_sad.gif',
    ':sad:' => 'icon_sad.gif',
    ' :o' => 'icon_surprised.gif',
    ' :-o' => 'icon_surprised.gif',
    ':eek:' => 'icon_surprised.gif',
    ' 8O' => 'icon_eek.gif',
    ' 8-O' => 'icon_eek.gif',
    ':shock:' => 'icon_eek.gif',
    ' :?' => 'icon_confused.gif',
    ' :-?' => 'icon_confused.gif',
    ' :???:' => 'icon_confused.gif',
    ' 8)' => 'icon_cool.gif',
    ' 8-)' => 'icon_cool.gif',
    ':cool:' => 'icon_cool.gif',
    ':lol:' => 'icon_lol.gif',
    ' :x' => 'icon_mad.gif',
    ' :-x' => 'icon_mad.gif',
    ':mad:' => 'icon_mad.gif',
    ' :P' => 'icon_razz.gif',
    ' :-P' => 'icon_razz.gif',
    ':razz:' => 'icon_razz.gif',
    ':oops:' => 'icon_redface.gif',
    ':cry:' => 'icon_cry.gif',
    ':evil:' => 'icon_evil.gif',
    ':twisted:' => 'icon_twisted.gif',
    ':roll:' => 'icon_rolleyes.gif',
    ':wink:' => 'icon_wink.gif',
    ' ;)' => 'icon_wink.gif',
    ' ;-)' => 'icon_wink.gif',
    ':!:' => 'icon_exclaim.gif',
    ':?:' => 'icon_question.gif',
    ':idea:' => 'icon_idea.gif',
    ':arrow:' => 'icon_arrow.gif',
    ' :|' => 'icon_neutral.gif',
    ' :-|' => 'icon_neutral.gif',
    ':neutral:' => 'icon_neutral.gif',
    ':mrgreen:' => 'icon_mrgreen.gif',
    );

    And your smilies should be in /wp-images/smilies/.

  8. cnm
    Member
    Posted 8 years ago #

    :-(

    this is odd... I cut and pasted the exact block of code from the var file to the config file and nothing has changed

  9. Ming
    Member
    Posted 8 years ago #

    If the smilies are showing up as text check that you have the 'Convert emoticons like :-) and :-P to graphics on display' under Options -> Write

  10. cnm
    Member
    Posted 8 years ago #

    hello Ming... this box is checked in the options section

  11. Ming
    Member
    Posted 8 years ago #

    Coolio.

    Can we get a link to your test site? That'll help us troubleshoot.

    I'm off for the night but I'll check back tomorrow to see if a solution has been posted.

  12. cnm
    Member
    Posted 8 years ago #

    the anti-smiley place

    thanks folks... I am off as well but will check back in the afternoon

    ciao

  13. That is really weird. Your smilies directory is fine: http://cnm.eotsmedia.com/wp-images/smilies/

    My guess is that somehow the option is not being set right.

    May I suggest installing WP yourself and not via a 3rd party script? Always best to do these things yourself with the official installer.

  14. Ming
    Member
    Posted 8 years ago #

    Looks like a bug? Try putting a space before your smilies.

    It looks like they need a space before to match the conversion. That works unless your smilie is the first thing on a line. If someone confirms I'll file a bug report.

  15. cnm
    Member
    Posted 8 years ago #

    ho-ho! Gold star to Ming for pointing out the issue... I went into the variables file and removed the spaces...

    thank you kindly for pointing this out... in a why it is sort of a fluke that we came across this bug as most people will use smileys in a sentence rather then how I was testing them... thanks again

    moving right along...

  16. Beel
    Member
    Posted 8 years ago #

    Sorry I came in late on this one as there have been threads on this issue going back over a year. Smilies will not work if they are the first item in a paragraph.,,

    :) will not work
    will work :)
    also:
    :smile: will work

    Edit: Just did a quickie search:
    http://wordpress.org/support/topic/23847
    http://wordpress.org/support/topic/15822#post-91372
    (the second one used to have my explanation as to why smilies wouldn't work at the beginning of the line, but apparently those posts, though referenced by others, went missing, too ;-)

  17. cnm
    Member
    Posted 8 years ago #

    hey Beel... it's cool, nothing like figuring something out as a group anyway

    thanks!

  18. D'oh, totally did not think of that. lol

  19. way2kool
    Member
    Posted 7 years ago #

    I am having problems with my smiley's showing a red x. I have tried different steps that was mention above but nothing is working. I am very new to all of this though.

    The smiley are in the image folder. I tried taking spaces out of the var. and putting them in and this did not help either. I tried coping the codes mention above and that didn't work.

    When I go to view the smiley's in the image folder they work fine just not on the word press site. all x they work if you use them but how can I get the images to show up and not the x.

    I have a check mark in the options

    Patty

  20. oncidium
    Member
    Posted 7 years ago #

    I'm still having this same problem Patty! I have searched and searched and tried almost everything but still don't have the answer after a couple of months. I use wp-grins and did the steps listed here: http://www.tamba2.org.uk/wordpress/smilies/ to no avail. All of this started after the 2.0 upgrade :(

Topic Closed

This topic has been closed to new replies.

About this Topic