WordPress.org

Ready to get started?Download WordPress

Forums

No rss feed (14 posts)

  1. asfodel
    Member
    Posted 5 years ago #

    My feed has stopped working. If you go to the feed url, it doesn't show the most recent posts. I'm using the Feedburner plugin, but deactivating it doesn't seem to help either.

    Feedburner gives me this error message:
    -------------
    Identify Feed Source

    The feed URL you entered is:

    http://nothingwrongwithme.com/?feed=rss

    We could not find a valid feed at that address. Here are some possible reasons this might have happened:

    *

    Is the feed valid? Confirm its validity now.
    ---------------------

    When I click on it, it does confirm the validity of the feed, but the feed is not updated with the newest posts.

    I noticed a few days ago that it hadn't updated in about a month, so a I had gone into Feedburner and had to re-sign up, and then it updated itself, but not since.

    The people who read my site tend not to use rss, so it's not a huge issue, but it means my posts don't appear on google in a timely way either, nor in google blogs.

  2. asfodel
    Member
    Posted 5 years ago #

    It works now, mysteriously. I had to set it up again, for the third time, as if the feed had never existed.

  3. asfodel
    Member
    Posted 5 years ago #

    Doesn't work again. I don't know where to look for the problem. Any advice at all?

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Your actual feed address should be this:
    http://nothingwrongwithme.com/?feed=rss2

  5. asfodel
    Member
    Posted 5 years ago #

    Thanks for the reply.

    Both http://nothingwrongwithme.com/?feed=rss2 and http://nothingwrongwithme.com/?feed=rss should be my feeds.

    Neither one works, though both will validate. They are not being automatically updated. (Nor do I know how to update them manually, or I would.)

  6. asfodel
    Member
    Posted 5 years ago #

    It's now giving me anew error message:

    Bang! Kapowww! Krakkk!
    (FeedBurner encountered an error while trying to bring you this feed and is now keeping its head down. Details follow.)

    Feed Address: http://feeds.feedburner.com/nothingwrongwithme/wEri

    HTTP Error Code: 500

    Detail: There was a problem retrieving the feed: java.net.SocketTimeoutException: connect timed out
    What can I do about this?

    * The issue you encountered may be temporary. If it persists after you reload this page, please click the button below to report it to us:

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Both http://nothingwrongwithme.com/?feed=rss2 and http://nothingwrongwithme.com/?feed=rss should be my feeds.

    No, the first one is correct, the second one is not. The feed=rss is the old style RSS 0.92 feed, which lacks most everything. You need to use the RSS2 feed, all the time. Especially with feedburner.

    Also, you need to upgrade away from WordPress 2.1 as soon as possible, and you might want to turn on "Full Text" in your feeds as well, on the Reading configuration screen.

  8. asfodel
    Member
    Posted 5 years ago #

    Okay, but regardless, the feed doesn't work. I've been using both,and neither one works.

    And yes I should upgrade. :)

  9. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    No, your feed does work. I pulled it up using the feed validator before and it worked fine.

  10. asfodel
    Member
    Posted 5 years ago #

    It works intermittently. It's now fixed itself, like it did two days ago when I wrote:

    It works now, mysteriously. I had to set it up again, for the third time, as if the feed had never existed.

    But I don't know if it will last, since it didn't last before.

    Yes, it has always passed validation, but it didn't update when new posts were posted, which is the whole purpose of a feed, right? Hence, it didn't work!

    It didn't update at all (i.e. there were no new posts listed if you looked at the feed) for the entire month of August.

    Thanks for answering my posts. I do appreciate it.

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    It didn't update at all (i.e. there were no new posts listed if you looked at the feed) for the entire month of August.

    The WordPress feed does not "update" on some sort of schedule. It's generated on the fly, at the time you request it, just like every other page. So it can't exactly "not update".

    However, your feedburner feed can fail to update for some other reason. That I can't help you with. Take FeedBurner out of the equation and see if your WordPress feed works by itself first.

  12. asfodel
    Member
    Posted 5 years ago #

    I understand the feed is being generated on the fly, but that's what it isn't doing. Subscribers are not getting notified of new posts, and neither is google. And if you look at the feed, the new posts aren't there.

    I'm not sure how to get rid of FeedBurner because deactivating the FeedBurner FeedSmith plugin doesn't do it. Clicking on http://nothingwrongwithme.com/?feed=rss2 still redirects to
    http://feeds.feedburner.com/nothingwrongwithme/wEri .

  13. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Deactivating the feedsmith plugin will indeed do it. Just restart your browser. Redirects can be cached by browsers too, you know.

    Also, your feed appears to be perfectly up to date to me. Although you still don't have "Full Text" turned on for the feed.

  14. asfodel
    Member
    Posted 5 years ago #

    Thanks. The Feedsmith plugin is deactivated and the feed is up to date. Hopefully it will continue to work. :)

    I appreciate your help and suggestions.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.