WordPress.org

Ready to get started?Download WordPress

Forums

WP Ultimate Search
[resolved] No results anywhere and nothing in chrome, help! (8 posts)

  1. RonStrilaeff
    Member
    Posted 1 year ago #

    Here is my blog/test site http://strilaeff.net It is the main site in a multisite installation and I activated this plugin only for this site (not network activate).

    I installed it with the defaults (it created the "search" page), and put the widget in the footer. I have standard categories and tags which you can see work by using the normal menu.

    It does nothing in chrome (except show the search bar).

    In firefox, it gets the cat and tag terms, but always returns empty results. There is an unexpected link on the search results page to that same page. Other pages (like "About") show the title but it is not a link.

    I'm evaluating this because I need the features of the pro version (it can find custom post types using custom taxonomies, right?), but you have to help me get the basic version working out of the box or I'm not interested.

    http://wordpress.org/extend/plugins/wp-ultimate-search/

  2. Bryce Corkins
    Member
    Posted 1 year ago #

    This looks like partly a bug a partly and a configuration issue..

    Bug: Since your widget is loading on the /search/ page, there are two instances of the search bar on the same page. This breaks either one or both of the search bars.. since the data that's getting passed around via ajax gets confused about where it's going. I'm going to try and release a v1.0.4 as soon as I can with a fix that will disable the widget on the /search/ page.

    Configuration: The widget redirects to the search results page set in WPUS options. On some servers, this is /search/ and on some servers this is /search (no trailing slash). Go ahead and change the search results page in the settings to /search/, and it should redirect properly.

    Then, for now, you can just add the [wp-ultimate-search-results] shortcode to the /search/ page until I can update the plugin to automatically unload the widget on that page.

    Best

  3. RonStrilaeff
    Member
    Posted 1 year ago #

    Thanks for looking at it, maybe I can help you by being a typical test site. I don't need it to work yet, since our live site (where I would like some ajaxified advanced search) will not be ready for a month or two. Even then I will probably just have some category drop downs to start.

    Anyways, here is the content of my /search (or /search/) page:

    content before shortcode [wp-ultimate-search-results] content after shortcode

    In firefox, on my site, the shortcode produces no content. There is one space on either side of the square brackets.

    I just tested it as network activate vs subsite activate and it behaves the same so I will leave it as subsite activate.

    (Forget chrome for now, the search widget it is just unresponsive there and i'm pretty sure the google search js stuff in a text widget at the top of my sidebar is not interfering.)

  4. Bryce Corkins
    Member
    Posted 1 year ago #

    Have you tried disabling the widget, and then setting the /search/ page to contain:

    [wp-ultimate-search-results]
    [wp-ultimate-search-bar]

    If that doesn't work, then maybe there's something wonky going on with your site in particular, and I can then investigate that further.

  5. RonStrilaeff
    Member
    Posted 1 year ago #

    ok I tried that and it (or my site) seems to be ignoring the shortcodes on the /search page. WP sees it as a shortcode though since it is getting replaced by nothing.

    I'm using woothemes-canvas and I know their shortcodes work.

    I'll dig in later to see what is wonky. No worries.

  6. Bryce Corkins
    Member
    Posted 1 year ago #

    Ok, cool. Let me know what you find out. I'd be happy to take a closer look if you get stuck.

  7. RonStrilaeff
    Member
    Posted 1 year ago #

    Hey I don't have time to track this down myself, but I was just checking some log and config files on my server and stumbled on this error when I was playing with your plugin.

    Apparently it is not hard to create a situation in which the "WHERE" clause is empty:

    [Mon Apr 08 18:29:22 2013] [warn] [client 174.66.18.85] mod_fcgid: stderr: WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ff_posts.post_status = 'publish'' at line 5 for query , referer: http://strilaeff.net/blog/replacing-motor-mounts-on-a-vw-passat/
    [Mon Apr 08 18:29:22 2013] [warn] [client 174.66.18.85] mod_fcgid: stderr: \t\t\tSELECT *,, referer: http://strilaeff.net/blog/replacing-motor-mounts-on-a-vw-passat/
    [Mon Apr 08 18:29:22 2013] [warn] [client 174.66.18.85] mod_fcgid: stderr: \t\t\tsubstring(post_content, 1,200), referer: http://strilaeff.net/blog/replacing-motor-mounts-on-a-vw-passat/
    [Mon Apr 08 18:29:22 2013] [warn] [client 174.66.18.85] mod_fcgid: stderr: \t\t\tAS excerpt, referer: http://strilaeff.net/blog/replacing-motor-mounts-on-a-vw-passat/
    [Mon Apr 08 18:29:22 2013] [warn] [client 174.66.18.85] mod_fcgid: stderr: \t\t\tFROM ff_posts WHERE , referer: http://strilaeff.net/blog/replacing-motor-mounts-on-a-vw-passat/
    [Mon Apr 08 18:29:22 2013] [warn] [client 174.66.18.85] mod_fcgid: stderr: \t\t\tAND ff_posts.post_status = 'publish' made by do_action('wp_ajax_nopriv_wpus_search'), call_user_func_array, WPUltimateSearch->get_results, WPUltimateSearch->execute_query_basic, referer: http://strilaeff.net/blog/replacing-motor-mounts-on-a-vw-passat/

    glhf

  8. Bryce Corkins
    Member
    Posted 1 year ago #

    On most servers this doesn't even create a warning (at least where we've tested it), but I'll make a note to patch this for the next update.

    Thanks for pointing it out.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.