WordPress.org

Ready to get started?Download WordPress

Forums

No Remote Access (2 posts)

  1. Gongalong
    Member
    Posted 9 months ago #

    Hi folks,

    I have installed WordPress on a Win 7 PC using a Microsoft linked install http://www.microsoft.com/web/wordpress

    This is just for test purposes so far, with a view to rolling out on a virtual machine.

    On the machine itself I can access both the site and the admin page with no issues at all (http://localhost:17351/).

    When I try and access remotely via IP, I get a 400 error (in IE). The firewall on the Win 7 PC is turned off.

    Unfortunately I know essentially nothing about WordPress and any site backend configuration. Is there something I need to do to enable remote access, or have I made some other basic error?

    TIA

  2. jonradio
    Member
    Posted 9 months ago #

    That 400 error code is supposed to mean you made a syntax error when typing the URL. If the IP address is 1.2.3.4 then you should be typing http://1.2.3.4:17351 into IE.

    All that said, I have not tried very hard yet, but I cannot get Web PI to be accessible from another machine on the same router. I am using Windows 8 on both machines and, so far, been able to determine that at least three things are stopping me:

    1. Software Firewall (I use one built into my anti-virus software)
    2. Firewall inside the router
    3. Windows 8 Sharing not set up properly

    The only WordPress issue that I can think of that could be involved would be the Site URL and Home URL settings. They might have to be changed to the IP address, rather than localhost.

    Again, I'm no expert on this issue, but I've got into it far enough to know that it is NOT a simple problem. For my testing, I ended up using TeamViewer, which allows me to remotely take over the computer running WordPress under Web PI, and then just use it as localhost.

    Not an elegant solution, but it got me over the issue of not wanting to install Web PI on my own Desktop Windows machine, which would have disabled my existing Xampp installation.

Reply

You must log in to post.

About this Topic