WordPress.org

Ready to get started?Download WordPress

Forums

YOP Poll
[resolved] no radio box (16 posts)

  1. sfaudemer
    Member
    Posted 2 months ago #

    Hi (excuse my english i'm french)
    i have a problem, no radio box appears on my web page. Only questions but impossible to clic to vote !
    please help me

    Stephane

    https://wordpress.org/plugins/yop-poll/

  2. YOP
    Member
    Plugin Author

    Posted 2 months ago #

    Hi sfaudemer,

    Please send us a link to a page containing a poll so we may take a closer look.

    Regards,
    YOP Team!

  3. sfaudemer
    Member
    Posted 2 months ago #

    Hi
    i send you the Url when the website will be public online.
    thank you

  4. sfaudemer
    Member
    Posted 1 month ago #

    HI
    the website is online !!
    this is an example of my probleme : no radio box appears !
    http://www.docteurmarques.fr/yop-poll-archive

    thank you for your help
    Stephane

  5. YOP
    Member
    Plugin Author

    Posted 1 month ago #

    Hi Stephane,

    It looks like the problem is created by the Wp theme you use.
    Edit yop_poll_model.php and look for all the lines that start with

    $temp_string = str_ireplace( '%POLL-ANSWER-CHECK-INPUT%', '<input type="radio"

    For each line, before type="radio" add style="webkit-appearance:radio;"

    Regards,

    YOP Team

  6. sfaudemer
    Member
    Posted 1 month ago #

    HI
    I put this style="webkit-appearance:radio;" like this :

    ( '%POLL-ANSWER-CHECK-INPUT%', '<input style="webkit-appearance:radio;" type="radio" checked="checked" value="' . $answer['id'] . '" name="yop_poll_answer" id="yop-poll-answer-' . $poll_id . $unique_id . '-' . $answer['id'] . '" />', $m[5] );

    But no radio box appears. i do somtehing wrong ?

    http://www.docteurmarques.fr/yop-poll-archive/

    Best regards

  7. YOP
    Member
    Plugin Author

    Posted 1 month ago #

    Hey Stephane,

    Please make sure you add style="webkit-appearance:radio;" before type="radio" for each occurrence of

    $temp_string = str_ireplace( '%POLL-ANSWER-CHECK-INPUT%', '<input type="radio"

    in yop_poll_model.php

    If it doesn't work, then edit the template you used for your poll and in the CSS section add webkit-appearance:radio !important; in
    #yop-poll-answers-%POLL-ID% ul li input{

    Let us know if you need more help.

    YOP Team

  8. sfaudemer
    Member
    Posted 1 month ago #

    yes in all occurences.

    for the CSS i don't know how ans where put this section in the css file ! sorry !

    webkit-appearance:radio !important; in
    #yop-poll-answers-%POLL-ID% ul li input{

    best regards

    Stephane

  9. YOP
    Member
    Plugin Author

    Posted 1 month ago #

    Hi Stephane,

    In the CSS section on your template you can add
    webkit-appearance:radio !important;
    right after #yop-poll-answers-%POLL-ID% ul li input{

    Regards,

    YOP Team

  10. sfaudemer
    Member
    Posted 1 month ago #

    Ok but
    I do this but nothing appen's. it's the same probleme.
    i put this code in Custom style Box of template.

    you can see the page with Firebug for example.

    Regards
    Stephane

  11. YOP
    Member
    Plugin Author

    Posted 1 month ago #

    Hi Stephane,

    In the CSS section of the template, replace

    #yop-poll-answers-%POLL-ID% ul li input {
     margin:0px;
     float:none;
    }

    with

    #yop-poll-answers-%POLL-ID% ul li input {
     margin:0px;
     float:none;
    webkit-appearance:radio !important;
    }

    and save.

    Regards,

    YOP Team

  12. sfaudemer
    Member
    Posted 1 month ago #

    I do that
    a put this code in style.css of Market Blog theme .... but it's the same thing : No radio box
    sorry ! helllp !

  13. sfaudemer
    Member
    Posted 1 month ago #

    for more information, the radio box are Okay in Yop poll admin but not in the website.

  14. YOP
    Member
    Plugin Author

    Posted 1 month ago #

    Hey Stephane,

    You have to make those changes in the CSS section of the YOP template you used, not in the CSS file of your website.

    From your WP menu, go to YOP Poll-> Templates -> drag your mouse over the template you used for your poll and click on Edit. Next, scroll down to the CSS section of that template (it's between Template After End Date and JavaScript).

    In the CSS replace

    #yop-poll-answers-%POLL-ID% ul li input {
     margin:0px;
     float:none;
    }

    with

    #yop-poll-answers-%POLL-ID% ul li input {
     margin:0px;
     float:none;
    webkit-appearance:radio !important;
    }

    and save.

    Let us know if you need more help.

    Best wishes,

    YOP Team

  15. sfaudemer
    Member
    Posted 1 month ago #

    Okay i understand
    I do that in the Green3 template. in the CSS box.
    Ok i find the code to replace.
    A save
    BUT sorry, no radio box :-(

    Stephane
    See you tomorrow
    Bye

  16. YOP
    Member
    Plugin Author

    Posted 1 month ago #

    Hi Stephane,

    Please email us at yop.help{@]gmail.com and provide admin credentials (a link, username and password) so we may taker a closer look.

    Regards,

    YOP Team

Reply

You must log in to post.

About this Plugin

About this Topic

Tags