WordPress.org

Ready to get started?Download WordPress

Forums

No Prety Permalinks & mod_rewrite is ON (supposedly), (7 posts)

  1. dcheshire
    Member
    Posted 6 years ago #

    I previously asked the question "why to my permalinks all contain /index.php/ and was informed that I have the "Nearly Pretty" permalink structure because mod_rewrite is not available on the host.

    However, I have subsequently contacted the host provider and they tell me that mod_rewrite is indeed active.

    1. How do I confirm that mod_rewrite is active (I have cPanel access to the host only)

    2. If mod_rewrite is active, then is there anything else preventing the "Pretty Permalinks" from being active? eg. incorrect file/folder permissions ???

  2. ipears
    Member
    Posted 6 years ago #

    Question: Do you have the .htaccess file in your blog's root and is it writable (CHMOD 666)?

  3. dcheshire
    Member
    Posted 6 years ago #

    Unfortunately only have cpanel access at the moment (ie from work!!), I'll check with FTP access tonight

  4. dcheshire
    Member
    Posted 6 years ago #

    OK... checked for .htaccess file and there is one in the top level wordpress folder. It was set to writable by group (CHMOD 664). Ive set it to 666. Went back to wp-admin and tried to reset the permalinks again, but I'm still only given the option including /index.php/

  5. designsimply
    Member
    Posted 6 years ago #

    These are the requirements for pretty permalinks listed in the WordPress documentation:

    • Apache web server with the mod_rewrite module installed
    • In WordPress's home directory,
    • The FollowSymLinks option enabled
    • FileInfo directives allowed (e.g. AllowOverride FileInfo, AllowOverride All)
    • An .htaccess file (if this file is missing, WordPress will try to create it when you activate "pretty" permalinks)
    • If you want WordPress to update the .htaccess file automatically, WordPress will need write access to the file.

    See Using "Pretty" permalinks for more details.

  6. dcheshire
    Member
    Posted 6 years ago #

    Thanks, I'll get back to the Host and ask about FollowSymLinks and FileInfo directive.

  7. dcheshire
    Member
    Posted 6 years ago #

    I passed on the details about FollowsynLinks ans FileInfo directive to the host, who responded:

    We've added a few lines to your .htaccess file try again.

    Here's what they added:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    It seems to have done the job!

Topic Closed

This topic has been closed to new replies.

About this Topic