WordPress.org

Ready to get started?Download WordPress

Forums

No posts found in admin and Safari (2 posts)

  1. youjustmademylist
    Member
    Posted 5 years ago #

    I don't know where to start with this so any help would be GREAT! Please keep in mind my knowledge of databases is limited to setting one up in the standard
    wordpress way.

    For no apparent reason one of my blogs lost all of its posts yesterday. When I view the site in Firefox the posts appear but in Safari or IE all of my content is missing and "no posts found" display where the content should be. Also, all of my posts are missing in my WP admin. Although it says there are 400 published posts I can not access any of them.

    In all browsers my list of "recent posts" are missing.

    In Safari I can view past posts if I click on a specific category.

    I updated all of my blogs to 2.7.1 last week and my other blogs are working.

    I tried resetting my permalinks and that did nothing.

    I have no idea what to do next - Please help ASAP!

  2. Alison Barrett
    Member
    Posted 4 years ago #

    I know this is an old topic, but I just had this exact same problem. This is how I fixed it:

    I signed in to phpMyAdmin and downloaded a backup of my wp_posts table (just in case!). Then I went to "Operations" and clicked the "Repair Table" link at the bottom of the page. It took less than a second and my table was fixed. After that, my posts showed up everywhere they were supposed to.

Topic Closed

This topic has been closed to new replies.

About this Topic