WordPress.org

Ready to get started?Download WordPress

Forums

Fullscreen Galleria
No pictures shown just black screen (17 posts)

  1. ete
    Member
    Posted 1 year ago #

    When i click on any picture it opens the semi-transparent black background but empty with no picture, navigation arrows, close button, anything. And you cannot even close or go away from this screen.
    Tried with Chrome, Safari, Firefox, Opera (all the same behaviour)

    Watching the error console in safari gives this result:
    TypeError: 'undefined' is not an object (evaluating 'fsg_json[postid].length') galleria-fs.js:129

    Any help how to fix it to work properly and show the images?

    http://wordpress.org/extend/plugins/fullscreen-galleria/

  2. ete
    Member
    Posted 1 year ago #

    Update:

    Tried removing the plugin and reinstalling it (via FTP) and i still get the same problem.

    Here are the results from the error console form Chrome:
    Uncaught SyntaxError: Unexpected token } /press/:393

    Uncaught TypeError: Cannot read property 'length' of undefined galleria-fs.js:129
    fsg_show_galleria galleria-fs.js:129
    v.event.dispatch jquery.js:2
    o.handle.u jquery.js:2

  3. pdamsten
    Member
    Plugin Author

    Posted 1 year ago #

    Not sure where this error comes from:
    Uncaught SyntaxError: Unexpected token } /press/:393
    Might be the reason why all the vars for fsg cannot be found.

  4. ete
    Member
    Posted 1 year ago #

    Do you think you can give me any newbie tips on how to locate a "SyntaxError" like this?
    Thanks for the reply

  5. pdamsten
    Member
    Plugin Author

    Posted 1 year ago #

    Looks like there is syntax error in /press/ directory. I don't have such a directory so I can't say what it is used for.

  6. ete
    Member
    Posted 1 year ago #

    /press/ is one page of my site.
    I have a Fullscreen Galleria on this page.

    I know maybe this shouldn´t´be part of your troubleshooting and maybe more like enlighting newbies like me... but i don´t know how to trace these errores.

  7. ete
    Member
    Posted 1 year ago #

    Resolved! I had a problem on my header.

    Now is working but a new problem arised. When i close the FSG navigation behind it remains open the first photo of the galleria with lightbox.

  8. pdamsten
    Member
    Plugin Author

    Posted 1 year ago #

    Maybe some other plugin i nor liking FSG. Hard to say...

  9. morvi
    Member
    Posted 6 months ago #

    Hi

    I have a similar error in a new WP installation, no other plugin apart of the fullScreen

    fsg_json is not defined

    Source File: http://garciaponte.com/morvi1248/wp-content/plugins/fullscreen-galleria/galleria-fs.js?ver=1.4.3

    Tried deactivate and unistal - reinstall and no luck

    Any Idea?

  10. morvi
    Member
    Posted 6 months ago #

    Now if someone can understand this one
    In this complete new installation - no other plugin
    2 posts - with identical settings and code
    one works the other gives the reported error above and included below.

    Post working (Gall FS3)
    http://garciaponte.com/morvi1248/?p=12

    And post hat give the error (Gall FS4)
    http://garciaponte.com/morvi1248/?p=54

    Why o why!

    Timestamp: 19/02/2014 19:25:15
    Error: ReferenceError: fsg_json is not defined
    Source File: http://garciaponte.com/morvi1248/wp-content/plugins/fullscreen-galleria/galleria-fs.js?ver=1.4.3
    Line: 129

  11. pdamsten
    Member
    Plugin Author

    Posted 6 months ago #

    In Gall FS4 post image link is empty (href='') for some reason and that's why FSG does not generate code for the image. If you look at the posts in html mode are they exactly the same? WordPress generated html is not the same for both posts.

  12. morvi
    Member
    Posted 6 months ago #

    Sorry this is URL of Gall 4 - (also in left menu)

    http://garciaponte.com/morvi1248/?p=58

  13. morvi
    Member
    Posted 6 months ago #

    the content of each post is identical (copy and paste)

  14. pdamsten
    Member
    Plugin Author

    Posted 6 months ago #

    Could you post me the code in html/text tab here or to my email petri.damsten@gmail.com

  15. morvi
    Member
    Posted 6 months ago #

    replied by email
    Thanks for your help - having innumerable problems with some plugins and themes - so I decided to move to a new host - and not to use WMPS this time and now I am finally getting somewhere!!!

    the code on both posts is identical

    [fsg_link link="file" rows="1" cols="1" include="
    <img src="http://garciaponte.com/morvi1248/wp-content/uploads/2014/02/Clip_2.jpg" alt="Clip_2" width="2387" height="1704" class="alignnone size-full wp-image-39" />,<img src="http://garciaponte.com/morvi1248/wp-content/uploads/2014/02/Clip_2.jpg" alt="Clip_2" width="2387" height="1704" class="alignnone size-full wp-image-39" />,<img src="http://garciaponte.com/morvi1248/wp-content/uploads/2014/02/Clip_2.jpg" alt="Clip_2" width="2387" height="1704" class="alignnone size-full wp-image-39" />"]

    <img src="http://garciaponte.com/morvi1248/wp-content/uploads/2014/02/w02l-300x200.jpg" alt="w02l" width="300" height="200" class="alignnone size-medium wp-image-6" />
    [/fsg_link]

  16. rostislav.petrov
    Member
    Posted 6 months ago #

    Had the same problem as morvi: fsg_json is not defined

    In my case the cause appeared to be a new blank line in the caption of one image. Including this image into a FSG will cause the described problem and the recorded error is fsg_json is not defined.

    FSG version 1.4.3

  17. pdamsten
    Member
    Plugin Author

    Posted 5 months ago #

    Thanks for debugging. Fixed in 1.4.4

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.