WordPress.org

Ready to get started?Download WordPress

Forums

No option for people to 'post a comment' on my blog page. (5 posts)

  1. johnwhalley
    Member
    Posted 1 year ago #

    Hi, i've just got my site up and running and all in all, i'm very happy with how WordPress deals with it all.

    Only problem I have is there's no 'post a comment' option on my blog page ( Cosmic-Robot.com link here ). I've seen others post this issue too and I think i've done everything that has been suggested for this issue.

    I've ticked the 'allow comments' on the 'edit page' screen.

    In Settings/Discussion i've ticked the 'Allow people to post comments on new articles' box. Users do not have to sign in or register to post.

    I deactivated all plug-ins and refreshed everything.

    Unfortunately, no luck, there's still no add comment/post reply button. Could anyone suggest anything else please? Much appreciation.

  2. alchymyth
    Forum Moderator
    Posted 1 year ago #

    have you edited comments.php of your theme?

    what happens if you temporarily switch to the default theme Twenty Twelve?

    what happens if you temporarily deactivate all plugins?

  3. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    First, you have the post titles hidden on your blog page (the comment section is displayed on single post pages not blog pages). Second, for the one post there, the url is:

    http://www.cosmic-robot.com/394/

    which is some sort of redirect, most likely by a plugin

    Check all your plugin settings for comment settings.

  4. johnwhalley
    Member
    Posted 1 year ago #

    Thanks for the response guys. Firstly @ alchymyth, I haven't edited the comments.php of the theme as far as i know. I switched to Twenty Twelve as you suggested but still no 'add comment' button. I also disabled all plug-ins again (I only have 7 active to be honest), but as before, there's no change.

    @ Seacoast Web Design, I see what you mean about the post title being hidden, but I've no idea why it is, or how to un-hide it. This is my first blog so didn't realise how it should look, ie: with a title. I don't see anything on the page set-up to either hide or unhide titles. Is there a way to turn them back on?
    Also, no idea why there a redirect on the post, or even what that means really. The plug-ins i have active are as follows:

    AJAX Thumbnail Rebuild, Backup, Contact form plug-in, Facebook button plug-in, Jetpack by wordpress.com, Maintenance Mode, and Official Statcounter Plug-in. I've checked the settings of each but can't see anything obvious.

    Thanks again for the help so far.

  5. johnwhalley
    Member
    Posted 1 year ago #

    Hah, i seem to have fixed the post title issue, but no idea how, i've not changed any settings... still no 'reply' button though.

Topic Closed

This topic has been closed to new replies.

About this Topic