WordPress.org

Ready to get started?Download WordPress

Forums

no option for page template (10 posts)

  1. mrthrust
    Member
    Posted 5 years ago #

    ive installed wordpress on multiplue servers for various projects,

    recenlty upgraded all sites to 2.5.1
    in one site i noticed that if i go to
    ->manage->pages:
    under were it lists all the extras for this page ie:

    Comments & Pings
    Allow Comments
    Allow Pings
    Password Protect This Page
    Page Template

    now in one site i have created page templates
    using the following code:
    <?php
    /*
    Template Name: Course
    */
    ?>

    now this site all works well..
    but on another site, same version 2.5.1 with a few different plugins

    the options for Page Template is not available????
    so i cant set a different template for this site..???

    is there any option im missing? i have both wp-admin sections opened at once and checked all options and i cant find nothing wrong..

    disabled all plugins even removed them all from both sites but still no option in the manage->pages: section

    any help would be great:
    Cheers
    Marty

  2. moshu
    Member
    Posted 5 years ago #

    You gave already the answer to your question:

    now in one site i have created page templates

    That's it. If no Page template - no option.

  3. mrthrust
    Member
    Posted 5 years ago #

    Hi there, thanks for the reply.
    yea i thought that as well..

    so in the site with no tempalte option i created 2 pages,
    blog_header.php

    with the code

    <?php
    /*
    Template Name: Blog Header
    */
    ?>

    even with this code in place when i visit the manage tab, and select the page i want to apply the template to, theres no option for this in the selections below the post. :|

    even when i created a new page theres still no option to allow for a template to be applied...

  4. Evita
    Member
    Posted 5 years ago #

    Maybe a silly question - but it happend to me - do you have the normal page.php in your template folder of this one site. Because without the normal page.php there is no page template option.

  5. mrthrust
    Member
    Posted 5 years ago #

    the way its setup is all default pages for the template are in the theme folder, "wp-content/themes/thetheme/*files"
    ive created 2 other pages in this folder...

    *blog_header.php
    *blog_page.php

    each have a its own html + wordpress code..
    when i load the blog page i want a different layout,
    ie: more landscape rather than portrait.

    but the option still wont appear to set the template for that page. :(

    very frustrating, trying to look for a theme switcher from a URL
    ie: www.mysite.com/index.php?action=chngetheme&theme=MyNewTheme

    but not had much luck

  6. Brayne
    Member
    Posted 5 years ago #

    Many people are having this issue it seems. My fix was to ensure the permissions for the folder of the theme were set at 755. The files within are at 644. So....

    themes/default
    themes/red
    themes/blue

    Where default, red, blue are all set to 755 and that did the trick. My page template options showed up nicely under the Advanced Options area down below.

    Hope this helps.

  7. michaelb123
    Member
    Posted 5 years ago #

    also

    <?php
    /*
    Template Name: Blog Header
    */
    ?>

    so you can use S P A C E S for a 'name'?
    i would think not.

  8. moshu
    Member
    Posted 5 years ago #

    And you are wrong. In that line you can have 10 words long name. Don't confuse it with the filename (whatever.php) which indeed, cannot have spaces!

  9. mrthrust
    Member
    Posted 5 years ago #

    thanks for all the comments..

    although i have tried various methods, long name, short name,
    filename variations, file permissions, i still cant seem to make the option for choosing a template file active at all..

    even created new pages(still no option), published them, edit (still no option)

    on the other site i have copied the entire file from which the template was working.. and that still didnt show up in the advance options section..

    its really got me hitting a brick wall..

    has anyone seen the plugin were it changes theme based on url?
    i did see one last week, but i failed to bookmark it.

  10. moshu
    Member
    Posted 5 years ago #

    Did you see this similar thread with some possible solutions?
    http://wordpress.org/support/topic/164813?replies=38#post-724034

Topic Closed

This topic has been closed to new replies.

About this Topic