WordPress.org

Ready to get started?Download WordPress

Forums

MailPoet Gravity Forms Add-on
[resolved] No new 'MailPoet' tab in the Gravity Forms settings page (18 posts)

  1. eumed
    Member
    Posted 4 months ago #

    Hello Sebastien.
    The plugin work fine if I enable a multi-list selection; don't work with a simple single checkbox. There is no new 'MailPoet' tab in the Gravity Forms settings page.
    I use Gravity Forms 1.8.5, Gravity Forms PDF Extended 3.3.4, MailPoet Gravity Forms Add-on 2.0.0 and MailPoet 2.6.

    Another question: I would like the checkbox cheched. Is it possible?
    Thank you.

    Massimo

    https://wordpress.org/plugins/mailpoet-gravity-forms-add-on/

  2. Sebastien D
    Member
    Plugin Author

    Posted 4 months ago #

    I will install the PDF add-on on our demo site and will see if there is any problems with out plugin if installed. The settings page should be loading.

    As for the checkbox checked I will add an option for that in the settings page and release it in the next hotfix release.

  3. eumed
    Member
    Posted 4 months ago #

    Thanks for the quick reply.

  4. Sebastien D
    Member
    Plugin Author

    Posted 4 months ago #

    Try accessing this page in you WordPress dashboard.

    admin.php?page=gf_settings&subview=MailPoet

  5. eumed
    Member
    Posted 4 months ago #

    I see MailPoet as the title, 4 items on the left (Settings, API, PDF, Uninstall) and no content on the right.

  6. Sebastien D
    Member
    Plugin Author

    Posted 4 months ago #

    Uninstall the add-on, download the plugin to your computer and then upload it. It may of not extracted the settings page file when installed the first time.

    I have now and then had plugins not install properly when installing directly from WordPress.org so I download them first and then upload them my self.

    Let me know if that helps.

  7. eumed
    Member
    Posted 4 months ago #

    Done. But nothing has changed.

  8. Sebastien D
    Member
    Plugin Author

    Posted 4 months ago #

    Do you have wp-admin cached at all ?

  9. eumed
    Member
    Posted 4 months ago #

    No cache system is active.

  10. Sebastien D
    Member
    Plugin Author

    Posted 4 months ago #

    Can you give me access to your WordPress dashboard for me to take a look please ?

    Contact me via my website please so we can keep details private. Link is on my profile page.

    Thank you.

  11. eumed
    Member
    Posted 4 months ago #

    I'm sorry but I can't do that. Thanks anyway :-)
    I will follow the development of your plugin (for me it would be useful to have just the checkbox checked).

  12. Sebastien D
    Member
    Plugin Author

    Posted 4 months ago #

    Have the checkbox checked for all lists you enable in the form ?

  13. eumed
    Member
    Posted 4 months ago #

    In the GF Form Editor? The MailPoet add-on checkboxes are always unchecked after update.

  14. Sebastien D
    Member
    Plugin Author

    Posted 4 months ago #

    Can you send me a screenshot please ?

  15. eumed
    Member
    Posted 4 months ago #

    I contact you via your website.

  16. Sebastien D
    Member
    Plugin Author

    Posted 4 months ago #

    I have found the cause of the problem. It turns out Gravity Forms have translated there screen id's.

    And because I use the screen id to load the settings, when using WordPress in any other language it stops loading because the screen id no longer becomes a match.

    I will push an update that will fix this problem.

    Screen ID in English: 'forms_page_gf_settings'
    Screen ID in Italian: 'moduli_page_gf_settings'

  17. eumed
    Member
    Posted 3 months ago #

    Great, Sebastien. I have not thought about the localization in Italian. It work fine now. Thank you.

    The second initial request: the 'MailPoet Gravity Forms Add-on' new field has the checkboxes for lists or single list authorization always unchecked. I can't choose to leave them checked. Would it be possible in a future plugin update?

  18. 1nejad
    Member
    Posted 3 months ago #

    I also noticed that the checkbox is always unchecked. I used to have it checked by default and it is much more useful that way. Is that an option? I can't find a solution to this anywhere since the update.

Reply

You must log in to post.

About this Plugin

About this Topic