WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] No Network/Super admin after enabling Network (4 posts)

  1. SRD75
    Member
    Posted 2 years ago #

    I've just successfully enabled networks on my WP 3.2.1 blog.

    However, at top right, I have no Network Admin under my name.

    If I go to /wp-admin/network, I receive "You do not have sufficient permissions to access this page."

    In my WP_Sitemeta table, site_admins is set to a:2:{i:0;N;i:1;s:3:"My_Username";}. admin_user_id in rhis table is blank.

    In, WP_Usermeta, SL_capabilities is set to a:1:{s:13:"administrator";s:1:"1";} for my username.

    I had disabled all plugins before install.

    wp-config contains the following:

    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true );
    define('SUBDOMAIN_INSTALL', true );
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'www.superlogical.net' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', 1 );
    define('BLOG_ID_CURRENT_SITE', 1 );
  2. SRD75
    Member
    Posted 2 years ago #

    Question is too hard?

  3. SRD75
    Member
    Posted 2 years ago #

    I had another look at wp-config.php, and the above entries were not there.

    How this happened I'm unsure. Adding them back adds a "My Sites" entry at top left under Dashboard.

    However, I have no ability to add a site, and I receive the same error when visiting /wp-admin/network.

  4. SRD75
    Member
    Posted 2 years ago #

    I installed WordPress 3.2.1 fresh on a new domain, and then enabled Multi-Site, which functioned as documented. I could reach /wp-admin/network without problems.

    Comparing the database of this WP with the problem installation, in the wp_sitemeta table, admin_email was not set for the problem site.

    Also, wp_sitemeta > site_admins was different. The problem website had it set to:

    a:1:{i:0;N;i:1;s:3:"username";}

    The correct value was:

    a:1:{i:0;s:3:"username";}

    Setting admin_email to my Admin account's email and changing siteadmins to the correct value above added "Site Admin" to the top right drop down box under my username.

    However, when trying to load the Site Admin section, my browser produced an error:

    This webpage has a redirect loop. The webpage at [baseurl]/wp-signup.php?new=[baseurl] has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.

    After I added www. to:

    define('DOMAIN_CURRENT_SITE', 'www.example.com' );

    in wp-config.php, I was able to load /wp-admin/network without problem, and all network / multi-site options were visible.

Topic Closed

This topic has been closed to new replies.

About this Topic