WordPress.org

Ready to get started?Download WordPress

Forums

No luck getting multisite to work for subfolder test site (14 posts)

  1. jkrawitz
    Member
    Posted 2 years ago #

    Hi, I'm a complete newbie as far as multisite goes, and don't have much experience with WordPress, though my main site is coming along okay. I'm trying to set up a subfolder as a test site for a PR client and have had no luck at all. My site is: majormedialearning.com. The subfolder is at majormedialearning.com/Valentinos.

    My own site is installed in the root directory, and not in a subdirectory. I created a /Valentinos/ subdirectory, also in the root directory, for the Valentinos site. I installed a separate copy of WP in the Valentinos folder. I also installed a separate MySQL database for the Valentinos site and entered the database name, password and hosting path info in the wp-config.php file in the Valentinos folder.

    I used the (main site) WP dashboard and followed the directions for installing a network, putting the "home" directory with its multiple subfolders in the root directory, and making the specified changes in copies of the main site's wp-config.php and .htaccess files in the newly created /home/content/56/7040756/html subfolder. I specified the main site's database in that wp-config file, which may have been one of any number of possible mistakes on my part.

    To summarize, I now have 3 wp-config.php files altogether. One, in the root directory where the original copy of WP is installed,specifies that multisite is allowed but does not include the additional info in the /home/content/...etc copy mentioned directly above. Both of these refer to the main site's MySQL database. The third wp-config.php is in the /Valentinos folder and specifies the database info for the Valentinos database.

    When I log into WP for the main site (majormedialearning.com) the dashboard does not show the /Valentinos subfolder/site. When I click on "Create a Network" it indicates that "An existing WordPress network was detected." I've tried logging directly into http://www.majormedialearning.com/Valentinos/wp-admin, which results in the following error message:

    "Warning: Cannot modify header information - headers already sent by (output started at /home/content/56/7040756/html/Valentinos/wp-config.php:1) in /home/content/56/7040756/html/Valentinos/wp-includes/pluggable.php on line 866"

    I hope this is coherent, because I now feel completely lost. I've tried everything in the WP support files and read a LOT of forum posts to no avail. Please help!

  2. mokito
    Member
    Posted 2 years ago #

    Hello this is frustrating it happens to me lots.
    I work last week and until today i have my site running. I was pulling my hair like crazy. lol
    This is what i recommend. you can do what is best for you but if you follow my steps is going to be easier trust me.

    Don't skips steps. " Read but no do nothing yet.."

    1. install worpress from scratch with no templates
    2. then you going to follow the steps on (http://codex.wordpress.org/Create_A_Network ) define('WP_ALLOW_MULTISITE',

    true); on top of the /* That's all, stop editing! Happy blogging. */

    Also a video from this guy that i found is good.
    http://www.youtube.com/watch?v=ndLEVwBA92w

    3. Also when you login to the website you will see the network.
    DON'T install the network yet.

    4. Go to plugging and look for ( enable multi-site by jason grim ) this will help you with steps from 3 to 6. here is the link from him http://jgwebdevelopment.com/plugins/wordpress-multi-site-enabler-plugin/
    then. also download the plugins from donncha o caoimh (WordPress MU Domain Mapping ) http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/
    NOTE: DONT ACTIVE NONE OF THE PLUGINS YET.

    NOW start. clik on the network under tools and active.
    watch the video #1 then do the steps on video.
    after that install the multisite it may ask you for ( sunrise.php ) here is
    http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/

    and then the domain mu. do this if the domains gives you error
    http://support.hostgator.com/articles/hosting-guide/lets-get-started/dns-name-servers/wildcard-dns-what-is-it-and-how-do-i-use-it.

    also must contact your hosting in case your subdomain dont accept the subdomain *yourname.com.

    sent them this email lol this were my steps.
    email
    im creating a network o multisite on my site using word press. http://codex.wordpress.org/Create_A_Network
    now my problem is that is not reproducing the new subdomains for members ( theirname.myname.com )
    it will need
    Wildcard DNS record
    Apache Virtual Host
    cPanel Domains

    i try a all but i may miss something, i'm not a guru or know coding.. if you can help me. you must have more experience than me.

    best regard...

    sorry is a lot but until today my site is working. is a lot but nobody teach me so i know is hard. i hope it work for you. let me know ....

    Regards,
    AMY

  3. jkrawitz
    Member
    Posted 2 years ago #

    Thank you, Amy, for taking so much time and effort to help with my issue. Wow! That's a lot of steps!

    My problem is that I don't want or need to install subdomains (ie. http://Valentinos.majormedialearning.com) -- just a single subfolder/subdirectory (htp://majormedialearning.com/Valentinos/ to use as a temporary WP test site for a client who's also a friend. And if it's at all possible, I really don't want to lose my company's site while trying to install a test subfolder for my client. I'm doing this as a favor to her and it's really unlikely that I would ever attempt to host a true network of multiple WP sites.

    Can anyone help me set up (what is presented as an easy installation of) a sub-folder test site with a different theme, images, etc from my own site?

    Desperately seeking a test site that I can later move to the client's separately hosted site? (She has a "website tonight" template on her site now and it will have to be totally ditched to allow for WP installation. She doesn't want to lose her current site for what might be an extended period while we work on the test site that will ultimately replace what she has now. I'm using Elegant Themes' templates if that makes a difference.

    So if anyone has a solution that will work on my site or anywhere else, please, please help!

    Thank you VERY much,
    Joan

  4. jkrawitz - I would install a separate solo site in that folder. MUCH easier to move if they want it later.

  5. jkrawitz
    Member
    Posted 2 years ago #

    Thank you, Ipstenu! That's what I've been trying to do, I think, but my understanding of how multisite works has me boggled.

    Do you mean that I should ditch the multisite setup entirely and just use the separate folder as if it were its own, totally unrelated, site? (I hope!)

    I'm going to try backing everything up, downloading clean installations of WP and seeing if it will work that way.

    If I'm wrong, please, please, please let me know what to and how to do it. Please! Thank so again,
    Joan

  6. jkrawitz
    Member
    Posted 2 years ago #

    Well, that didn't work. I changed multisite to "false" in both folders, backed up and deleted the "home" folder entirely and tried to log in to http://majormedialearning.com/valentinos/wp-admin/. I wound up in the majormedialearning theme ("The Corporation") at a (nonexistent) page named "home" with the following error message:

    Notice: Undefined variable: post_number in /home/content/56/7040756/html/wp-content/themes/TheCorporation/index.php on line 6

    HELP!

  7. Do you mean that I should ditch the multisite setup entirely and just use the separate folder as if it were its own, totally unrelated, site? (I hope!)

    Yes.

    Did you INSTALL wordPress on it's own, in the VALENTINOS folder?

  8. jkrawitz
    Member
    Posted 2 years ago #

    Did you INSTALL wordPress on it's own, in the VALENTINOS folder?

    I did install WP on its own in the Valentinos folder. It's been there the whole time I've been trying to make this work.

    How can I be getting the error message above, that refers to the "home" folder for multisites, when I no longer have the "home" folder online. (I backed it up under a different name on my computer before deleting the "home" folder in both places. I just rechecked to be sure it's not there and it's not.

    Did I use the right url (http://majormedialearning.com/valentinos/wp-admin/)to try to log in to the Valentinos test site?

    The majormedialearning site has WP installed in the root directory. The Valentinos folder is also installed in the root directory. Could it be a problem with my editing of .htaccess or wp-config.php? If so, what should those files look like? And is there any other file or folder that might have been affected when I tried to make multisite work?

  9. Why are you trying to turn Multisite on at all in valentinos? Does your client need a multisite and you want to test it out or what? Because moving multisite involves DB savvy.

  10. jkrawitz
    Member
    Posted 2 years ago #

    Thank you, again, ipstenu.

    Sorry for not explaining more thoroughly. I had changed multisite to "false" and deleted the multisite lines in the wp-config files in

      both

    places (http://majormedialearning.com/wp-config.php

      and

    http://majormedialearning.com/Valentinos) As you suspected, the client doesn't need multisite.

    I'll post all the code for the wp-config files for both sites below. Maybe you can figure out what went wrong from that.

    **THE CODE FOR http://majormedialearning.com/wp-config.php is immediately below.**
    ** THE CODE FOR http://majormedialearning.com/Valentinos/wp-config.php follows the code below. I have removed the database references to prevent them from being posted publicly.

    **THIS IS THE CODE FOR http://majormedialearning.com/wp-config.php**
    //

    <?php
    
    /**
    
     * The base configurations of the WordPress.
    
     *
    
     * This file has the following configurations: MySQL settings, Table Prefix,
    
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
    
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    
     *
    
     * This file is used by the wp-config.php creation script during the
    
     * installation. You don't have to use the web site, you can just copy this file
    
     * to "wp-config.php" and fill in the values.
    
     *
    
     * @package WordPress
    
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    
    /** The name of the database for WordPress */
    
    define('DB_NAME', 'maj1xxxxxxxxx');
    
    /** MySQL database username */
    
    define('DB_USER', 'maj1xxxxxxxx');
    
    /** MySQL database password */
    
    define('DB_PASSWORD', 'xxxxxxx');
    
    /** MySQL hostname */
    
    define('DB_HOST', 'maj1xxxxxxx.db.7xxxxxxx.hostedresource.com');
    
    /** Database Charset to use in creating database tables. */
    
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    
    define('DB_COLLATE', '');
    
    /**#@+
    
     * Authentication Unique Keys and Salts.
    
     *
    
     * Change these to different unique phrases!
    
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    
     *
    
     * @since 2.6.0
    
     */
    
    define('AUTH_KEY',         'F#8EfkEpD2%+M9x!9_)B');
    
    define('SECURE_AUTH_KEY',  '!Ss5-AsxmN3HfLU2H_60');
    
    define('LOGGED_IN_KEY',    'XhRLU%qaP5PrORPL4ggp');
    
    define('NONCE_KEY',        's%Tp5K)LTyj-aS5dv$P(');
    
    define('AUTH_SALT',        'z0V0xnH4jkrJQT/nd06H');
    
    define('SECURE_AUTH_SALT', '%H52RhG_NSA$6nx$d)g@');
    
    define('LOGGED_IN_SALT',   '=R7g1)NWQ33+7npAEI )');
    
    define('NONCE_SALT',       '*gzWZ$7D3+ W1$U00+mU');
    
    /**#@-*/
    
    /**
    
     * WordPress Database Table prefix.
    
     *
    
     * You can have multiple installations in one database if you give each a unique
    
     * prefix. Only numbers, letters, and underscores please!
    
     */
    
    $table_prefix  = 'wp_';
    
    /**
    
     * WordPress Localized Language, defaults to English.
    
     *
    
     * Change this to localize WordPress.  A corresponding MO file for the chosen
    
     * language must be installed to wp-content/languages. For example, install
    
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
    
     * language support.
    
     */
    
    define ('WPLANG', '');
    
    /**
    
     * For developers: WordPress debugging mode.
    
     *
    
     * Change this to true to enable the display of notices during development.
    
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
    
     * in their development environments.
    
     */
    
    define('WP_DEBUG', true);
    define('WP_ALLOW_MULTISITE', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    
    if ( !defined('ABSPATH') )
    
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    
    require_once(ABSPATH . 'wp-settings.php');
    
    //
    
    ** END OF FILE**
    
    ** THE FOLLOWING IS THE CODE FOR the wp-config.php file in the valentinos folder http://majormedialearning.com/valentinos/wp-config.php
    
    //
    <?php
    /**
     * The base configurations of the WordPress installation for Valentinos.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'valentinos');
    
    /** MySQL database username */
    define('DB_USER', 'valentinos');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'xxxxxxxx');
    
    /** MySQL hostname */
    define('DB_HOST', 'valentinos.db.7xxxxx.hostedresource.com');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         'F#8EfkEpD2%+M9x!9_)B');
    define('SECURE_AUTH_KEY',  '!Ss5-AsxmN3HfLU2H_60');
    define('LOGGED_IN_KEY',    'XhRLU%qaP5PrORPL4ggp');
    define('NONCE_KEY',        's%Tp5K)LTyj-aS5dv$P(');
    define('AUTH_SALT',        'z0V0xnH4jkrJQT/nd06H');
    define('SECURE_AUTH_SALT', '%H52RhG_NSA$6nx$d)g@');
    define('LOGGED_IN_SALT',   '=R7g1)NWQ33+7npAEI )');
    define('NONCE_SALT',       '*gzWZ$7D3+ W1$U00+mU');
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.???
     *This may be superceded by "enable multisite/network ability
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
     */
    define ('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', true);
    define('WP_ALLOW_MULTISITE', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    
    //

    ** End Valentinos wp-config.php file.**

  11. jkrawitz
    Member
    Posted 2 years ago #

    Oops. I forgot to post the error message I'm

      still
    getting when I try to access http://majormedialearning.com/Valentinos/wp-admin/

    I deleted the "home" folders a week ago but still get this message:

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/56/7040756/html/Valentinos/wp-config.php:1) in /home/content/56/7040756/html/Valentinos/wp-includes/pluggable.php on line 866

  12. There's nothing wrong with your wp-config, but ... I cannot, for the life of me, figure out what the heck the problem is.

    You way overcomplicated things and I'm not sure how to tell you how to UN tangle it.

    I would do this.

    Delete the Valentinos folder. Just dump the whole thing, database and all, and start over from scratch.

  13. jkrawitz
    Member
    Posted 2 years ago #

    Thank you, Ipstenu. I'll dump the Valentinos folder and database and start from scratch.

    Is there any chance that the problem is coming from the .htaccess file? I fooled around with that but I'm pretty sure I put it back in its original configuration. Just in case that's the missing link, this is the .htaccess file from the root directory. Is there anything here that might be causing the bizarre error message that refers to a "home" folder that I dumped long ago and doesn't show up at the server level?

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress
  14. ASSUMING that .htaccess is in your main public_html folder, no, it shouldn't affect the subfolders.

Topic Closed

This topic has been closed to new replies.

About this Topic