WordPress.org

Ready to get started?Download WordPress

Forums

Image Zoom
No longer working and site load increased (31 posts)

  1. bcjhood
    Member
    Posted 7 months ago #

    Love the plugin, been using it for months.

    But it's no longer working, about the time I upgraded WordPress to 3.8 I think.

    It's also adding 4 seconds to my site's load time, so I checked it on webpagetest.org. It looks like these elements are unable to load:

    /image-zoom/core/load-styles.php
    /image-zoom/core/load-scripts.php

    It first tries to load them and gets 301 errors. Then it tries again and gets 404 errors. It happened on my old webhost as well as my new one. Any ideas? I haven't changed my plugins or theme.

    http://wordpress.org/plugins/image-zoom/

  2. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    Work very well on WP3.8 ...
    What is you URL so that I could test ?

  3. bcjhood
    Member
    Posted 7 months ago #

    Wow thanks for the quick response :)

    I tried the tests again and I don't even see it trying to load those files anymore. The plugin still isn't working.

    tiptopsecurity.com

    URL with some images:
    http://tiptopsecurity.com/how-to-securely-wipe-your-hard-drive-with-dban-erase-your-data-for-good/

  4. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    There is my plugin running but the loading url is very very strange ...
    https://tiptopsecurity.com/tts-content/plugins/home4/rcjhood/public_html/tts-content/plugins/image-zoom/core/load-styles.php
    instead of
    https://tiptopsecurity.com/tts-content/plugins/image-zoom/core/load-styles.php

  5. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    ohh ...
    You have migrated to an other hoster ?
    That may explain if you migrate your site incorrectly

  6. bcjhood
    Member
    Posted 7 months ago #

    Ok, that's where it installed when I uninstalled/reinstalled the plugin. Looks like a mix of my old host's and new host's html directories.

    Image zoom is the only thing in that directory at all. Wonder why it installed there.

    So in theory if I just move those files into the right directory it should work?

  7. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    No I believe that your old directory is hardly stored somewhere in the database or in the conf file ...
    Thus, when my plugin create the url of the JS / CSS to be loaded, the behaviour is erroneous ...
    $url = plugin_dir_url("/").'/'.str_replace(basename( $this->path),"",plugin_basename($this->path)) .$name ;

    The plugin is not installed in that directory but he believe he is

  8. bcjhood
    Member
    Posted 7 months ago #

    Okay, I uninstalled the plugin, completely deleted that home4 directory and reinstalled. I see the plugin folder in the right place now but it's still looking in that old directory for the files.

    So now I have to find why it's trying to look in the wrong place. Could it be a caching problem?

  9. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    The home4 directory exists ? stange ...
    what is the normal complete path to the plugin dir ?

  10. bcjhood
    Member
    Posted 7 months ago #

    home4 was part of the directory path at my last webhost.

    All my other plugins install correctly in /tts-content/plugins/. Image zoom was the only one in that home4 folder for some reason.

    It seems to be installing in the right place now, but it still doesn't work. It may be I just need to update the cache or something.

  11. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    You have a cache plugin ?
    empty cache / deactivate ?

  12. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    Could you confirm that in the wp-config.php file you have this line ?
    define('ABSPATH', dirname(__FILE__) . '/');

  13. bcjhood
    Member
    Posted 7 months ago #

    Yes, I do have that line.

    Correction... home4 is THIS webhost, not my old one. Sorry about that. So I don't know why it created that wacky directory.

    I've disabled my cache plugin (WP Super Cache) and waiting to see if that works.

  14. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    If it work that should be instantaneous ... If not I will need an access to your website (FTP and WP account)
    You could sent me the credential by the feedback tab in the plugin

  15. bcjhood
    Member
    Posted 7 months ago #

    Thanks for your awesome help on this! Getting closer I think.

    The cache is deactivated.

    Image Zoom is installed in the right plugin directory with all my other plugins.

    webpagetest.org is not getting any more 404s - it's finding both those files now.

    But the plugin doesn't work when I visit the page.

  16. bcjhood
    Member
    Posted 7 months ago #

    I'd rather not give out my login info. You've been very helpful so far! I'm just not comfortable giving out that information to anyone.

    Any idea where else it might be getting that strange directory from? I noticed that those image zoom files are the only ones on the page besides google's that are trying to load with a secure connection.

  17. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    I do not ask for your credentials : I only need a test account that you might create on purpose.

    The FTP connection is not necessary if I am able to modify plugins code i.e. in tiptopsecurity.com/wp-admin/plugin-editor.php

  18. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    At the very very least I may also send you a beta version and ask you what is being displayed on the page, re-send your another version, etc.

    But this solution is quite painful ...

    Finally, be sure that if I were a malicious guy, my plugin would contains a very bad backdoor ... this is not the case obviously :)

  19. bcjhood
    Member
    Posted 7 months ago #

    I have an account ready for you with access to the plugin editor. But I can't find the feedback tab on your plugin. Do you have some other way I can send you the login info?

  20. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    The feedback tab is in the page where you configure the plugin

    You could also send me a mail ... My email is (my name here in one word) @ (my name here in one word) . Fr

    Ps : sorry for the delay I was sleeping

  21. bcjhood
    Member
    Posted 7 months ago #

    No worries, thanks so much for your help on this! You provide some great support for a free plugin... :)

  22. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    I Will work on that this we !
    Please note that the editing function of the plugin may sometimes bug and create a php bug for all the site : in such case I will send you a notification as soon as possible so that you could delete the plugin dir from your FTP directory

    Hope that will not happen but prefer to warn

  23. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    Ok ... I test few things on your website and the following appears :
    - I do not know which plugins does that but you have a caching feature activated on your website as, when I modify code, the appeareance is unchanged ...
    - Either your installation of wordpress is buggy, or a plugin screws the WP functions.

    For instance, I tried to display 2 results :

    echo plugin_dir_url("/") ;
    echo plugin_basename($this->path) ;

    The previous code should display something like :

    http://www.sedlex.fr/wp-content/plugins/
    image-zoom/image-zoom.php

    Instead the wp function on your website display

    /tts-content/plugins/
    home4/rcjhood/public_html/tts-content/plugins/image-zoom/image-zoom.php

    As you see it is very very different and that cause the image zoom plugin to bug ...

    These function are not plugin's functions but are WP functions and their behaviour are well documented (you could have found a WP bug but it far beyond my expretise)

    In any way, I recommend deactivating ALL plugins to see if that change something (and try the above code).
    I have not try to deactivate any of the activated plugins as we have not discussed that before.

    Tell me

  24. Sed Lex
    Member
    Plugin Author

    Posted 7 months ago #

    Strange I see that your page contains the following code

    <!-- Dynamic page generated in 0.391 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2014-01-18 03:45:25 -->

    but you plugin page says that this plugin is non activated

  25. Sed Lex
    Member
    Plugin Author

    Posted 6 months ago #

    Have you solved your issue ?

  26. bcjhood
    Member
    Posted 6 months ago #

    I have not, yet. I'm still trying different things. I'm experimenting with WP Super Cache to see why it's still caching when it says it's not.

  27. bcjhood
    Member
    Posted 6 months ago #

    I've manually removed all the the remaining bits of the super cache plugin. It should not be caching anymore.

    But image zoom still isn't working. Would you be willing to check it again and see if it's still caching?

  28. Sed Lex
    Member
    Plugin Author

    Posted 5 months ago #

    You did uninstall the plugin ?

  29. bcjhood
    Member
    Posted 5 months ago #

    I'm sorry, I had it deactivated so I could troubleshoot a different plugin.

    I think I have issues with my wordpress installation and database. Other plugins are giving me trouble too. I reactivated image zoom if you wanted to look at it, but soon I'm going to reinstall wordpress and start over. Hopefully that will fix my problems.

  30. Sed Lex
    Member
    Plugin Author

    Posted 5 months ago #

    Yes definitely I believe that your have some issue with your installation :(

Reply »

You must log in to post.

About this Plugin

About this Topic

Tags