WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] No longer sending through Askimet (5 posts)

  1. MaximumFish
    Member
    Posted 9 months ago #

    Hi,

    We setup Contact Form 7 to send through Askimet as described on your documentation page and all was working well. We then separated the name into first name, last name to better work with Mailchimp (using the Contact Form 7 Autoresponder Addon) and have the form setup like so:

    <p>First Name (required)<br />
        [text* your-first-name akismet:author] </p>
    
    <p>Last Name (required)<br />
        [text* your-last-name akismet:author] </p>

    As far as I can tell, sending two fields through askimet:author should cause no problems, but now everything is passing, even if I put 'viagra-test-123' into both of the name fields.

    Is there anything I can do to fix this, while retaining the first name, last name setup? It might not even be related, but Askimet itself reports that it is working and is able to contact all of its servers just fine.

    Much thanks for any help.

    http://wordpress.org/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 9 months ago #

    When you have two akismet:author fields, they are concatenated and sent to Akismet. So when you put viagra-test-123 into both fields, "viagra-test-123 viagra-test-123" is sent to Akismet. I guess Akismet treats one "viagra-test-123" only as the name for demo.

  3. MaximumFish
    Member
    Posted 9 months ago #

    Interesting, thanks. So am I doing it right by specifying both fields be sent to Askimet, or should I be letting the contact form do it another way?

    I just noticed I've been calling it Askimet this whole time when it's Akismet. At least I seem to have it right in the code!

  4. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 9 months ago #

    You are doing it right. Wait and see how it works for a while.

  5. MaximumFish
    Member
    Posted 9 months ago #

    OK, thanks a lot for the input. I have now managed to get it to flag spam by referencing some well known substances in the body, so it does seem to be working as expected.

    Thanks again for the ridiculously flexible plugin!

Reply

You must log in to post.

About this Plugin

About this Topic