WordPress.org

Ready to get started?Download WordPress

Forums

Electric Studio Auto Post Expire
[resolved] No longer 'expiring' even with proper past date in place (10 posts)

  1. 3cstudio
    Member
    Posted 1 year ago #

    Enjoying this plugin, but recently (in the past week or so?) the expired posts began showing up on the site -- had performed a few updates during that timeframe, including moving to WordPress 3.5.

    The plugin itself is at version 1.6.6 and yet my client (using custom post types to make Coupons) had a few pages of expired coupons presented at their checkout counter by a customer who demanded all coupons be honored (since they were still visible on the website). :-/

    Please advise - any info would be much appreciated.

    Steve C.
    3Cstudio

    http://wordpress.org/extend/plugins/electric-studio-auto-expire-post/

  2. Gabor Javorszky
    Member
    Posted 1 year ago #

    Hi Steve,

    I'll look into this over the next couple of days. Sorry it caused trouble. I'll test it on a site with 3.4.2 and then upgrade to 3.5 using custom post types. I can't at the moment, as I'm in transit at an airport, but as soon as I have some time, I'll do it (possibly Tuesday or Wednesday).

    Gabor

  3. 3cstudio
    Member
    Posted 1 year ago #

    Thanks for the update, Gabor. I look forward to hearing from you shortly. S

  4. Gabor Javorszky
    Member
    Posted 1 year ago #

    Hi Steve,

    Couple of more questions

    • What is the post status that is being set on the posts when expired?
    • Can you reach the same content with the permalink? (eg. when using twentytwelve, if a post is published, I can reach it. If the post is in draft, I get a 404 if I'm logged out. If I'm logged in, I can still reach it.)
    • Are the coupons in question actually show up as restored in the back-end?

    If it's easier, use my e-mail address, I tend to respond faster there (although I do get notifications here.

    Gabor

  5. 3cstudio
    Member
    Posted 1 year ago #

    Hi Gabor,

    I am (for whatever reason) not receiving email alerts from this forum, and not seeing anything Spam, plus I don't see where I can get your email address, so I'm simply responding to this thread again. :-/

    I noticed that just this morning there was a plugin update for Auto Post Expire. I went ahead and updated, and it seems it defaulted back to no "Expire the content" section top-right. So, on the Settings page: /wp-admin/options-general.php?page=es_ape_options_page I reset the custom post type for Coupons back to Draft status and the Frequency to Daily.

    Now, I'll have a couple of test coupons run and see if that fixes anything before we dig deeper... more in a bit.

    Steve C.
    3Cstudio

  6. Gabor Javorszky
    Member
    Posted 1 year ago #

    Hi Steve,

    If you tick the 'Notify me of follow-up posts via email', you'll get notifications. Otherwise my e-mail is in the plugin file near the top. (I don't write it here due to e-mail address farming robots and other nasty bits).

    Let me know how it goes, and any steps needed to reproduce the bug.

    Gabor

  7. 3cstudio
    Member
    Posted 1 year ago #

    OK, here's my results of a test:

    • added a Coupon back in: http://myflowerland.com/specials-coupons/coupons/ -- the last one listed there for Bows
    • set the date and time to: 12/18/2012 and 10:30
    • confirmed the overall General settings were to my time zone (Detroit) in case that mattered
    • when 10:30 came and went, I made sure the server cache was cleared to keep that from being a factor
    • only Coupons is checked in plugin settings, with it set to move the Coupon to Draft, and to check for expired content every 15 minutes

    And now it is gone! Thanks Gabor... talking it out must have fixed it. ;-) I'll mark this as resolved shortly.

    Thanks again,

    Steve C.
    3Cstudio

  8. 3cstudio
    Member
    Posted 1 year ago #

    Email:

    - yes, I always leave that checked: "Notify me of follow-up posts via email"... but have received nothing yet, to any folder

    - I don't see your address, but hopefully it won't be needed (much) anymore

    - I changed the address on record to another, just in case filtering was the culprit on the other one...

    So, we'll see if that helps!

  9. Gabor Javorszky
    Member
    Posted 1 year ago #

    Hiya Steve,

    Glad that got resolved. Setting the time zone is important, and for some reason, this piece of info is nowhere to be found. I'll add it to make it more prevalent across the plugin and documentation.

    Thanks for marking this resolved.

    Hint for people reading this in the future: please set your timezones!

    Gabor

  10. 3cstudio
    Member
    Posted 1 year ago #

    :D

    I didn't get a notification of this via email again, and I even changed to a Gmail address. :-/ Triple-checking the Notify checkbox -- yep, it's checked! Ah well...

    Thanks again for your help and for noting the time zone issue in future iterations of the plugin's docs.

    Peace to you and yours!

    Steve C.
    3Cstudio

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic