WordPress.org

Ready to get started?Download WordPress

Forums

Apocalypse Meow
[resolved] No Log-in History (9 posts)

  1. steadybright
    Member
    Posted 8 months ago #

    Hi,

    I am receiving no log-in history from AM. The plugin worked fine on a previous install (Arch Linux ARM, nginx, SQLite, and PHP).

    My current install is:
    Also on Arch Linux ARM, Apache, MariaDB (MySQL), PHP.

    WordPress = 3.6.1
    Apocalypes Meow = 1.4.4

    The Apache error log looks good, except for errors regarding missing favicon.ico and robots.txt files, and a warning that my RSA serrver certificate commonName does not match my server name.

    The install details (from the outstanding Bulletproof Security plugin) follow:

    MySQL:

    MySQL Database Version: 5.5.33a-MariaDB-log
    MySQL Client Version: mysqlnd 5.0.11-dev - 20120503
    Database Host: 127.0.0.1
    Database Name: mpb_wp
    Database User: root
    SQL Mode: Not Set
    WordPress Installation Folder: /wp/
    WordPress Installation Type: Subfolder Installation
    Network/Multisite: Multisite is Not enabled
    WP Permalink Structure: /%post_id%/%postname%/
    Custom Permalinks: √ Custom Permalinks are in use
    PHP Version Check: √ Using PHP5
    Browser Compression Supported: gzip,deflate,sdch

    PHP:

    PHP Version: 5.5.5
    PHP Memory Usage: 9.45 MB
    WordPress Admin Memory Limit: 256M
    WordPress Base Memory Limit: 40M
    PHP Actual Configuration Memory Limit: 128M
    PHP Max Upload Size: 2M
    PHP Max Post Size: 8M
    PHP Safe Mode: Off
    PHP Allow URL fopen: On
    PHP Allow URL Include: Off
    PHP Display Errors: Off
    PHP Display Startup Errors: Off
    PHP Expose PHP: On
    PHP Register Globals: Off
    PHP MySQL Allow Persistent Connections: On
    PHP Output Buffering: 4096
    PHP Max Script Execution Time: 30 Seconds
    PHP Magic Quotes GPC: Off
    PHP open_basedir: /srv/httpa/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/
    PHP XML Support: Yes
    PHP IPTC Support: Yes
    PHP Exif Support: No

    I really like the AM plugin! I hope we can sort out the cause of the trouble.

    steady

    http://wordpress.org/plugins/apocalypse-meow/

  2. blobfolio
    Member
    Plugin Author

    Posted 8 months ago #

    Hey steadybright,

    Thanks for all the details! Would you please check/confirm three things for me?

    1) Did the database tables get created? You should see *meow_log and *meow_log_banned (where * is your WP prefix)?

    2) Are you behind any sort of proxy that might be returning a reserved/internal IP instead of the user's actual one?

    3) Is the $_SERVER['REMOTE_ADDR'] environmental variable being populated?

  3. steadybright
    Member
    Posted 8 months ago #

    Hi Blobfolio,

    Thank you for your prompt reply. To answer your questions:

    1. Yes, both tables are present.
    2. No, I'm not behind a proxy.
    3. Please help me know where to look for this, so I may answer your question. :)

    steady

  4. blobfolio
    Member
    Plugin Author

    Posted 8 months ago #

    Hey Steady,

    I'm sorry, #3 requires a little bit of PHP. But as an Arch user, I'm sure you've had to do worse!

    $_SERVER['REMOTE_ADDR'] is a PHP variable that should return the IP address of the visitor. The easiest way to see this and other variables is to make a quickie PHP file with the following code:
    <?php phpinfo(); ?>

    It is this variable that Apocalypse Meow tries to evaluate prior to logging a log-in attempt. If the value returned by this variable is not an IP, or falls within private or reserved ranges, or matches that of the server itself, then it can't do its job, and so doesn't log anything.

    To see how the above test actually evaluates on your server, please create a quickie PHP file somewhere on the server with the following code:
    <?php var_dump(filter_var($_SERVER['REMOTE_ADDR'], FILTER_VALIDATE_IP, FILTER_FLAG_NO_PRIV_RANGE | FILTER_FLAG_NO_RES_RANGE)); ?>

    That should either print your IP if your IP is okedoke, or False. If it is False. Please let me know if you get your IP or False.

    Thanks for taking the time to help debug this plugin!

  5. steadybright
    Member
    Posted 8 months ago #

    Hi Blob,

    I created the file with the code above, and the result was my WAN (external) IP address.

    Also, I checked my PHP Test page, and is lists the same IP address in the "REMOTE_ADDR" field in the "Apache Configuration" section. (Sorry for not cluing in on this the first time around.)

    By the way, I don't think we are debugging your plugin, rather I think we are debugging my configuration. :)

    Thanks so much for your help.

    steady

  6. blobfolio
    Member
    Plugin Author

    Posted 8 months ago #

    Hey Steady,

    Would you please let me know what other plugins you have installed? I'm going to try to recreate your setup and see if I can break something too! Thanks!

  7. steadybright
    Member
    Posted 8 months ago #

    Hi Blob,

    Ok, we can stick a fork in this one. Your earlier statement:

    It is this variable that Apocalypse Meow tries to evaluate prior to logging a log-in attempt. If the value returned by this variable is not an IP, or falls within private or reserved ranges, or matches that of the server itself, then it can't do its job, and so doesn't log anything.

    was the clue that helped resolve the problem.

    I had set the LAN IP address as the WordPress Address and Site Address in the WordPress General Settings page. Once I updated the fields to the dynamic DNS URI, the problem disappeared.

    The PHP test page resolved my WAN IP because I entered the DDNS URI in the address bar, which stuck. However, in WP, the Site Address value replaced the URI I entered, resulting in unlogged logins for AM.

    Thanks for the critical bit of data, which ultimately resolved the problem.

    Thank you,

    steady

  8. blobfolio
    Member
    Plugin Author

    Posted 8 months ago #

    Hey Steady,

    Thanks for the update, and I'm glad it's working now!

    In the next release, I'll include that IP validation test as part of the settings page itself, so it can be made clear when there are issues that could prevent logging.

  9. steadybright
    Member
    Posted 8 months ago #

    Thank you for supporting your excellent plugin so well!

    steady

Reply

You must log in to post.

About this Plugin

About this Topic