WordPress.org

Ready to get started?Download WordPress

Forums

Category Posts in Custom Menu
[resolved] No links output in wordpress 3.5 (4 posts)

  1. pittsaj
    Member
    Posted 1 year ago #

    Just updated a site to WordPress 3.5, links were displaying in previous version and but after the upgrade.

    http://wordpress.org/extend/plugins/category-posts-in-custom-menu/

  2. Diana Koenraadt
    Member
    Plugin Author

    Posted 1 year ago #

    I'm very sorry to hear that. I've immediately updated my blog to 3.5, but I experience no such problem.

    Can you please perform these steps:
    - Add another static link to your menu, to make sure that there are other links in the menu besides the ones generated by my plugin. (WP 3.5 changelog "No markup is output if wp_nav_menu() has no menu items", I haven't gotten around to inspect the code changes yet so can't tell what influence this may have on my plugin.)
    - Disable and re-enable the plugin
    - Revert to the default WordPress Theme
    - Disable other plugins

    E-mail me (diana (a) dianakoenraadt * nl) a screenshot of your menu setup in Appearance > Menus so that I can mimic this and inspect the results.

  3. pittsaj
    Member
    Posted 1 year ago #

    Hi Anaid, thanks so much for your quick reply, it turns out that another plugin was causing issues (Post Types Order - http://www.nsp-code.com/). Must be something to do with the way this plugin orders the posts in WordPress.

    I really appreciated your suggestions and helping me sort this one out.

    Andrew

  4. Diana Koenraadt
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Andrew,

    For me, I'm relieved that my plugin isn't the cause ;) But unfortunately you may experience this type of results if you are using several plugins that edit the menu. This is because WordPress only has one "hook" we can attach functions to to edit the menu, and if two plugins use the hook then they will conflict. When another plugin uses that same hook, my plugin takes lower priority, it should not do anything when another plugin uses that same hook. I'm not sure though if there are other ways that conflict can arise, through other hooks... I'll look into that.

    I will download the plugin you mentioned, and try it out myself to see where the problem occurs and if I can to anything to limit problems.

    Thank you for reporting this. Marking this topic as resolved.

    Kind regards,
    Diana

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.