WordPress.org

Ready to get started?Download WordPress

Forums

WP-United : phpBB WordPress Integration
[resolved] No kind of path is working in Setup (22 posts)

  1. Denim Mage
    Member
    Posted 1 year ago #

    No matter what I put as the "phpBB Location", in dozens of different ways and combinations and directories listed, nothing will connect. Also, the "show me the file chooser" is broken. It doesn't do anything. I have tried it in IE, Firefox, and Chrome.

    http://wordpress.org/extend/plugins/wp-united/

  2. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Sorry you're having problems. I need more information to help you properly.

    Note that some shared hosts have very strict settings preventing you from enumerating your own files. That's probably why the file chooser isn't available for you. The manual entry is actually already the backup choice... Most users never see it.

    At a minimum in order to be able to help you, I need to know what is shown by default in the first part of the path entry, and the info from your Get Help screen. I'd also need to know what kind of paths you tried to type and what was the error you received.

    Thanks!

    John

  3. Denim Mage
    Member
    Posted 1 year ago #

    I am trying to connect for the first time in order to enter setup. The error is always "The server returned the following information:
    ERROR: phpBB's config.php could not be found at the location you chose"

    Image of input boxes on setup page

    I have tried every combination of the following domain and placement of config.php: (including: splitting the domain into two halves, one for the first input box and the other for the second; removing the "config.php" part from input; including or not including forward slashes; and including or not including "home" and/or "public_html")

    http://www.earthmages.com/[public_html/]phpBB/config.php

    Nothing, in any combination, works. It always says "config.php could not be found at the location you chose".

  4. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    The path is a file path, not a url... there should be no http and no domain.

    It will be something like:
    /home/xxx/public_html/phpBB/

    If you can post the info from the get help screen (showing sensitive info) as requested, I can tell you what your path is.

  5. Denim Mage
    Member
    Posted 1 year ago #

    Is "xxx" the domain? Such as "xxx" = "earthmages.com"? Does "xxx" need to exist?

    Also, there is no screenshot, unless you want me to screenshot every attempt at filling in the input boxes. I already gave you the location of my config.php file. I'm not sure what you are asking for.

    Page I am on, with error

    Location of config.php:

    http://www.earthmages.com/public_html/phpBB/config.php

  6. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Xxx is part of the file path. It could be similar to your domain name, it depends on how your host sets it up.

    There is a wp-united page called "get help". That includes a bunch of information that you can post in order to help with support. It's on the left, in the wp-united menu, labelled "Get Help"

  7. Denim Mage
    Member
    Posted 1 year ago #

    There are two input boxes side by side in the setup page where you put in the URL of config.php, as shown in the picture. What is the difference between the two? Can I ignore one? Can you make a screenshot of what goes into the boxes, or do I even need the first one if both WordPress and phpBB are hosted under the same domain?

  8. Denim Mage
    Member
    Posted 1 year ago #

    Here is the information:

    [b]WP-United Version[/b]        :     0.9.2.3-r0
    [b]WordPress Version[/b]        :     3.5.1
    [b]PHP Version[/b]              :     5.2.17
    [b]WP-United enabled?[/b]       :     No
    [b]WordPress Home URL[/b]       :     http://www.earthmages.com/
    [b]WordPress Base URL[/b]       :     http://www.earthmages.com/
    [b]WordPress Plugin URL[/b]     :     http://www.earthmages.com/wp-content/plugins/wp-united/
    [b]phpBB URL[/b]                :     Unknown
    [b]Plugin Path[/b]              :     /home/a3359902/public_html/wp-content/plugins/wp-united/
    [b]WordPress Path[/b]           :     /home/a3359902/public_html/
    [b]phpBB Path[/b]               :
    [b]Active plugins[/b]           :     better-wp-security/better-wp-security.php, wp-united/wp-united.php
    [b]Current theme[/b]            :     Twenty Twelve
    [b]Allocated memory[/b]         :     32728M
    [b]Memory limit[/b]             :     256M
    [b]Locale[/b]                   :     en_US
    [b]integrateLogin[/b]           :     0
    [b]showHdrFtr[/b]               :     NONE
    [b]wpSimpleHdr[/b]              :     1
    [b]dtdSwitch[/b]                :     0
    [b]phpbbCensor[/b]              :     1
    [b]wpPageName[/b]               :     page.php
    [b]phpbbPadding[/b]             :     6-12-6-12
    [b]xposting[/b]                 :     0
    [b]phpbbSmilies[/b]             :     0
    [b]avatarsync[/b]               :     1
    [b]integcreatewp[/b]            :     1
    [b]integcreatephpbb[/b]         :     1
    [b]xpostautolink[/b]            :     0
    [b]xpostspam[/b]                :     all
    [b]xpostforce[/b]               :     -1
    [b]xposttype[/b]                :     excerpt
    [b]xpostprefix[/b]              :     [BLOG]
    [b]cssMagic[/b]                 :     1
    [b]templateVoodoo[/b]           :     1
    [b]useForumPage[/b]             :     1
  9. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    The first one should be pre-populated with the document root. But I am guessing that in your case this didn't happen.

    Anyway as long as the two boxes add up to the correct path you will be fine. You should notice when typing into the boxes that the path chosen is just the two boxes added together.

    Thanks for the get help info. I can see from that that your phpBB path is probably:
    /home/a3359902/public_html/phpBB . Put /home/a3359902/public_html/ in the first box and phpBB in the second one.

  10. Denim Mage
    Member
    Posted 1 year ago #

    I got a success message.

    It says my path is:

    /homea3359902public_htmlphpBB

  11. Denim Mage
    Member
    Posted 1 year ago #

    The path adder is still buggy, even if I did eventually get it working. Just pasting the correct URL into the input does not work properly.

  12. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    It's not a URL. It's a file path. What did you paste? Did the path below the path adder change automatically as you were typing? If not it might be a JavaScript error caused by another plugin... You could try with other plugins disabled.

  13. Denim Mage
    Member
    Posted 1 year ago #

    I meant pasting the path, not pasting the URL.

    The path below the adder does change automatically.

  14. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks. What was the bug? Was it not letting you connect even though that composite path below was incorrect?

  15. Denim Mage
    Member
    Posted 1 year ago #

    The bug is semantic. Instead of the yellow text on the connect page saying my path is /home/a3359902/public_html/phpBB, it says my path is /homea3359902public_htmlphpBB.

    However, I strongly suggest that you either make the two input boxes into one, or provide a little bit of descriptive text beside each to help people decide which parts of the file path go into which input box. Basically, I'm saying that even though the system seems to work, I don't believe it's as accessible as it should be.

    I also think you should point out somewhere that in order to make blog posts integrate into the forums, every kind of permission needs to be deliberately set-- group permissions, forum permissions, roles, access... It took me many hours of work to get posts and comments integrated properly. I suppose one might consider that it goes without saying, but phpBB works right out of the box, and WP-United doesn't; and I imagine it would confuse a great many users who don't mess with every permission setting on their board to learn how it works. I bet a lot of users would give up on WP-United for that reason. So if you think it's worth putting thought into, you might want to put in some documentation about what permissions and roles need to be set/created. It's just a thought.

  16. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Thanks. That's a bug... It shouldn't strip th directory separators. To be honest the boxes you are seeing are the fall-back method and won't be seen by the vast majority, but I take your point.

    For cross-posting you only need to ensure the user is integrated and has posting and cross-posting permissions. I agree this needs documentation... I need help with that.

  17. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the detailed report though :-)

  18. Denim Mage
    Member
    Posted 1 year ago #

    I might be willing to help with the documentation.

    Here's the thing about permissions though: all groups, forums, and roles in the forum administration panel have their own WP-United permissions-- which need to be set individually. This isn't ideal. I think that it should be that all forums, as well as the administrator and editor groups, automatically have WP-United cross-posting permissions. That way all one has to do to enable or disable cross-posting is to change the forum that posts are cross-posted to (or select "disabled") in the WP backend. That drop-down option already exists.

    There should also be a quick button to give or remove all non-guest, non-read-only, and non-bot groups and roles permissions to cross-comment, instead of always having to set all permissions individually. I'm trying to think of other ways to make this easier...

  19. Denim Mage
    Member
    Posted 1 year ago #

    I just updated the previous post, so if you've already read it, you might want to look at it again.

  20. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks...

    That's not how phpBB permissions work though.

    A user could have permissions assigned by their role or any of the groups of which they are a member (or, you can assign permissions to individual members). If ANY of these groups or role have a "Yes" permission, then that user will receive that permission.

    If ANY of those groups or roles has a "Never" permission, then that will override the "Yes" to become a "No".

    So you need to set it for the member OR the group OR the role, not all.

    This is the same as opening any forum to a group, or locking one down.

    WP-United just uses the native phpBB permissions system, and doesn't impose any additional requirements on top of that.

    phpBB MODs usually aren't allowed to turn on permissions by default -- people are encouraged to review and amend the permissions themselves. I will certainly do what I can to make it clearer though.

  21. Denim Mage
    Member
    Posted 1 year ago #

    It wasn't that easy for me. But I don't remember everything about what I was doing first, so I don't know what to tell you.

  22. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    I'm going to mark this as resolved, but feel free to open a new thread if you have any other issues.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.