WordPress.org

Ready to get started?Download WordPress

Forums

No input file specified - WordPress adding an extra "/" (7 posts)

  1. omnicommie
    Member
    Posted 7 years ago #

    I did a bit of searching for this topic and saw many instances and solutions. I wasn't sure which one was the best for me.

    I just switched to a new host from my own (I was running OS X Server 10.4), and I have my site up with Dreamhost. It seems that internal links (individual posts, pages) do not work. Whenever I try to navigate to them via link it seems an extra "/" is added to whatever the loaction I want is. When removed, the links all work fine.

    I tried looking in the configuration, but I found nothing to change (that i could see.)

    Dan

  2. tpurl
    Member
    Posted 7 years ago #

    I'm also having a similar issue. I just upgraded from 2.1 to 2.1.2, and when I access http://mysite/index.php/, I get your error. The error, however, doesn't appear when I visit http://mysite/index.php.

    This is a problem since the header link on my site points to the "ending /" version of my home page, not the version that works.

    I'm using Apache. Anyone have any ideas as to how to fix this?

    Thanks!

    Tom Purl

  3. thelazygeisha
    Member
    Posted 7 years ago #

    I would check your .htaccess file to make sure it's properly formatted for permalinks. This sounds like a permalink issue to me.

  4. tpurl
    Member
    Posted 7 years ago #

    Thanks a lot thelazygeisha! I'll check that out soon.

  5. carnoy
    Member
    Posted 7 years ago #

    I got the same pb and tried to check for the .htaccess.
    But in the basic installation as now there is no .htaccess file.
    Does it means I should prepare a .htaccess file , but what about settings ?
    Many thanks to anybody who can help.

  6. Chris_K
    Member
    Posted 7 years ago #

    If your Permalinks are set to default, there need not be an .htaccess file.

  7. carnoy
    Member
    Posted 7 years ago #

    They are set to défault.
    I found the reason of the extra "/" which give the "No input file specified" error msg.
    I set the WordPress adress as "http://www.mysite.com/index.php" and the blog adress as "http://www.mysite.com/index.php".
    The blog adress should be (default) only "http://www.mysite.com"
    The best is to leave blog adress in blank if it is not special url.
    Therefore there is no more error msg.

Topic Closed

This topic has been closed to new replies.

About this Topic