WordPress.org

Ready to get started?Download WordPress

Forums

No Input File Specified urgent help needed (5 posts)

  1. spotcream
    Member
    Posted 4 years ago #

    I needed to activate php5 via my cpanel account so i logged in went into the php version settings and changed it from 4 to php5.

    I went to my site and all that is displayed is no input file specified.

    I have searched around a bit but have come up with nothing that really works I dont seem to be able to find a php.ini file that some people keep mentioning.

    Here is my .htaccess file from inside the main root www.

    Options -MultiViews
    # BEGIN W3 Total Cache
    <IfModule mod_setenvif.c>
    SetEnvIfNoCase Accept-Encoding (gzip|deflate) APPEND_EXT=.$1
    </IfModule>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_URI} \/$
    RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp-(app|cron|login|register).php|wp-.*\.php|index\.php) [OR]
    RewriteCond %{REQUEST_URI} (wp-comments-popup\.php|wp-links-opml\.php|wp-locations\.php) [NC]
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} =""
    RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|wordpress_\[a-f0-9\]\+|wordpress_logged_in) [NC]
    RewriteCond %{HTTP_USER_AGENT} !(bot|ia_archive|slurp|crawl|spider) [NC]
    RewriteCond /home/spot/public_html/wp-content/w3tc/pgcache/$1/_default_.html%{ENV:APPEND_EXT} -f
    RewriteRule (.*) wp-content/w3tc/pgcache/$1/_default_.html%{ENV:APPEND_EXT} [L]
    </IfModule>
    # END W3 Total Cache

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName spotcream.com
    AuthUserFile /home/PRIVATE/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/PRIVATE/public_html/_vti_pvt/service.grp

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_URI} ^/system.*
    RewriteRule ^(.*)$ index.php?/$1 [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.+)$ index.php?/$1 [L]

    </IfModule>

    # END WordPress
    # Add Expires headers
    # ExpiresActive On
    # ExpiresDefault \"access plus 5 days\"
    # ETags
    FileETag none
    # WP-AVOID-SLOW END

  2. Samuel B
    moderator
    Posted 4 years ago #

    try adding this to top of .htaccess

    AddHandler x-httpd-php5 .php
    AddHandler x-httpd-php .php4
  3. spotcream
    Member
    Posted 4 years ago #

    Your a genius lol ok it is working for the admin but not for the main website.

    i can access the admin but clicking on any links brings up the fire fox download box.

    just pasting AddHandler x-httpd-php5 .php
    AddHandler x-httpd-php .php4

    makes it happen with php4 or without

  4. spotcream
    Member
    Posted 4 years ago #

    Ignore what i just said it wasnt working for the admin it was my browser cache

  5. spotcream
    Member
    Posted 4 years ago #

    ok i searched around some more and came across this

    <FilesMatch "\.(php|inc|phtml)$">
    AddHandler application/x-httpd-php .inc .php .phtml
    AddHandler application/x-httpd-php-source .php5
    </FilesMatch>

    I pasted it into my .htaccess file and the site now appears.

    In the ADMIN all the plugins still say im using php4 no matter what i do ie reinstall / delete them

Topic Closed

This topic has been closed to new replies.

About this Topic